TPS Driver: TPS Driver

TPS Driver 2.2.0
TPS Driver library for the Hercules Microcontrollers
  • Main Page
  • Related Pages
  • Modules
  • Data Structures
  • Files
TPS Driver

Introduction

The TPS65381-Q1 device is a multi-rail power supply designed to supply microcontrollers in safety-critical applications, such as those found in automotive applications. The device supports Texas Instruments HerculesTM TMS570LS series and RM4x series 16/32-bit RISC flash Safety MCU and other microcontrollers with dual-core lockstep (LS) or loosely-coupled architectures (LC). The TPS6538x driver library is a software library for the Hercules Safety MCU which provides driver level API to interface the Hercules MCU with TPS6538x power supply chip and make use of the various TPS6538x device features such as voltage monitoring, watchdog monitoring, error monitoring etc.

The TPS65381-Q1 device integrates multiple supply rails to power the MCU, CAN, or FlexRay, and an external sensor. An asynchronous-buck switch-mode power-supply converter with an internal FET converts the input battery voltage to a 6-V pre-regulator output. This 6 V is supplies the other regulators. Furthermore, the device supports wake-up from IGNITION or wake-up from the CAN transceiver.

The library provides extensive API which can be effectively used to configure and use the TPS device for the end application.

The library will be released as Compliance Support Package (CSP) which will help in product certification when using this library in customer projects related to functional safety associated with ISO26262 and IEC61508 standards.

TPS Driver Usage in End Application

The TPS library provides driver level API to interface the Hercules device with TPS and make use of the various TPS device features such as voltage monitoring, watchdog monitoring, error monitoring etc. The TPS library will serve as special driver library which helps the application to interface the TPS56381 PMIC with Hercules microcontroller. The library will be released as an additional package along with the SafeTI™ Diagnostic Library release package which will be released as CSP and will help the end customers in the ISO26262 certification of the product. Below block diagram shows the usage of the TPS driver (library) in the end application.

TPS device features

The below block diagram of the TPS device provides fine details about the features of the TPS device [1].

The TPS library provides extensive API to use all the above mentioned features of the TPS device.

Interfacing TPS Device with the Hercules processors

The below figure shows an example of how the TPS device is interfaced with a Hercules processor [1].This gives an overview of various connections which has to be made to the TPS device from the Hercules processors. It shows the various peripherals and ports which are used for communicating with the TPS device.

System Requirements

Following sections outline the hardware & software requirements for using the TPS Driver

Software Requirements

  1. CCS 5.5 or newer version using Codegen tools version 5.1.6.
  2. HALCoGen 4.00.00 or newer version

Hardware Requirements

  1. TMS570LS3137 Hitex Safety Kit, RM48L952 Hitex Safety Kit, TMS570LS1227 Control Card, RM46 Control card.
  2. Library can be used across Hercules family of processors but has not been tested on platforms other than those mentioned above.

New in this Release

Following sections outline defects & enhancements resolved in this release

  1. This release is maintainance release for the TPS driver with bug fixes and MISRA violation fixes.

Fixed in this release

Please check the release notes for more information on this

Software Manifest

You Can find the Software Manifest for Diagnostic Library in the <Installation directory>="">.pdf file of your installation.

Include files necessary for using TPS Driver

The Tps_Driver.h should be included(#include "Tps_Driver.h") by the application to use the TPS Driver.

Generated on Fri Feb 6 2015 03:20:40 for TPS Driver by doxygen 1.8.7


TPS Driver: Configuration items

  • Related Pages
  • Modules
  • Data Structures
  • Files
Configuration items

Refer to configuration items for TPS Driver library for a list of configurable settings

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: References

  • Files
References
  1. Multi-Rail Power Supply for Microcontrollers in Safety-Critical Applications(TPS65381-Q1)
  2. Datasheets, TRM, Safety manuals for Hercules devices - http://www.ti.com/Hercules
  3. Interfacing TPS65381 With Hercules™ Microcontrollers - http://www.ti.com/lit/an/spna176/spna176.pdf
  4. HALCoGen - http://www.ti.com/tool/halcogen
  5. UniFlash - http://www.ti.com/tool/uniflash
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: TPS65381 Driver API

TPS65381 Driver API

Initialization API

API | Description
TPS_DriverInit | This is the Initialization API for TPS(This does not Initialize Watchdog for watchdog init refer to TPS_WatchdogInit)

Interfacing API for TPS

API | Description
TpsIf_GetRegister | Read TPS Register
TpsIf_GetRegisterBitField | Read TPS Register Bit Field(starting bit number of the bit field and the length of bit field serve as inputs to this API)
TpsIf_Init | Initialize TPS Interface
TpsIf_SetRegister | Set TPS Register
TpsIf_SetRegisterBitField | Set TPS Register bit field
TpsIf_SetRegisterBitFieldVerify | Set TPS Register bit field readback and verify
TpsIf_SetRegisterVerify | Set TPS Register readback and verify
TpsIf_SpiIFTestPwmlow | Test SPI Interface
TpsIf_TestCommandParityLogic | Test the command parity logic
TpsIf_TestWrongCommandLogic | Test wrong command logic

Watchdog related API for TPS

API | Description
TPS_WDSetTokenFDBCKValue | Set Watchdog timer(WDT) token FSM feedback configuration value
TPS_WDSetTokenSeedValue | Set Watchdog timer(WDT) token seed value
TPS_WatchdogInit | Initialized the watchdog module with user specified configuration
TPS_UpdateActiveWDToken | Update the current active token of the TPS WDT
TPS_ClearWatchdogFailureStatusFlag | Clear watchdog failure status flag
TPS_SetWatchdogMode | Set Watchdog configuration
TPS_ConfigureWatchdogReset | enable/disable watchdog reset
TPS_ConfigureWatchdogWindows | configure watchdog windows
TPS_GetWatchdogAnswerCount | The API provides watchdog answer count
TPS_GetWatchdogErrorType | The API provides failure status information of the watchdog
TPS_GetWatchdogFailCount | The API provides watchdog failure count information
TPS_GetWatchdogFailureStatus | The API provides watchdog failure count information
TPS_SendWdgResponse | API to send watchdog response to TPS

CRC related API for TPS

API | Description
TPS_CalculateCRC8 | Calculate the CRC 8 value of the Tps65381 configuration registers(stored as 64 bit data)
TPS_ConfigureSafetyCheckControl | sets the safety check control register flags
TPS_GetCRCErrorStatus | The API is used to get the error status of Configuration register CRC calculation and EEPROM CRC calculation
TPS_InitializeDatastringforCRCCaclcuation | The API initializes the 64 bit data string for 8 bit crc calculation
TPS_UpdateDatastringforCRCCaclcuation | The API updates the 64 bit data string for 8 bit crc calculation for specified register
TPS_UpdateRegisterSafetyCfgCRC | Update SAFETY_CFG_CRC register
TPS_StartEECRCCheck | The API starts EEPROM CRC check

Fault injection and Safety Diagnostic API

API | Description
TPS_CheckEnabledAMUXSignalLimits | Check Enabled AMUX signal limits(voltage limits)
TPS_ConfigureBISTatStartup | The API enables and disables BIST at startup
TPS_DisableMUXDiagnostic | Disable MUX diagnostics
TPS_EnableAMUXSignal | Enable particular AMUX signal(for Diagnostics)
TPS_EnableDMUXSignal | Enable particular DMUX signal(for Diagnostic)
TPS_FaultInjectCRC | Inject CRC fault
TPS_FaultInjectWD | Inject fault in watchdog
TPS_GetABISTTestStatus | The provides the ABIST test status
TPS_GetBISTRunningStatus | The API gets the built in selftest status
TPS_GetJnTempandCurrentLimitStatus | Provide status of junction temperature monitoring and current limit status
TPS_GetLBISTTestStatus | The API provides the LBIST test status
TPS_GetVMONStatus | Provide status of the Voltage monitoring by the TPS
TPS_GoToSafeState | e API moves the TPS device safe state(from Active mode)
TPS_ProtectConfigurationRegisters | LOCK/UNLOCK (protect) the configuration registers for writing
TPS_RegReadBackandCompare | Register read back and compare
TPS_StartBIST | The API starts the built in selftest ABIST/LBIST
TPS_TestErrorPinMonitoring | The API does the selftest of the error pin monitoring

Debug Support API

API | Description
TPS_SetMCUSoftwareDebugMode | Set TPS device configuration so to support MCU software debug
TPS_SendDebugText | The API is used flag the errors/debug messages for debug purposes
TPS_DebugInit | API to initialize the debug support in the TPS driver

Other Configuration and Status API

API | Description
TPS_ClearDeviceErrorCount | API clears the devices error count values in the TPS register SAFETY_ERR_STAT
TPS_ClearErrorPinFailureStatusFlag | he API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register
TPS_ConfigureErrorMonitoring | Set Error signal monitoring mode
TPS_ConfigureIgnintionPowerLatchControl | Set ignition power latch behavior
TPS_ConfigureNRESMonitoring | Configure NRES pin Monitoring
TPS_ConfigureSafeStateTimeout | Enable or disable the safe state timeout
TPS_ConfigureSafetyCheckControl | sets the safety check control register flags
TPS_ConfigureVDD5 | The API enables voltage source VDD5
TPS_ConfigureVSOUT1 | The API enables voltage source VSOUT1
TPS_ExitDiagnosticMode | Takes the necessary actions so as to exit DIAGNOSTIC mode and enter the active mode of TPS device operation
TPS_Get3_3Vor5VSupply | gets VDD3/VDD5 selection
TPS_GetCurrentTPSDeviceState | Get Current TPS device State
TPS_GetDEV_STATE | Provide information regarding TPS
TPS_GetDeviceErrorCount | API provides the device error count value in TPS
TPS_GetDeviceInformation | The API provides TPS device information
TPS_GetENDRVErrorStatus | The API provides Enable drive error status
TPS_GetErrorPinFailureStatusFlag | The API provides failure status information of the error pin of MCU
TPS_GetNRESErrorStatus | The API provides failure information of NRES pin(readback state of NRES PIN)
TPS_GetSPIErrorStatus | Provide device the error status of the previous SPI transmission
TPS_GetTPSDeviceConfiguration | Provide device confiuration(setting made in the DEV_CFG1 and DEV_CFG2 register)
TPS_SetPowerDownThreshhold | Set power down threshold value
TPS_SetSafeLockThreshhold | Set device ERROR COUNT threshold value
TPS_SetSafeStateTimoutDuration | Set Safe State time out duration
TPS_SetTPSDeviceConfigurationRegisters | The API helps in setting the device configuration register
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: Build

Build

Building the library

The TPS65381 Driver release includes a Code Composer Studio Eclipse project (in the build_TPSDriverLib folder) which can be built using the Code Composer Studio GUI or through the command line.

Separate project configurations are defined to select between a Big Endian (for TMS570 devices) and a Little Endian (for RM4 devices) variants debug/release build configuration. A particular configuration can be selected in the CCS project under <Right Click Project> -> Build Configurations. Depending on your Hercules MCU, you set a particular configuration active and work with it.

These configurations can be managed under <Right Click Project> -> Build Configurations -> Manage...

Prebuilt release mode libraries for the Hercules MCU devices are available in the libs folder.

Demo application

Board specific sample applications are bundled with the TPS65381 Driver to demonstrate the use of the driver APIs.

This is an example application which does not use any RTOS. This project relies on HALCoGen to provide the system initialization and application framework. The project can be imported using the File -> Import -> Existing CCS Eclipse Project and pointing it to the particular build folder in <Installation Directory>&lt;device+board> folder (depending on the board). This may then be built and run on the specified target board. The application cannot be run with the debugger connected(as already the TPS is initialized).Please follow the below steps to run the demo application

  • Flash the demo application and disconnect the Target.
  • Power Reset the board and connect to the Target again.

  • Pause the debugger and observe that the debugger halts at the last while loop in sys_main.c which confirms that all the tests of the TPS driver have been executed.

    You can enable the debug messages by using the configuration item macros for enabling the debug messages. To observe the debug messages which communicate the activity of the demo application you need to connect to the serial terminal of the board using an application like Teraterm or Putty and configure the appropriate baud rate (default configuration of serial port is 115200 baud,2 stop bits and no parity)

Separate HALCoGen projects have been created under the <Installation Directory>demo_app<device+board> folder. These projects can be accessed in HALCoGen under File -> Open -> Project and pointing it to the HALCoGen project file (*.hcg) of the corresponding device, available in that particular folder. This opens the HALCoGen project and user can now modify its configuration and update the HALCoGen files (for instance update the HALCoGen files to newer versions).

TPS65381 Driver functionality in Demo application

The Demo Application for the TPS driver tests the various API provided by the driver. The Testing is done in various phases.

  1. In the First phase - TEST_BASIC_SETTINGS - TPS is kept in diagnostic state.

    • TPS is initialized using the TPS_DriverInit.
    • TPS is set to MCU debug mode using TPS_SetMCUSoftwareDebugMode to stay in diagnostic state.
    • Verification of the current state of TPS is done.
    • AMUX/DMUX diagnostics is tested.
    • Interface tests are done so as to verify the TPS interface API.
    • CRC and Fault injection CRC tests are performed.
    • VMON status API and Error monitoring API are tested.

    The next phase is testing of the Watchdog functionality - TEST_WD_DIAGMODE

  2. In phase - TEST_WD_DIAGMODE(Testing of Watchdog in Diagnostic mode of TPS)

    • Watchdog servicing is tested.
    • Behavior of ENDRV pin is verified.
    • RTI module of the MCU is used so as to respond to TPS watchdog at appropriate times.

    The next phase is TEST_WDDIAG_ERRORS

  3. In Phase - TEST_WDDIAG_ERRORS(Testing of Watchdog errors in DIAGNOSTIC mode of TPS)
    • Various error scenarios of the watchdog are verified.
    • Fault injection watchdog API is verified.
    • Behavior of ENDRV is verified.

    • RTI module of the MCU is used so as to respond to TPS watchdog at appropriate times.

      Next phase is TEST_WD_ACTMODE(Testing of the watchdog servicing in the ACTIVE mode of TPS)

  4. In Phase - TEST_WD_ACTMODE
    • The diagnostic mode is exited.

    • It is verified that the TPS is is in ACTIVE MODE.

      All other operations or tests are similar to TEST_WDACT_ERRORS.The next state is TEST_WDACT_ERRORS.

  5. In the phase- TEST_WDACT_ERRORS(Testing of the watchdog errors in ACTIVE mode of the TPS)

    • The operations/tests performed are same as TEST_WDDIAG_ERRORS except that the tests are performed when the TPS is active mode.

      The next state is changed to TEST_WD_ACTMODE and this is the final state TPS watchdog is serviced with Watchodg answers at right time.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: Modules

Modules
Here is a list of all modules:
[detail level 12]
▼ Read commands for the various registers of the TPS
Write commands for the various registers of the TPS
▼ configuration items for TPS Driver library
SRAM Range defines
macros for enabling the debug messages
API used for handling CRC protection of configuration registers and EEPROM.
API used for handling BIST Runs in TPS.
API used for MUX Diagnostics.
API used for handling NRES monitoring and test.
API used for handling the TPS watchdog(external watchdog)
AMUX signal enumeration min and max values
DMUX signal enumeration min and max values
Macros for indicating the current TPS device state


TPS Driver: Read commands for the various registers of the TPS

Modules | Macros
Read commands for the various registers of the TPS

Modules

Write commands for the various registers of the TPS

Macros

#define | RD_COMMAND_NONE ((uint16)0x0000U)
#define | RD_WD_WIN2_CFG ((uint16)0x0500U)
#define | RD_DEV_ID ((uint16)0x0600U)
#define | RD_DEV_REV ((uint16)0x0C00U)
#define | RD_DEV_STAT ((uint16)0x1100U)
#define | RD_VMON_STAT_1 ((uint16)0x1200U)
#define | RD_SAFETY_STAT_1 ((uint16)0x2400U)
#define | RD_WD_WIN1_CFG ((uint16)0x2E00U)
#define | RD_SAFETY_ERR_CFG ((uint16)0x3000U)
#define | RD_WDT_TOKEN_VALUE ((uint16)0x3600U)
#define | RD_SAFETY_PWD_THR_CFG ((uint16)0x3900U)
#define | RD_SAFETY_FUNC_CFG ((uint16)0x3A00U)
#define | RD_SAFETY_BIST_CTRL ((uint16)0x3C00U)
#define | RD_SAFETY_CHECK_CTRL ((uint16)0x4400U)
#define | RD_DEV_CFG2 ((uint16)0x4800U)
#define | RD_WDT_STATUS ((uint16)0x4E00U)
#define | RD_SENS_CTRL ((uint16)0x5600U)
#define | RD_SAFETY_ERR_PWM_L ((uint16)0x5900U)
#define | RD_SAFETY_CFG_CRC ((uint16)0x5A00U)
#define | RD_WDT_TOKEN_FDBCK ((uint16)0x7800U)
#define | RD_SAFETY_STAT_3 ((uint16)0xA300U)
#define | RD_SAFETY_STAT_4 ((uint16)0xA500U)
#define | RD_VMON_STAT_2 ((uint16)0xA600U)
#define | RD_SAFETY_ERR_STAT ((uint16)0xAA00U)
#define | RD_DIAG_MUX_SEL ((uint16)0xAC00U)
#define | RD_DEV_CFG1 ((uint16)0xAF00U)
#define | RD_SAFETY_STAT_5 ((uint16)0xC000U)
#define | RD_SAFETY_STAT_2 ((uint16)0xC500U)
#define | RD_SAFETY_ERR_PWM_H ((uint16)0xD700U)
#define | RD_DIAG_CFG_CTRL ((uint16)0xDD00U)
#define | RD_WRONG_PARITY ((uint16)0x0D00U)
#define | RD_WRONG_COMMAND ((uint16)0x2C00U)

Detailed Description

Following macros are the Read commands for the various registers of the TPS

Macro Definition Documentation

#define RD_COMMAND_NONE ((uint16)0x0000U)

Alias for no read command

#define RD_DEV_CFG1 ((uint16)0xAF00U)

Alias for read config 1

#define RD_DEV_CFG2 ((uint16)0x4800U)

Alias for read config 2

#define RD_DEV_ID ((uint16)0x0600U)

Alias for read device identifier

#define RD_DEV_REV ((uint16)0x0C00U)

Alias for read device revision

#define RD_DEV_STAT ((uint16)0x1100U)

Alias for read device status

#define RD_DIAG_CFG_CTRL ((uint16)0xDD00U)

Alias for read diagnostic config control

#define RD_DIAG_MUX_SEL ((uint16)0xAC00U)

Alias for read diagnostic mux select

#define RD_SAFETY_BIST_CTRL ((uint16)0x3C00U)

Alias for read safety BIST control

#define RD_SAFETY_CFG_CRC ((uint16)0x5A00U)

Alias for read safety config crc

#define RD_SAFETY_CHECK_CTRL ((uint16)0x4400U)

Alias for read safety check control

#define RD_SAFETY_ERR_CFG ((uint16)0x3000U)

Alias for read safety error config

#define RD_SAFETY_ERR_PWM_H ((uint16)0xD700U)

Alias for read safety error pwm high

#define RD_SAFETY_ERR_PWM_L ((uint16)0x5900U)

Alias for read safety error pwm low

#define RD_SAFETY_ERR_STAT ((uint16)0xAA00U)

Alias for read safety error status

#define RD_SAFETY_FUNC_CFG ((uint16)0x3A00U)

Alias for read safety function config

#define RD_SAFETY_PWD_THR_CFG ((uint16)0x3900U)

Alias for read safety power down threshold config

#define RD_SAFETY_STAT_1 ((uint16)0x2400U)

Alias for read safety status 1

#define RD_SAFETY_STAT_2 ((uint16)0xC500U)

Alias for read safety status 2

#define RD_SAFETY_STAT_3 ((uint16)0xA300U)

Alias for read safety status 3

#define RD_SAFETY_STAT_4 ((uint16)0xA500U)

Alias for read safety status 4

#define RD_SAFETY_STAT_5 ((uint16)0xC000U)

Alias for read safety status 5

#define RD_SENS_CTRL ((uint16)0x5600U)

Alias for read sense control

#define RD_VMON_STAT_1 ((uint16)0x1200U)

Alias for read voltage monitor status 1

#define RD_VMON_STAT_2 ((uint16)0xA600U)

Alias for read voltage monitor status 2

#define RD_WD_WIN1_CFG ((uint16)0x2E00U)

Alias for read watchdog open window config

#define RD_WD_WIN2_CFG ((uint16)0x0500U)

Alias for read watchdog close window config

#define RD_WDT_STATUS ((uint16)0x4E00U)

Alias for read watchdog status

#define RD_WDT_TOKEN_FDBCK ((uint16)0x7800U)

Alias for read watchdog token feedback

#define RD_WDT_TOKEN_VALUE ((uint16)0x3600U)

Alias for read watchdog token

#define RD_WRONG_COMMAND ((uint16)0x2C00U)

InValid Command with correct parity bit

#define RD_WRONG_PARITY ((uint16)0x0D00U)

Valid Command with incorrect parity bit

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: Write commands for the various registers of the TPS

Macros | Typedefs | Variables
Write commands for the various registers of the TPS
Read commands for the various registers of the TPS

Macros

#define | WR_COMMAND_NONE ((uint16)0x0000U)
#define | WR_WD_WIN2_CFG ((uint16)0x0900U)
#define | WR_SAFETY_FUNC_CFG ((uint16)0x3500U)
#define | WR_SAFETY_CFG_CRC ((uint16)0x6300U)
#define | WR_WDT_TOKEN_FDBCK ((uint16)0x7700U)
#define | WR_SENS_CTRL ((uint16)0x7B00U)
#define | WR_CAN_STBY ((uint16)0x7D00U)
#define | WR_SAFETY_ERR_PWM_L ((uint16)0x7E00U)
#define | WR_SAFETY_CHECK_CTRL ((uint16)0x9300U)
#define | WR_DEV_CFG2 ((uint16)0x9500U)
#define | WR_SAFETY_PWD_THR_CFG ((uint16)0x9900U)
#define | WR_DIAG_MUX_SEL ((uint16)0xC900U)
#define | WR_SAFETY_BIST_CTRL ((uint16)0x9F00U)
#define | WR_SAFETY_ERR_STAT ((uint16)0xA900U)
#define | WR_DEV_CFG1 ((uint16)0xB700U)
#define | WR_SW_UNLOCK ((uint16)0xBB00U)
#define | WR_SW_LOCK ((uint16)0xBD00U)
#define | WR_DIAG_CFG_CTRL ((uint16)0xCC00U)
#define | WR_SAFETY_ERR_PWM_H ((uint16)0xD800U)
#define | WR_SAFETY_ERR_CFG ((uint16)0xDB00U)
#define | WR_WDT_ANSWER ((uint16)0xE100U)
#define | WR_WD_WIN1_CFG ((uint16)0xED00U)

Typedefs

typedef struct TpsIf_Command TpsIf_COMMAND_t
Tps Interface Instruction Type Definition. More...

Variables

uint16 | Read
uint16 | Write

Detailed Description

Following macros are the Write commands for the various registers of the TPS

Macro Definition Documentation

#define WR_CAN_STBY ((uint16)0x7D00U)

Alias for write CAN standby

#define WR_COMMAND_NONE ((uint16)0x0000U)

Alias for no write command

#define WR_DEV_CFG1 ((uint16)0xB700U)

Alias for write device config 1

#define WR_DEV_CFG2 ((uint16)0x9500U)

Alias for write device config 2

#define WR_DIAG_CFG_CTRL ((uint16)0xCC00U)

Alias for write diagnostic config control

#define WR_DIAG_MUX_SEL ((uint16)0xC900U)

Alias for write diagnostic mux select

#define WR_SAFETY_BIST_CTRL ((uint16)0x9F00U)

Alias for write safety BIST control

#define WR_SAFETY_CFG_CRC ((uint16)0x6300U)

Alias for write safe config crc

#define WR_SAFETY_CHECK_CTRL ((uint16)0x9300U)

Alias for write safety check control

#define WR_SAFETY_ERR_CFG ((uint16)0xDB00U)

Alias for write safety error config

#define WR_SAFETY_ERR_PWM_H ((uint16)0xD800U)

Alias for write safety error pwm high

#define WR_SAFETY_ERR_PWM_L ((uint16)0x7E00U)

Alias for write safety error pwm low

#define WR_SAFETY_ERR_STAT ((uint16)0xA900U)

Alias for write safety error status

#define WR_SAFETY_FUNC_CFG ((uint16)0x3500U)

Alias for write safety function config

#define WR_SAFETY_PWD_THR_CFG ((uint16)0x9900U)

Alias for write safety power down threshold config

#define WR_SENS_CTRL ((uint16)0x7B00U)

Alias for write sense control

#define WR_SW_LOCK ((uint16)0xBD00U)

Alias for write SW lock

#define WR_SW_UNLOCK ((uint16)0xBB00U)

Alias for write SW unlock

#define WR_WD_WIN1_CFG ((uint16)0xED00U)

Alias for write open window config

#define WR_WD_WIN2_CFG ((uint16)0x0900U)

Alias for write close window config

#define WR_WDT_ANSWER ((uint16)0xE100U)

Alias for write wdg answer

#define WR_WDT_TOKEN_FDBCK ((uint16)0x7700U)

Alias for write wdg token feedback

Typedef Documentation

TpsIf_COMMAND_t

Tps Interface Instruction Type Definition.

This type is used to access a Tps Instructions.

Variable Documentation

uint16 Read

Read Command for the register

uint16 Write

Write command for the register

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: configuration items for TPS Driver library

Modules
configuration items for TPS Driver library

Modules

SRAM Range defines
macros for enabling the debug messages

Detailed Description

configuration items for TPS Driver library

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: SRAM Range defines

Macros
SRAM Range defines
configuration items for TPS Driver library

Macros

#define | SRAM_START ((uint32)0x08000000U)
#define | SRAM_END ((uint32)0x0803FFFFU)

Detailed Description

Following macros are used to define the range of TCM RAM

Macro Definition Documentation

#define SRAM_END ((uint32)0x0803FFFFU)

End address of TCM SRAM

#define SRAM_START ((uint32)0x08000000U)

Start address of TCM SRAM

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: macros for enabling the debug messages

Macros
macros for enabling the debug messages
configuration items for TPS Driver library

Macros

#define | DEBUG_ENABLE 1U
#define | ERROR_ENABLE 0U

Detailed Description

Following macros are used to enable/disable debug information from TPS

Macro Definition Documentation

#define DEBUG_ENABLE 1U

enable/disable the debug messages from TPS

#define ERROR_ENABLE 0U

enable/disable the error messages from TPS

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: API used for handling CRC protection of configuration registers and EEPROM.

Functions
API used for handling CRC protection of configuration registers and EEPROM.

Functions

boolean | TPS_ConfigureSafetyCheckControl (TPS_SafetyCheckControl safety_check, boolean blstate)
sets the safety check control register flags. More...
boolean | TPS_StartEECRCCheck (void)
The API starts EEPROM CRC check. More...
boolean | TPS_InitializeDatastringforCRCCaclcuation (uint32 u32DataforCRC[2])
The API initializes the 64 bit data string for 8 bit crc calculation. More...
boolean | TPS_CalculateCRC8 (uint32 u32DataforCRC[2], uint8 *u8crc_value)
Calculate the CRC 8 value of the Tps65381 configuration registers(stored as 64 bit data) More...
boolean | TPS_GetCRCErrorStatus (TPS_CRCErrorStatus *crc_error_status)
The API is used to get the error status of Configuration register CRC calculation and EEPROM CRC calculation. More...
boolean | TPS_GetEECRCCheckRunningStatus (TPS_TestRunningStatus *runningstatus)
The API gets the EE CRC Check running status. More...
boolean | TPS_FaultInjectCRC (void)
Inject CRC fault. More...
boolean | TPS_UpdateRegisterSafetyCfgCRC (uint8 u8safetycfgcrc)
Update SAFETY_CFG_CRC register. More...

Detailed Description

CRC support API

Function Documentation

boolean TPS_CalculateCRC8 | ( | uint32 | u32DataforCRC[2],
 |  | uint8 * | u8crc_value
 | ) |  |

Calculate the CRC 8 value of the Tps65381 configuration registers(stored as 64 bit data)

Description:
The API Calculates the CRC 8 value for the 64 bit data.This can be used for calculation of the CRC for the device configuration registers of the TPS device
Parameters
[in] | *u32DataforCRC | pointer to the 64 bit data for which the CRC 8 has to be calculated.
[out] | *u8crc_value | pointer to the calculated crc8 value.
Returns
TRUE : if crc value is calculated. FALSE: if the execution of the API failed(entry condition and parameter check failed)

Example Usage:

uint32 u32dataforcrc[2] = {0U,0U};
uint8 u8CRC8;
TPS_CalculateCRC8(u32dataforcrc,&u8CRC8);
Entry Mode:
TPS in Diagnostic state(This is used normally called after
data string for the crc calcuation has been initialized
by calling TPS_InitializeDatastringforCRCCaclcuation
or TPS_UpdateDatastringforCRCCaclcuation.
Exit Mode:
TPS in Diagnostic/Active state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_ConfigureSafetyCheckControl | ( | TPS_SafetyCheckControl | safety_check,
 |  | boolean | blstate
 | ) |  |

sets the safety check control register flags.

Description:
Write to the various flags of the safety check control register to enable or disable a particular safety mechanism.
Parameters
[in] | safety_check | The Safety Check parameter(a flag in safety check control register) to be enabled of disabled.
[in] | blstate | Enable or disable the safety check control flag.
Returns
TRUE : no errors. FALSE: Errors in execution.

Example Usage:

TPS_ConfigureSafetyCheckControl(CFG_CRC, FALSE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_FaultInjectCRC ( void )

Inject CRC fault.

Description:
The API initializes the SAFETY_CFG_CRC with incorrect CRC and.
enables CRC check so as to generate a CRC error.Application
should make sure that it is reading the error status after
injecting the fault(2.1 us is needed for completion of the crc
check.If the status of the crc error is not read the behavior
of the following EEPROM CRC check will be erraneous please
check section 4.9.15(page no 48) of the data sheet for more
information.
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_FaultInjectCRC();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_GetCRCErrorStatus ( TPS_CRCErrorStatus * crc_error_status )

The API is used to get the error status of Configuration register CRC calculation and EEPROM CRC calculation.

Description:
The API updates the passed structure with CRC error status for the EEPROM and Config register CRC calculation
Parameters
[out] *crc_error_status The structure will be updated with the CRC error status for the EEPROM and Configuration registers
blCfgCRCError if TRUE there was an error in cofig register CRC calculation.
blEECRCError if TRUE there was an error in the EE CRC calculation
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_CRCErrorStatus crc_error_status;
TPS_GetCRCErrorStatus(&crc_error_status);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_GetEECRCCheckRunningStatus ( TPS_TestRunningStatus * runningstatus )

The API gets the EE CRC Check running status.

Description:
The API gets the whether the EEPROM CRC check on the TPS device is running or over.
Parameters
[out] runningstatus the api updates the EE CRC Check running running status in this variable.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_TestRunningStatus runningstatus;
TPS_GetEECRCCheckRunningStatus(&runningstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_InitializeDatastringforCRCCaclcuation ( uint32 u32DataforCRC[2] )

The API initializes the 64 bit data string for 8 bit crc calculation.

Description:
The API initializes the 64 bit data for crc.It updates the necessary fields in the 64 bit data with the
contents of the specific fields of the TPS configuration registers as specified in the section
Device Configuration Register Protection of the TPS65381 data sheet.
Parameters
[in] *u32DataforCRC pointer to the 64 bit data which has to be
initialized for the calculation of the 8 bit crc.The 64 bit
data is stored in uint32 array of 2 elements.Application
should make sure that the array passed is of correct size.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint32 u32dataforcrc[2] = {0U,0U};
TPS_InitializeDatastringforCRCCaclcuation(u32dataforcrc);
Entry Mode:
TPS in Diagnostic state(called after setting up all the
necessary parameters for TPS)
Exit Mode:
TPS in Diagnostic/Active state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_StartEECRCCheck ( void )

The API starts EEPROM CRC check.

Description:
The API sets the EE_CRC_CHK in the SAFETY_BIST_CTRL register so as to trigger the built in self test.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_StartEECRCCheck();
Entry Mode:
TPS in Diagnostic/Active state
Exit Mode:
TPS in Diagnostic/Active state
See also:
API used for handling CRC protection of configuration registers and EEPROM.
boolean TPS_UpdateRegisterSafetyCfgCRC ( uint8 u8safetycfgcrc )

Update SAFETY_CFG_CRC register.

Description:
The API writes the user provide value to the register
SAFETY_CFG_CRC
Parameters
[in] u8safetycfgcrc value to be written to the SAFETY_CFG_CRC register
Returns
TRUE : no errors. FALSE: errors in execution

Example Usage:

//u8safetycfgcrc contains the calculated CRC8 using the crc calculation routines.
TPS_UpdateRegisterSafetyCfgCRC(u8safetycfgcrc);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: API used for handling BIST Runs in TPS.

Functions
API used for handling BIST Runs in TPS.

Functions

boolean | TPS_ConfigureBISTatStartup (boolean blbist_at_startup)
The API enables and disables BIST at startup. More...
boolean | TPS_StartBIST (TPS_BistTypes bist)
The API starts the built in selftest ABIST/LBIST. More...
boolean | TPS_GetBISTRunningStatus (TPS_BistTypes bist_type, TPS_TestRunningStatus *runningstatus)
The API gets the built in selftest running status. More...
boolean | TPS_GetABISTTestStatus (TPS_ABIST_Result *test_status)
The provides the ABIST test status. More...
boolean | TPS_GetLBISTTestStatus (TPS_Test_Result *LBIST_Test_Result)
The API provides the LBIST test status. More...

Detailed Description

BIST support API

Function Documentation

boolean TPS_ConfigureBISTatStartup ( boolean blbist_at_startup )

The API enables and disables BIST at startup.

Description:
The API sets the flags of the registers SAFETY_BIST_CTRL so as to
enable or disable the BIST at startup.
Parameters
[in] blbist_at_startup TRUE:BIST at startup is enabled.
FALSE:BIST at startup is disabled.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureBISTatStartup(TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling BIST Runs in TPS.
boolean TPS_GetABISTTestStatus ( TPS_ABIST_Result * test_status )

The provides the ABIST test status.

Description:
The API check if the ABIST is over and returns the ABIST Test status.It returns overall
ABIST test status.It also provides the status of LOCLK and Under and Over voltage test status.
Parameters
[out] test_status Structure which holds the ABIST test status
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ABIST_Result teststatus;
TPS_GetABISTTestStatus(&teststatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling BIST Runs in TPS.
boolean TPS_GetBISTRunningStatus | ( | TPS_BistTypes | bist_type,
 |  | TPS_TestRunningStatus * | runningstatus
 | ) |  |

The API gets the built in selftest running status.

Description:
The API gets the status of the built in selftest which is running
Parameters
[in] | bist_type | Built in selftest to be started.
[out] | runningstatus | the api updates the BIST running status in this variable.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_TestRunningStatus runninstatus;
TPS_GetBISTRunningStatus(ABIST,&runninstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling BIST Runs in TPS.
boolean TPS_GetLBISTTestStatus ( TPS_Test_Result * LBIST_Test_Result )

The API provides the LBIST test status.

Description:
The API check if the LBIST is over and returns the LBIST Test status.
Parameters
[out] LBIST_Test_Result TEST_PASS if the LBIST has passed.
TEST_FAIL if LBIST has failed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result testresult;
TPS_GetLBISTTestStatus(&testresult);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling BIST Runs in TPS.
boolean TPS_StartBIST ( TPS_BistTypes bist )

The API starts the built in selftest ABIST/LBIST.

Description:
The API sets the flags of the registers SAFETY_BIST_CTRL so as to start the
LBIST or ABIST.
Parameters
[in] bist Built in selftest to be started.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//Start ABIST
TPS_StartBIST(ABIST)
Entry Mode:
TPS in Diagnostic/Active state
Exit Mode:
TPS in Diagnostic/Active state
See also:
API used for handling BIST Runs in TPS.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: API used for MUX Diagnostics.

Functions
API used for MUX Diagnostics.

Functions

boolean | TPS_EnableAMUXSignal (TPS_AMUXSignals AMUXSignal)
Enable particular AMUX signal. More...
boolean | TPS_DisableMUXDiagnostic (void)
Disable MUX diagnostics. More...
boolean | TPS_CheckEnabledAMUXSignalLimits (TPS_Test_Result *Voltage_limit_test)
Check Enabled AMUX signal limits. More...
boolean | TPS_EnableDMUXSignal (TPS_DMUXSignals DMUXSignal)
Enable particular DMUX signal. More...

Detailed Description

MUX Diagnostics support API

Function Documentation

boolean TPS_CheckEnabledAMUXSignalLimits ( TPS_Test_Result * Voltage_limit_test )

Check Enabled AMUX signal limits.

Description:
The user selected AMUX signal limits are compared against the initialized limits(application).
Parameters
[out] Voltage_limit_test TEST_PASS if voltage limit test has passed.
TEST_FAIL if voltage limit test has failed.
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_Test_Result voltage_limit_test;
TPS_CheckEnabledAMUXSignalLimits(&voltage_limit_test);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for MUX Diagnostics.
boolean TPS_DisableMUXDiagnostic ( void )

Disable MUX diagnostics.

Description:
Any active MUX diagnostics is disabled and the output on the DIAG_OUT pin will be invalid.
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_DisableMUXDiagnostic();
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for MUX Diagnostics.
boolean TPS_EnableAMUXSignal ( TPS_AMUXSignals AMUXSignal )

Enable particular AMUX signal.

Description:
The user selected AMUX signal is enabled and will be available on the DIAG_OUT pin.
Parameters
[in] AMUXSignal AMUX signal to be enabled.
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_EnableAMUXSignal(VDD5);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for MUX Diagnostics.
boolean TPS_EnableDMUXSignal ( TPS_DMUXSignals DMUXSignal )

Enable particular DMUX signal.

Description:
The user selected DMUX signal is enabled and will be available on the DIAG_OUT pin.
Please refer to table Table 4-4 to 4-7 of the data sheet for more information.

Note: DMUX signals of GROUP 5 are not available for diagnostics

Parameters
[in] DMUXSignal : DMUX signal to be enabled.
Note: The signals reserved for production test and reserved logic cannot be used(as parameter for DMUXSignal)
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_EnableDMUXSignal(SPI_NCS);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for MUX Diagnostics.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: API used for handling NRES monitoring and test.

Functions
API used for handling NRES monitoring and test.

Functions

boolean | TPS_ConfigureNRESMonitoring (boolean blNRES_Monitoring)
Configure NRES pin Monitoring. More...
boolean | TPS_GetNRESErrorStatus (boolean *blNRESError)
The API provides failure information of NRES pin(readback state of NRES PIN). More...

Detailed Description

NRES Monitoring support API

Function Documentation

boolean TPS_ConfigureNRESMonitoring ( boolean blNRES_Monitoring )

Configure NRES pin Monitoring.

Description:
Disables/Enables the NRES ping(EXTERNAL MCCU RESET Pin) monitoring.
Parameters
[in] blNRES_Monitoring TRUE: NRES monitoring is enabled and
NRES ERROR will cause the TPS transition to the safe state.
FALSE: NRES monitoring is disabled.
Returns
TRUE: no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureNRESMonitoring(TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling NRES monitoring and test.
boolean TPS_GetNRESErrorStatus ( boolean * blNRESError )

The API provides failure information of NRES pin(readback state of NRES PIN).

Description:
The API provides status or Reset Input status (readback state of NRES PIN).
Parameters
[in] *blNRESError if TRUE the NRES_ERR has occured the readback status and current status of the NRES pin are not correct
if False NRES error readback status and current status of the NRES pin are same.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blNRESErrstatus;
TPS_GetNRESErrorStatus(&blNRESErrstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling NRES monitoring and test.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: API used for handling the TPS watchdog(external watchdog)

Functions
API used for handling the TPS watchdog(external watchdog)

Functions

boolean | TPS_WatchdogInit (const TPS_WatchdoConfiguration *const watchdogconfig)
API to set up and initialize TPS watchdog. More...
boolean | TPS_SetWatchdogMode (TPS_WatchdogMode watchdogmode)
Set Watchdog configuration. More...
boolean | TPS_ConfigureWatchdogWindows (TPS_WatchdogWindows watchdog_windows, uint8 u8windowtime_scaler)
configure watchdog windows. More...
boolean | TPS_ConfigureWatchdogReset (boolean blreset_enable)
enable/disable watchdog reset More...
boolean | TPS_UpdateActiveWDToken (void)
Update active Watchdog Token. More...
boolean | TPS_SendWdgResponse (TPS_WDResponse wd_response)
API to send watchdog response to TPS. More...
boolean | TPS_GetWatchdogFailureStatus (boolean *blFailureStatus)
The API provides watchdog failure count information. More...
boolean | TPS_ClearWatchdogFailureStatusFlag (void)
The API clears the watchdog fail status bit in the register SAFETY_ERR_STAT TPS register. More...
boolean | TPS_GetWatchdogAnswerCount (uint8 *u8AnswerCount)
The API provides watchdog answer count. More...
boolean | TPS_GetWatchdogErrorType (TPS_WatchdogErrorStatus *WDErrorStatus)
The API provides failure status information of the watchdog. More...
boolean | TPS_GetWatchdogFailCount (uint8 *u8watchdog_fail_count)
The API provides watchdog failure count information. More...
boolean | TPS_WDSetTokenSeedValue (uint8 u8TokenSeed)
Set Token Seed value for the watchdog. More...
boolean | TPS_WDSetTokenFDBCKValue (uint8 u8TokenFDBCK)
Set Token FeedBack value for the watchdog. More...
boolean | TPS_FaultInjectWD (TPS_WDFaultType WDFault)
Inject fault in watchdog. More...

Detailed Description

Watchdog support API

Function Documentation

boolean TPS_ClearWatchdogFailureStatusFlag ( void )

The API clears the watchdog fail status bit in the register SAFETY_ERR_STAT TPS register.

Description:
The API clears the watchdog fail status bit in the register SAFETY_ERR_STAT TPS register.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ClearWatchdogFailureStatusFlag();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_ConfigureWatchdogReset ( boolean blreset_enable )

enable/disable watchdog reset

Description:
enables or disable the watchdog reset.Should be used during the configuration of the Watchdhog. Note: if watcdog reset is enabled then on reaching watcdog fail count of 7 the TPS device will move to reset state reset resetting the MCU
Parameters
[in] blreset_enable parameter to enable/disable the watchdog reset.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureWatchdogReset(TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_ConfigureWatchdogWindows | ( | TPS_WatchdogWindows | watchdog_windows,
 |  | uint8 | u8windowtime_scaler
 | ) |  |

configure watchdog windows.

Description:
sets the scaling values which decide the watchdog CLOSE and OPEN window duration. Note: calling of this API immediately starts new watchdog sequence starting with close window and applications should start serving the watcdog appropriately
Parameters
[in] watchdog_windows OPEN or CLOSE window to be configured.
[in] u8windowtime_scaler scaler value which has to be configured
to WIN1/WIN2 registers which decides the OPEN/CLOSE window. Note: Watchdog open window time scaler(range 0 - 0x7F).minimum open window duration is .55ms maximum is 70.4ms Note: Watchdog close window time scaler(range 0 - 01F).minimum open window duration is .55ms maximum is 17.6ms
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureWatchdogWindows(OPEN_WINDOW,
(uint8) (40 / 0.55 - 1))
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_FaultInjectWD ( TPS_WDFaultType WDFault )

Inject fault in watchdog.

Description:
The API injects fault in the watchdog.The fault inject mode
such as BAD Answer are supported by the API.When called by
application API sends a wrong answer to the QANDA watchdog in
in the TPS device.The API can be used by applications only when
watchdog is configured in QANDA mode.
Parameters
[in] WDFault watchdog fault to be injected.
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_FaultInjectWD(BAD_ANSWER);
Entry Mode:
TPS in Diagnostic/Active state.
Exit Mode:
TPS in Diagnostic/Active state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_GetWatchdogAnswerCount ( uint8 * u8AnswerCount )

The API provides watchdog answer count.

Description:
The API provides the number of answers received
for the current active watchdog window.
Parameters
[in] *u8AnswerCount answer count indicating the no of answers
Received by the TPS device till now for the current
window.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8wdasnwercount;
TPS_GetWatchdogAnswerCount(&u8wdasnwercount);
Entry Mode:
TPS in Diagnostic/Active state
Exit Mode:
TPS in Diagnostic/Active state
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_GetWatchdogErrorType ( TPS_WatchdogErrorStatus * WDErrorStatus )

The API provides failure status information of the watchdog.

Description:
The API provides failure status information of the watchdog.
Parameters
[in] *WDErrorStatus structure which stores the information regarding the
various watchdog failures.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_WatchdogErrorStatus WDErrorStatus;
TPS_GetWatchdogErrorType(&WDErrorStatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_GetWatchdogFailCount ( uint8 * u8watchdog_fail_count )

The API provides watchdog failure count information.

Description:
The API provides watchdog failure count information.
Parameters
[in] *u8watchdog_fail_count watchdog fail count
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8wdfailcnt;
TPS_GetWatchdogFailCount(u8wdfailcnt);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_GetWatchdogFailureStatus ( boolean * blFailureStatus )

The API provides watchdog failure count information.

Description:
The API provides failure status information of the watchdog.
Parameters
[in] *blFailureStatus if TRUE the watchdog failure has ocurred if False no watchdog failure
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blWDFailureStatus;
TPS_GetWatchdogFailureStatus(&blWDFailureStatus)
See also:
API used for handling the TPS watchdog(external watchdog)
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_SendWdgResponse ( TPS_WDResponse wd_response )

API to send watchdog response to TPS.

Description:
The API sends the requested watchdog response to the TPS device
The response sent is based on the currently active token.At the
start of every watchdog window API TPS_UpdateActiveWDToken has
to be called by the application so as update the global
variable(active token) with the currently active token in
the TPS Device.
Parameters
[in] wd_response WD_TOKEN_RESP0 close window response
WD_TOKEN_RESP1 open window response
WD_TOKEN_RESP2 open window response
WD_TOKEN_RESP3 open window response
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SendWdgResponse(WD_TOKEN_RESP0);
Entry Mode:
TPS in Diagnostic/Active state
Exit Mode:
TPS in Diagnostic/Active state
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_SetWatchdogMode ( TPS_WatchdogMode watchdogmode )

Set Watchdog configuration.

Description:
Sets the watchdog configuration mode to either Q&A mode or the WDTI mode.

Note: Configuring watchdog in the WDTI mode will disable the error pin monitoring

Parameters
[in] watchdog_configuration parameter type of watchdog to be configured(Q&A or WDTI).
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//watchdog mode can be either QANDA_MODE or it can be WDTI mode
TPS_SetWatchdogMode(QANDA_MODE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_UpdateActiveWDToken ( void )

Update active Watchdog Token.

Description:
Updates the global variable which holds the current token
value with currently active token in the TPS device.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_UpdateActiveWDToken();
Entry Mode:
TPS in Diagnostic/Active state
Exit Mode:
TPS in Diagnostic/Active state
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_WatchdogInit ( const TPS_WatchdoConfiguration *const watchdogconfig )

API to set up and initialize TPS watchdog.

Description:
The API can be used to set up all the required parameters for the configuring the TPS watchdog.

Note: calling of this API immediately starts new watchdog sequence starting with close window and applications should start serving the watcdog appropriately Note: if watcdog reset is enabled then on reaching watcdog fail count of 7 the TPS device will move to reset state reset resetting the MCU

Parameters
[out] watchdogconfig pointer to the watchdog configuration structure which which is passed by the application.
Returns
TRUE : no errors. FALSE: Errors in execution.

Example Usage:

TPS_WatchdoConfiguration watchdogconfig;
//Initialize watchdog and open a new sequence run
watchdogconfig.u8TokenFDBK = 0;
watchdogconfig.u8TokenSeed = 0;
watchdogconfig.blwatchdog_reset = FALSE;
// approx 40ms
watchdogconfig.u8open_windowtime_scaler =
(uint8) (OPEN_WINDOW_CONFIG / 0.55 - 1);
//approx 15 ms
watchdogconfig.u8close_windowtime_scaler =
(uint8) (CLOSE_WINDOW_CONFIG / 0.55 - 1);
watchdogconfig.watchdog_mode = QANDA_MODE;
TPS_WatchdogInit(&watchdogconfig);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_WDSetTokenFDBCKValue ( uint8 u8TokenFDBCK )

Set Token FeedBack value for the watchdog.

Description:
Sets the token feedback value for the watchdog.This token
feedback value is used for controlling the sequence of the
tokens generated by the watchdog function.
Parameters
[in] u8TokenFDBCK parameter new token feedback value(range: 0x0U to 0xFU).
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_WDSetTokenFDBCKValue(0x4);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)
boolean TPS_WDSetTokenSeedValue ( uint8 u8TokenSeed )

Set Token Seed value for the watchdog.

Description:
Sets the token seed value for the watchdog.This token seed
value is used for the generation of the new token by
watchodog.The token seed value is taken by the Watchdog
function after the device transitions through the RESET State.
Parameters
[in] u8TokenSeed parameter new token seed value(range: 0x0U to 0xFU).
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_WDSetTokenSeedValue(0x4);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
API used for handling the TPS watchdog(external watchdog)


TPS Driver: AMUX signal enumeration min and max values

Macros
AMUX signal enumeration min and max values

Macros

#define | AMUX_MIN (VDD5)
#define | AMUX_MAX (VMON_BG)

Detailed Description

Following macros are used to define minimum and maximum values of the AMUX signals

Macro Definition Documentation

#define AMUX_MAX (VMON_BG)

ending AMUX signal

#define AMUX_MIN (VDD5)

starting AMUX signal


TPS Driver: DMUX signal enumeration min and max values

Macros
DMUX signal enumeration min and max values

Macros

#define | DMUX_MIN (RSV1)
#define | DMUX_MAX (VMON_TRIM_ER)

Detailed Description

Following macros are used to define minimum and maximum values of the AMUX signals

Macro Definition Documentation

#define DMUX_MAX (VMON_TRIM_ER)

ending DMUX signal

#define DMUX_MIN (RSV1)

starting DMUX signal


TPS Driver: Macros for indicating the current TPS device state

Macros
Macros for indicating the current TPS device state

Macros

#define | TPS_DEVICE_STANDBY ((uint8)0x0U)
#define | TPS_DEVICE_RESET ((uint8)0x3U)
#define | TPS_DEVICE_DIAGNOSTIC ((uint8)0x7U)
#define | TPS_DEVICE_ACTIVE ((uint8)0x5U)
#define | TPS_DEVICE_SAFE ((uint8)0x4U)

Detailed Description

macros indicating the current TPS device state

Macro Definition Documentation

#define TPS_DEVICE_ACTIVE ((uint8)0x5U)

the value of field FSM in register SAFETY_STAT_5 for ACTIVE state

#define TPS_DEVICE_DIAGNOSTIC ((uint8)0x7U)

the value of field FSM in register SAFETY_STAT_5 for DIAGNOSTIC state

#define TPS_DEVICE_RESET ((uint8)0x3U)

the value of field FSM in register SAFETY_STAT_5 for RESET state

#define TPS_DEVICE_SAFE ((uint8)0x4U)

the value of field FSM in register SAFETY_STAT_5 for SAFE state

#define TPS_DEVICE_STANDBY ((uint8)0x0U)

the value of field FSM in register SAFETY_STAT_5 for STANDBY state


TPS Driver: Data Structures

  • Data Structures
  • Data Structure Index
Data Structures
Here are the data structures with brief descriptions:
C TPS_ABIST_Result | ABIST result information to be used with TPS_GetABISTTestStatus API
C TPS_AllVoltageRailLimits | TPS_AllVoltageRailLimits structure is updated on TPS_Init and the structure is used for storing the limits for difference Voltage Rails which are selectable on the DIAG_OUT pin using AMUX diagnostics.refer to table 4-3 for more information
C TPS_CRCErrorStatus | The structure will contain the data regarding the CRC error in config registers/EEPROM
C TPS_DevCfg_reg_settings | Structure which can store the TPS device configuration register settings this structure updated with the relavant parameters is to be passed to the TPS_DriverInit API
C TPS_DeviceInformation | The structure will contain the device information such as device revision,device id
C TPS_DeviceState | The structure will contain the device state information such as latched CAN wake-up and deglitched IGN pin
C TPS_ERRORPinPWMWidthScaler | TPS_ERRORPinPWMWidthScaler structure to be used with TPS_ConfigureErrorMonitoring API
C TPS_Initilization_struct | TPS Initialization struct to be used with TPS_Init API
C TPS_OverallVMONStatus | TPS_OverallVMONStatus structure is used api TPS_GetVMONStatus and it is used for recording the complete voltage monitoring status of the TPS device
C TPS_Readback_Config | TPS_Readback_Config structure is updated on TPS_Init and the structure is used for read back and compare of important registers of the TPS
C TPS_VMONStatus | TPS_VMONStatus structure is used for recording the Over voltage and under voltage state of the of voltage sources
C TPS_VoltageRailLimits | TPS_VoltageRailLimits structure is used to represent the maximum,minmum and typical voltage value for particular voltage rail.It used used by the structure TPS_AllVoltageRailLimits
C TPS_WatchdoConfiguration | TPS watchdog configuration to be used with TPS_WatcdogInit API
C TPS_WatchdogWindows | TPS watchdog open and close window configuration to be used with TPS_ConfigureWatchdogWindows API


TPS Driver: TPS_ABIST_Result Struct Reference

  • Data Structures
  • Data Structure Index
TPS_ABIST_Result Struct Reference

ABIST result information to be used with TPS_GetABISTTestStatus API. More...

#include <Tps_Types.h>

Detailed Description

ABIST result information to be used with TPS_GetABISTTestStatus API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_AllVoltageRailLimits Struct Reference

  • Data Structures
  • Data Structure Index
TPS_AllVoltageRailLimits Struct Reference

TPS_AllVoltageRailLimits structure is updated on TPS_Init and the structure is used for
storing the limits for difference Voltage Rails which are selectable on the DIAG_OUT
pin using AMUX diagnostics.refer to table 4-3 for more information. More...

#include <Tps_Types.h>

Detailed Description

TPS_AllVoltageRailLimits structure is updated on TPS_Init and the structure is used for
storing the limits for difference Voltage Rails which are selectable on the DIAG_OUT
pin using AMUX diagnostics.refer to table 4-3 for more information.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_CRCErrorStatus Struct Reference

  • Data Structures
  • Data Structure Index
TPS_CRCErrorStatus Struct Reference

The structure will contain the data regarding the CRC error in config registers/EEPROM. More...

#include <Tps_Types.h>

Detailed Description

The structure will contain the data regarding the CRC error in config registers/EEPROM.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_DevCfg_reg_settings Struct Reference

  • Data Structures
  • Data Structure Index
TPS_DevCfg_reg_settings Struct Reference

structure which can store the TPS device configuration register settings this structure updated with the relavant parameters is to be passed to the TPS_DriverInit API. More...

#include <Tps_Types.h>

Detailed Description

structure which can store the TPS device configuration register settings this structure updated with the relavant parameters is to be passed to the TPS_DriverInit API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_DeviceInformation Struct Reference

  • Data Structures
  • Data Structure Index
TPS_DeviceInformation Struct Reference

The structure will contain the device information such as device revision,device id. More...

#include <Tps_Types.h>

Detailed Description

The structure will contain the device information such as device revision,device id.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_DeviceState Struct Reference

  • Data Structures
  • Data Structure Index
TPS_DeviceState Struct Reference

The structure will contain the device state information such as latched CAN wake-up and deglitched IGN pin. More...

#include <Tps_Types.h>

Detailed Description

The structure will contain the device state information such as latched CAN wake-up and deglitched IGN pin.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_ERRORPinPWMWidthScaler Struct Reference

  • Data Structures
  • Data Structure Index
TPS_ERRORPinPWMWidthScaler Struct Reference

TPS_ERRORPinPWMWidthScaler structure to be used with TPS_ConfigureErrorMonitoring API. More...

#include <Tps_Types.h>

Detailed Description

TPS_ERRORPinPWMWidthScaler structure to be used with TPS_ConfigureErrorMonitoring API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_Initilization_struct Struct Reference

  • Data Structures
  • Data Structure Index
TPS_Initilization_struct Struct Reference

TPS Initialization struct to be used with TPS_Init API. More...

#include <Tps_Types.h>

Detailed Description

TPS Initialization struct to be used with TPS_Init API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_OverallVMONStatus Struct Reference

  • Data Structures
  • Data Structure Index
TPS_OverallVMONStatus Struct Reference

TPS_OverallVMONStatus structure is used api TPS_GetVMONStatus
and it is used for recording the complete voltage monitoring status
of the TPS device. More...

#include <Tps_Types.h>

Detailed Description

TPS_OverallVMONStatus structure is used api TPS_GetVMONStatus
and it is used for recording the complete voltage monitoring status
of the TPS device.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_Readback_Config Struct Reference

  • Data Structures
  • Data Structure Index
TPS_Readback_Config Struct Reference

TPS_Readback_Config structure is updated on TPS_Init and the structure is used for
read back and compare of important registers of the TPS. More...

#include <Tps_Types.h>

Detailed Description

TPS_Readback_Config structure is updated on TPS_Init and the structure is used for
read back and compare of important registers of the TPS.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_VMONStatus Struct Reference

  • Data Structures
  • Data Structure Index
TPS_VMONStatus Struct Reference

TPS_VMONStatus structure is used for recording the Over voltage
and under voltage state of the of voltage sources. More...

#include <Tps_Types.h>

Detailed Description

TPS_VMONStatus structure is used for recording the Over voltage
and under voltage state of the of voltage sources.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_VoltageRailLimits Struct Reference

  • Data Structures
  • Data Structure Index
TPS_VoltageRailLimits Struct Reference

TPS_VoltageRailLimits structure is used to represent the maximum,minmum and typical
voltage value for particular voltage rail.It used used by the structure TPS_AllVoltageRailLimits. More...

#include <Tps_Types.h>

Detailed Description

TPS_VoltageRailLimits structure is used to represent the maximum,minmum and typical
voltage value for particular voltage rail.It used used by the structure TPS_AllVoltageRailLimits.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_WatchdoConfiguration Struct Reference

  • Data Structures
  • Data Structure Index
TPS_WatchdoConfiguration Struct Reference

TPS watchdog configuration to be used with TPS_WatcdogInit API. More...

#include <Tps_Types.h>

Detailed Description

TPS watchdog configuration to be used with TPS_WatcdogInit API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: TPS_WatchdogWindows Struct Reference

  • Data Structures
  • Data Structure Index
TPS_WatchdogWindows Struct Reference

TPS watchdog open and close window configuration to be used with TPS_ConfigureWatchdogWindows API. More...

#include <Tps_Types.h>

Detailed Description

TPS watchdog open and close window configuration to be used with TPS_ConfigureWatchdogWindows API.

The documentation for this struct was generated from the following file:
  • D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h


TPS Driver: Data Structure Index

  • Data Structures
  • Data Structure Index
Data Structure Index
T
T
TPS_CRCErrorStatus TPS_ERRORPinPWMWidthScaler TPS_VMONStatus
TPS_DevCfg_reg_settings TPS_Initilization_struct TPS_VoltageRailLimits
TPS_ABIST_Result TPS_DeviceInformation TPS_OverallVMONStatus TPS_WatchdoConfiguration
TPS_AllVoltageRailLimits TPS_DeviceState TPS_Readback_Config TPS_WatchdogWindows
T
Generated on Fri Feb 6 2015 03:20:40 for TPS Driver by doxygen 1.8.7


TPS Driver: File List

  • File List
  • Globals
File List
Here is a list of all documented files with brief descriptions:
[detail level 123]
▼ TPS_Driver |
▼ include |
Tps_Config.h | This files contains the configuration items for the the TPS Driver
TPS_DebugSupport.h | This files contains the Debug Support API prototypes
Tps_Driver.h | This files contains the configuration items for the the TPS Driver
Tps_Types.h | This files contains the types used by the TPS Library API's
▼ source |
Tps_Driver.c | Driver Level API to configure TPS device
Tps_Interface.h | File contains the TPS interfacing api's prototypes for read,write and verifying SPI mapped registers
Tps_priv.h | Private macros used by the TPS driver


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver Directory Reference

  • TPS_Driver
TPS_Driver Directory Reference

Directories

directory | include
directory | source


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include Directory Reference

  • TPS_Driver
  • include
include Directory Reference

Files

file | Tps_Config.h [code]
This files contains the configuration items for the the TPS Driver.
file | TPS_DebugSupport.h [code]
This files contains the Debug Support API prototypes.
file | Tps_Driver.h [code]
This files contains the configuration items for the the TPS Driver.
file | Tps_Types.h [code]
This files contains the types used by the TPS Library API's.


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Config.h File Reference

  • TPS_Driver
  • include
Tps_Config.h File Reference

This files contains the configuration items for the the TPS Driver. More...

Detailed Description

This files contains the configuration items for the the TPS Driver.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

The file contains configuration items such as SRAM RANGE degines etc.

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version created

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/TPS_DebugSupport.h File Reference

  • TPS_Driver
  • include
TPS_DebugSupport.h File Reference

This files contains the Debug Support API prototypes. More...

Detailed Description

This files contains the Debug Support API prototypes.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Driver
   @generator  No Configuration

The Tps_DebugSupport.h file provides the debug support API prototypes.These API's should help the application
debug the end application /driver.

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version

Function Documentation

void TPS_DebugInit ( SendDebugText SendTPSDebugText )

API to initialize the debug support in the TPS driver.

Description:
The API is used to set up the TPS driver for the debug support.
Parameters
[in] SendTPSDebugText pointer to the Application supported API
which receives the debug text from the TPS driver.

Example Usage:

todo
Entry Mode:
any,The debu support interface such as SCI has to be
initialized before the debug init is called.
Exit Mode:
any.
See also:
todo

todo todo

boolean TPS_SendDebugText | ( | TPS_DebugSeverity | severity,
 |  | const uint8 *const | u8buftext,
 |  | uint32 | u32value
 | ) |  |

The API is used flag the errors/debug messages for debug purposes.

Description:
The API is used flag the errors/debug messages for debug purposes.
Parameters
[in] severity Severity ERROR or DEBUG of the debug message.
[in] u8buftext NULL terminated text buffer containing user
information.
[in] u32value Value printed along with the debug text.This
arguement is ignored if severity is INFO Example Usage:
todo
Entry Mode:
any,The debug support interface such as SCI has to be
initialized before the debug init is called.
Exit Mode:
any.
See also:
todo

todo todo

#include "TPS_Types.h"
#include "TPS_Config.h"
#include <stdio.h>
#include <string.h>

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Driver.h File Reference

  • TPS_Driver
  • include
Tps_Driver.h File Reference

This files contains the configuration items for the the TPS Driver. More...

Detailed Description

This files contains the configuration items for the the TPS Driver.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Driver
   @generator  No Configuration

The TPS_Driver.c file provides the driver level api prototypes.These API's should help the application
in setting up proper operation mode for the TPS device.
This single file needs to be included by the application
in order to use the TPS Driver.

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version

Function Documentation

boolean TPS_ClearDeviceErrorCount ( void )

API clears the devices error count values in the TPS register SAFETY_ERR_STAT.

Description:
API clears the devices error count values in the TPS register SAFETY_ERR_STAT.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ClearDeviceErrorCount();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetDeviceErrorCount
boolean TPS_ClearErrorPinFailureStatusFlag ( void )

The API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register.

Description:
The API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ClearErrorPinFailureStatusFlag();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetErrorPinFailureStatusFlag
boolean TPS_ConfigureErrorMonitoring | ( | TPS_ErrorPinMonitoringMode | monitoring_mode,
 |  | TPS_ERRORPinPWMWidthScaler | pwm
 | ) |  |

Set Error signal monitoring mode.

Description:
Writes to the safety function control register so as to set MCU error signal monitoring mode.
Parameters
[in] monitoring_mode parameter indicating the PWM mode or error pin monitoring mode.
[in] pwm the scaler values for the register PWM_LOW and PWM_HIGH registers
which decide the pwm widths for the error monitoring. Note:when the mode is ERROR_PIN_MODE then the pwm_high width is not considered only the pwm_low width is used to set the pwm low duration.*
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ERRORPinPWMWidthScaler pwm;
pwm.u8PWM_LOW = 0U;
//PWM high is irrelavant since ERROR_PIN_MODE is being used.
TPS_ConfigureErrorMonitoring(ERROR_PIN_MODE, pwm)
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_ConfigureIgnintionPowerLatchControl ( boolean blignition_powerlatch_control )

Set ignition power latch behavior.

Description:
Enables ignition power latch in TPS device
The TPS powers the MCu even if the ignition goes low.
Parameters
[in] blignition_powerlatch_control parameter which enables or
disables ignition power latch.When enabled the device remains
powered on even if ignition goes low.
Returns
TRUE: no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureIgnintionPowerLatchControl(TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_ConfigureSafeStateTimeout ( boolean blsafe_state_timeout )

Enable or disable the safe state timeout.

Description:
Writes to the safety function control register so as safe state time out.
Parameters
[in] blsafe_state_timeout Enabled: After device error count limit has reached the TPS transitions to the Reset State
Disabled: The TPS remains locked to the safe state even after the device error count has been reached.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//disable safe state timeout
TPS_ConfigureSafeStateTimeout(FALSE)
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_SetSafeStateTimoutDuration,TPS_SetSafeStateTimoutDuration
boolean TPS_ConfigureVDD5 ( boolean blEnableVDD5 )

The API enables voltage source VDD5.

Description:
The API sets the flag VDD5_EN in the SENS_CTRL register so as to enable the VDD5 voltage source.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureVDD5(TRUE);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_ConfigureVSOUT1 ( boolean blEnableVSOUT1 )

The API enables voltage source VSOUT1.

Description:
The API sets the flag VSOUT1_ in the SENS_CTRL register so as to enable the VSOUT1 voltage source.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureVSOUT1(TRUE);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_DriverInit ( const TPS_Initilization_struct *const init_struct )

API to set up and initialize TPS driver.

Description:
The single API can be used to set up all the required parameters of the TPS statemachine
and configure all settings.
Parameters
[out] init_struct pointer to the initialization structure which which is passed by the application.
Returns
TRUE : no errors. FALSE: Errors in execution.

Example Usage:

TPS_Initilization_struct initstruct;
memcpy(&initstruct.AMUXVoltageRailLimits,
&TPS65381Q_VoltageLimits,
sizeof(TPS65381Q_VoltageLimits));
initstruct.GetTPSDiagPinSampledValue =
TPSDiagosticPinSampledData;
initstruct.blNRES_Monitoring = TRUE;
initstruct.blbist_at_startup = TRUE;
initstruct.blenable_drv_op = TRUE;
\\Error pin monitoring is disabled here,The Halcogen startup toggles the error pin,If error monitoring is
\\enabled then appropriate settings has to be made to error monitoring(PWM low width) width
\\so that the error monitoring does not reset the TPS device.
initstruct.blerror_pin_monitoring = FALSE;
initstruct.blignition_power_latch = FALSE;
initstruct.blsafe_state_timeout = TRUE;
initstruct.dev_configreg_settings.blMASK_VBAT_OV = TRUE;
initstruct.dev_configreg_settings.blMASK_VDD1_UV = TRUE;
initstruct.dev_configreg_settings.blPOST_RUN_RST = TRUE;
initstruct.dev_configreg_settings.blVDD3_5_OT = TRUE;
initstruct.dev_configreg_settings.blVDD5_OT = TRUE;
initstruct.error_pin_monitoring_mode = ERROR_PIN_MODE;
initstruct.error_pin_pwm_width.u8PWM_HIGH = 8;
\\the min error pin low dyuration in 204.8 us
initstruct.error_pin_pwm_width.u8PWM_LOW = 40;
initstruct.send_recieve_data_TPS = SendandRecieveDataTPS;
initstruct.u8pwd_threshhold_value = 5;
initstruct.u8safe_lock_threshhold = 5;
\\timeout duration in 198 ns
initstruct.u8safe_state_timeout_scaler = 4;
TPS_DriverInit(&initstruct);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TpsIf_Init
boolean TPS_ExitDiagnosticMode ( void )

Takes the necessary actions so as to exit DIAGNOSTIC mode and enter the active mode of TPS device operation.

Description:
Clears the flags related to WD_FAIL,ERROR_PIN_FAIL etc. and sets appropriate flags so as to exit
the DIAGNSOTIC state safely and enter the active state operating mode of the TPS device.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ExitDiagnosticMode();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Active state
See also:
TPS_ConfigureSafetyCheckControl
boolean TPS_Get3_3Vor5VSupply ( TPS_VDD_3_5_SEL * voltage_selection )

gets VDD3/VDD5 selection.

Description:
The API gets the VDD3/VDD5 selection at power up.The VDD3/5 volt selection can be made using the pin SEL_VDD3/5.
Parameters
[out] voltage_selection SEL_5V if 5V is selected by using the SEL_VDD3/5 pin.
SEL_3_3V if 3.3V is selected by using the SEL_VDD3/5 pin.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_VDD_3_5_SEL voltage_selection;
TPS_Get3_3Vor5VSupply(&voltage_selection);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetCurrentTPSDeviceState ( uint8 * u8CurrentTPSDeviceState )

Get Current TPS device State.

Description:
The API provides the value indicating the current TPS device state.
Parameters
[in] u8CurrentTPSDeviceState value indicating the current TPS
state.Please refer to section 4.16.7 to get more infomration
on the values representing the different states of the TPS.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8TPSDevState;
TPS_GetCurrentTPSDeviceState(u8TPSDevState);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetDEV_STATE ( TPS_DeviceState * dev_state )

Provide information regarding TPS.

Description:
The API reads the register DEV_STATE and provides the canwu_l
and IGN deglitched pin status.
Parameters
[in] *dev_state Structure which stores the
information regarding latched can wakeup
and deglitched ignition pin.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DeviceState devstate;
TPS_GetDEV_STATE(&devstate);
Entry Mode:
TPS in Diagnostic/Active/Safe state.c
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetDeviceErrorCount ( uint8 * u8DeviceErrorCount )

API provides the device error count value in TPS.

Description:
API provides the device error count value in TPS.The device
error count increases every time when the device transits to
Safe state.
Parameters
[out] u8DeviceErrorCount Device error count
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8DevErrCount;
TPS_GetDeviceErrorCount(&u8DevErrCount);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_ClearDeviceErrorCount
boolean TPS_GetDeviceInformation ( TPS_DeviceInformation * device_information )

The API provides TPS device information.

Description:
The API provides TPS device information such as major version,minor version and device ID.
Parameters
[out] device_information Structure containing the device information such as device ID and major,minor version.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DeviceInformation devinfo;
TPS_GetDeviceInformation(&devinfo);
Entry Mode:
TPS in Diagnostic/Active/Safe
Exit Mode:
TPS in Diagnostic/Active/Safe
boolean TPS_GetENDRVErrorStatus ( boolean * blENDRVError )

The API provides Enable drive error status.

Description:
The API provide enable drive error status.The enable drive
error gets set when there is mismatch between EN_DRV output and EN_DRV
feedback.
Parameters
[in] *blENDRVError if TRUE the ENDRV_ERR is set.ENDRV_ERR get set
is mismatch between the EN_DRV output and EN_DRV feedback is
detected.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blEndrvErrstatus;
TPS_GetENDRVErrorStatus(&blEndrvErrstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetErrorPinFailureStatusFlag ( boolean * blFailureStatus )

The API provides failure status information of the error pin of MCU.

Description:
The API provides failure status information of the error pin.
Parameters
[in] *blFailureStatus if TRUE the error pin failure has occurred
if False no error pin failure
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blfailstatus;
TPS_GetErrorPinFailureStatusFlag(&blfailstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_ClearErrorPinFailureStatusFlag
boolean TPS_GetJnTempandCurrentLimitStatus ( TPS_JnTempCurrentLimitStatus * JnTempCurrentLtMonitoring )

Provide status of junction temperature monitoring and current limit status.

Description:
The API gets the registers SAFETY_STAT_1 and k
updates the vmon status structure with the relevant information
The API can be used to know the voltage monitoring status
of the TPS device.
Parameters
[in] *JnTempCurrentLtMonitoring Structure which stores the
information regarding the\ junction
Temperature monitoring and current
limit status.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_JnTempCurrentLimitStatus jntempcurrentmonitoringstatus;
TPS_GetJnTempandCurrentLimitStatus(&jntempcurrentmonitoringstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetSPIErrorStatus ( TPS_SPIErrorType * spi_error_status )

Provide device the error status of the previous SPI transmission.

Description:
The API reads the register SAFETY_STAT_4 and provides the SPI
error status information.
Parameters
[in] *spi_error_status Structure which stores the
information regarding the spi error status.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SPIErrorType spierr;
TPS_GetSPIErrorStatus(&spierr);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetTPSDeviceConfiguration ( TPS_DevCfg_reg_settings * config_register_settings )

Provide device confiuration(setting made in the DEV_CFG1 and DEV_CFG2 register)

Description:
The API gets the registers DEV_CFG1 and DEV_CFG2 and updates
device_configuation structure with the relevant information
The API can be used to know the current TPS device configuration.
Parameters
[in] *device_configuation Structure which stores the
information regarding the dev config
register settings of the TPS device
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DevCfg_reg_settings tps_dev_cfg_regs;
TPS_GetTPSDeviceConfiguration(&tps_dev_cfg_regs);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_SetTPSDeviceConfigurationRegisters
boolean TPS_GetVMONStatus ( TPS_OverallVMONStatus * vmon_status )

Provide status of the Voltage monitoring by the TPS.

Description:
The API gets the registers VMON_STAT_1 and VMON_STAT_2 and
updates the vmon status structure with the relevant information
The API can be used to know the voltage monitoring status
of the TPS device.
Parameters
[in] *vmon_status Structure which stores the information regarding the
voltage monitoring status(VMON_STAT_1,VMON_STAT_2)
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_OverallVMONStatus overall_vmon_status;
TPS_GetVMONStatus(&overall_vmon_status);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GoToSafeState ( void )

The API moves the TPS device safe state(from Active state).

Description:
The API moves the TPS device to safe state.by creating an error in the MCU. Note: The error monitoring is enabled by setting the bit NO_ERROR in safety check control to 0
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_GoToSafeState();
Entry Mode:
TPS in Active
Exit Mode:
TPS in Safe
boolean TPS_ProtectConfigurationRegisters ( TPS_HandleConfigurationRegisters state )

LOCK/UNLOCK (protect) the configuration registers for writing.

Description:
The Device configuration registers can be protected/released (for writing) by using this API.
Parameters
[in] state LOCK - Lock the device configuration registers for writing. UNLOCK - unlock device configuration registers for writing
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//LOCK the writing to TPS protected registers
TPS_ProtectConfigurationRegisters(LOCK);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_RegReadBackandCompare ( TPS_Test_Result * readback_compare )

Register read back and compare.

Description:
The API compares the init_configuration(the user configured configuration)
against the read back configuration(reads the configuration from the TPS device).
Parameters
[out] readback_compare TEST_PASS if the read back and comparison has passed.
TEST_FAIL if read back and comparison has failed
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_Test_Result readback_compare_test;
TPS_RegReadBackandCompare(&readback_compare_test);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_SetMCUSoftwareDebugMode ( void )

Set TPS device configuration so to support MCU software debug.

Description:
Set TPS device configuration so to support MCU software debug.
The API sets specific flags such as DIAG EXIT MASK,NO_SAFE _TO
etc. bits so as to support MCU debug.Calling this APi corrupts
the initial settings made by the TPS_DriverInit API. So the
TPS_DriverInit has to be called so as to come back to the
init state.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetMCUSoftwareDebugMode();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetPowerDownThreshhold ( uint8 u8threshhold_value )

Set power down threshold value.

Description:
The API is used to set the power down threshold value in the
register PWD_THR_CFG register.
Parameters
[out] u8threshhold_value Device error-count threshold to power down the device.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetPowerDownThreshhold(0x3);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetSafeLockThreshhold ( uint8 u8SafeLockThreshhold )

Set device ERROR COUNT threshold value.

Description:
The API sets the device error count threshold value.Be Safe state timeout is disabled the device remains locked in the Safe State
even after the device error count even beyond this safe lock threshold value.
Parameters
[in] u8SafeLockThreshhold Device ERROR COUNT threshold value.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetSafeLockThreshhold(0x5);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetSafeStateTimoutDuration ( uint8 u8SafeStateTOtDuration_scaler )

Set Safe State time out duration.

Description:
Writes to the safety error configuration register so as to set safe state time out duration.Afer each error the device enters safe state from the active state
It remains in safe state until this time out duration before trasiting to the reset state.(when the device error count is lesser than the configured threshold value.
Parameters
[in] u8SafeStateTimoutDuration_scaler scaler value which decides the safe state timeout duration.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetSafeStateTimoutDuration(3);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_ConfigureSafeStateTimeout
boolean TPS_SetTPSDeviceConfigurationRegisters | ( | TPS_DeviceConfigRegisterSettings | field,
 |  | boolean | blvalue
 | ) |  |

The API helps in setting the device configuration register.

Description:
The APi when called with specific field value and proper setting of the enable_disable configures the features of TPS such as MASK_VVD3_OV,POST_RUN_RST etc.Please refer to section 4.15.3 in the TPS65381 detached.
Parameters
[in] field Feature(in the device configuration or the flag) which
has to enabled or disabled.It also indicates the field
in the configuration which has to be modified.
[in] blvalue parameter indicating whether the feature has to be
enabled or disabled
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetTPSDeviceConfigurationRegisters(MASK_VDD1_UV,TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetTPSDeviceConfiguration
boolean TPS_TestErrorPinMonitoring ( TPS_Test_Result * ErrorPinMonitoring_Test )

The API does the selftest of the error pin monitoring.

Description:
The API does of the selftest of the error pin monitoring.Can be called only in diagnostic mode
. The API makes sure that the ERROR_PIN_FAIL flag is appropriately set when the mcu error pin is
low for more than 15us.
Parameters
[out] ErrorPinMonitoring_Test TEST_PASS if the error monitoring is successful has passed.
TEST_FAIL if error monitoring has failed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result errorpinmonitoringtest;
TPS_TestErrorPinMonitoring(&errorpinmonitoringtest);
Entry Mode:
TPS in Diagnostic
Exit Mode:
TPS in Diagnostic
See also:
TPS_ConfigureErrorMonitoring
boolean TPS_UpdateDatastringforCRCCaclcuation | ( | uint32 | u32DataforCRC[2],
 |  | uint16 | u16reg
 | ) |  |

The API updates the 64 bit data string for 8 bit crc calculation for specified register.

Description:
The API updates the 64 bit data for crc with updated contents for the specified register. It updates the necessary fields for the specified register in the 64 bit data.
Parameters
[in] | *u32DataforCRC | pointer to the 64 bit data which has to be initialized for the calculation of the 8 bit crc.
[in] | u16reg | the register for which the contents in the data string (for crc calculation) needs to be updated.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint32 u32dataforcrc[2] = {0U,0U};
TPS_UpdateDatastringforCRCCaclcuation(u32dataforcrc,TPS_DEV_CFG2);
Entry Mode:
TPS in Diagnostic/active state(This is used normally after
TPS_InitializeDatastringforCRCCaclcuation called once) to
a individual field of the CRC string.
Exit Mode:
TPS in Diagnostic/Active state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
#include "TPS_Interface.h"
#include "TPS_Types.h"
#include "TPS_DebugSupport.h"
#include "reg_bitdefn_esm.h"
#include <string.h>

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h File Reference

  • TPS_Driver
  • include
Tps_Types.h File Reference

This files contains the types used by the TPS Library API's. More...

Detailed Description

This files contains the types used by the TPS Library API's.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

todo

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version created

Typedef Documentation

send_recieve_data

Definition for transmit_recieve_data data API, which is provided by the user application.

Description:
The application should support such an API and should pass the function pointer to TPS initialization routine.
Parameters
u16TransmitData | - data to be sent on the Configured MibSPI channel.
u32TransmitSize | - size of the data to be sent
u16RecieveData | - data received on the Configured MibSPI channel.
u32RecieveSize | - size of the data received
SendDebugText

Definition for send debug text API, which is provided by the user application.

Description:
The application should support such an API which can recieve the debug text
and use the information appropriately
Parameters
textbuf | - text buffer containing debug text.
length | - length of the text buffer

Enumeration Type Documentation

enum _TPS_AMUXSignals
Enumerator
VDD5 | VDD5 AMUX signal
VDD6 | VDD6 AMUX signal
VCP | external charge pump(VCP) AMUX signal
VSFB1 | Sensor supply feedback voltage AMUX signal
VBAT_SAFING | safing battery supply AMUX signal
VBAT | battery supply AMUX signal
MAIN_BG | regulators band-gap reference AMUX signal
VMON_BG | Voltage-monitor band gap AMUX signal
enum _TPS_BistTypes
Enumerator
ABIST | Analog built in selftest
LBIST | Logic built in selftest
enum _TPS_DeviceConfigRegisterSettings
Enumerator
MASK_VDD1_UV | nMASK_VDD1_UV register field of DEV_CFG1 register
VDD3_5_OT | EN_VDD3/5_OT register field of DEV_CFG2 register
VDD5_OT | EN_VDD5_OT register field of DEV_CFG2 register
MASK_VBAT_OV | MASK_VBAT_OV register field of DEV_CFG2 register
POST_RUN_RST | POST_RUN_RST register field of DEV_CFG2 register
enum _TPS_DMUXSignals
Enumerator
RSV1 | Reserved, logic 0
AVDD_UVN | AVDD undervoltage comparator output
BG_ERR1 | VMON or main band gap is OFF
BG_ERR2 | VMON or main band gap is OFF
VCP12_NUV | VCP12 charge-pump undervoltage comparator
VCP12_OV | VCP12 charge-pump overvoltage comparator
VCP17_OV | VCP17 charge-pump overvoltage comparator
VDD6_NUV | VDD6 undervoltage comparator
VDD6_OV | VDD6 overvoltage comparator
VDD5_NUV | VDD5 undervoltage comparator
VDD5_OV | VDD5 overvoltage comparator
VDD3_5_NUV | VDD3/5 undervoltage comparator
VDD3_5_OV | VDD3/5 overvoltage comparator
VDD1_NUV | VDD1 undervoltage comparator
VDD1_OV | VDD1 overvoltage comparator
LOCLK | Loss-of-system-clock comparator
RSV2 | Reserved, logic 0
SYS_CLK | System clock source
DFT1 | Signal reserved for production test
WDT_CLK | Watchdog clock reference (0.55-ms period time)
RST_EXT_CLK | Reset extension oscillator output
T_5US | 5-µs time reference
T_15US | 15-µs time reference
T_40US | 40-µs time reference
T_2MS | 2-ms time reference
UC_ERROR_WDI | External MCU ERROR/WDI input pin
SPI_NCS | SPI chip-select input pin
SPI_SDI | SPI slave-data input pin
SPI_CLK | SPI clock input pin
SDO_RDBCK | SPI slave-data output-pin readback
UC_ERROR_WDI_RED | Same signal as 2.10
NRST_EXT_IN | NRES pin readback (reset to external MCU)
RSV3 | Reserved, logic 0
DFT2 | Signal reserved for production test
DFT3 | Signal reserved for production test
CP_OV | Charge-pump overvoltage comparator
CP_UVN | Charge-pump undervoltage comparator
CP_PH1 | Charge-pump switching phase 1
CP_PH2 | Charge-pump switching phase 2
CP_DIFF3V | Indicates VCP-VBATP > 3 V
DFT4 | Signal reserved for production test
VBAT_UVN | VBAT undervoltage comparator
VBATP_OV | VBAT overvoltage comparator
DMUX_VDD5_OT | VDD5 overtemperature
DMUX_VDD3_5_OT | VDD3/5 overtemperature
VSOUT_OT | VSOUT overtemperature
VDD5_CL | VDD5 current-limit
VDD3_CL | VDD3 current-limit
RSV4 | Reserved, logic 0
VSOUT_ILIM | VSOUT1 current-limit
VSOUT_UVN | VSOUT1 undervoltage comparator
VSOUT_OV | VSOUT1 overvoltage comparator
DVDD_UV | DVDD undervoltage comparator
DVDD_OV | DVDD overvoltage comparator
RSV5 | Reserved
VS_TRK_MODE | VSOUT1 in track-mode indication
VMON_TRIM_ER | VMON trim error
enum _TPS_ErrorPinMonitoringMode
Enumerator
PWM_MONITORING_MODE | PWM monitoring mode for the MCU error signal monitoring
ERROR_PIN_MODE | MCU error signal low monitoring
enum _TPS_HandleConfigurationRegisters
Enumerator
LOCK | select the 5v voltage source
UNLOCK | select the 3.3 volt voltage source
enum _TPS_Registers
Enumerator
TPS_DEV_REV | 0x00: Alias for device revision register
TPS_DEV_ID | 0x01: Alias for device identifier register
TPS_DEV_STAT | 0x02: Alias for device status register
TPS_DEV_CFG1 | 0x03: Alias for config 1 register
TPS_DEV_CFG2 | 0x04: Alias for config 2 register
TPS_VMON_STAT_1 | 0x05: Alias for voltage monitor status 1 register
TPS_VMON_STAT_2 | 0x06: Alias for voltage monitor status 2 register
TPS_SAFETY_STAT_1 | 0x07: Alias for safety status 1 register
TPS_SAFETY_STAT_2 | 0x08: Alias for safety status 2 register
TPS_SAFETY_STAT_3 | 0x09: Alias for safety status 3 register
TPS_SAFETY_STAT_4 | 0x0A: Alias for safety status 4 register
TPS_SAFETY_STAT_5 | 0x0B: Alias for safety status 5 register
TPS_SAFETY_ERR_CFG | 0x0C: Alias for safety error config register
TPS_SAFETY_BIST_CTRL | 0x0D: Alias for safety BIST control register
TPS_SAFETY_CHECK_CTRL | 0x0E: Alias for safety check control register
TPS_SAFETY_FUNC_CFG | 0x0F: Alias for safety function config register
TPS_SAFETY_ERR_STAT | 0x10: Alias for safety error status register
TPS_SAFETY_ERR_PWM_H | 0x11: Alias for safety error pwm high register
TPS_SAFETY_ERR_PWM_L | 0x12: Alias for safety error pwm low register
TPS_SAFETY_PWD_THR_CFG | 0x13: Alias for safety power down threshold config register
TPS_SAFETY_CFG_CRC | 0x14: Alias for safety config crc register
TPS_DIAG_CFG_CTRL | 0x15: Alias for diagnostic config control register
TPS_DIAG_MUX_SEL | 0x16: Alias for diagnostic mux select register
TPS_WDT_TOKEN_FDBCK | 0x17: Alias for watchdog token feedback register
TPS_WDT_WIN1_CFG | 0x18: Alias for watchdog open window config register
TPS_WDT_WIN2_CFG | 0x19: Alias for watchdog close window config register
TPS_WDT_TOKEN_VALUE | 0x1A: Alias for watchdog token register
TPS_WDT_STATUS | 0x1B: Alias for watchdog status register
TPS_WDT_ANSWER | 0x1C: Alias for watchdog answer register
TPS_SENS_CTRL | 0x1D: Alias for sense control register
TPS_SW_LOCK | 0x1E: Alias for register lock register
TPS_SW_UNLOCK | 0x1F: Alias for register unlock register
enum _TPS_SafetyBISTControlRegisterSettings
Enumerator
EE_CRC_CHK | EE_CRC_CHECK field of the SAFETY_BIST_CTRL register
AUTO_BIST | AUTO_BIST field of the SAFETY_BIST_CTRL register
enum _TPS_SafetyCheckControl
Enumerator
CFG_CRC | crc enable disable.Once enabled it takes 2.1us for completion of the crc check.
DRV_OUTPUT | DRV output of TPS device
ERROR_PIN_MONITORING | MCU error pin monitoring
DIAG_EXIT_MASK | diag exit mask which disables the exit from the diagnostic mode of the TPS
DIAG_EXIT | diag exit on enabling this the TPS exits diagnostic mode and enters active mode(when the diag exit mask is not set
enum _TPS_SPIErrorType
Enumerator
NO_ERROR | SPI no error
COMMAND_ERROR | Wrong SPI command
FORMAT_ERROR | format error(received bit count is not equal to 16
DATA_OP_MISMATCH | Data output mismatch
enum _TPS_Test_Result
Enumerator
TEST_FAIL | Test failed
TEST_PASS | Test Passed
enum _TPS_TestRunningStatus
Enumerator
OVER | Test is over
RUNNING | Test is running
enum _TPS_VDD_3_5_SEL
Enumerator
SEL_5V | select the 5v voltage source
SEL_3_3V | select the 3.3 volt voltage source
enum _TPS_WatchdogMode
Enumerator
WDTI_MODE | Watchdog trigger input configuration
QANDA_MODE | Watchdog question and answer mode
enum _TPS_WatchdogWindows
Enumerator
OPEN_WINDOW | open window of the watchdog
CLOSE_WINDOW | close window of the watchdog
enum _TPS_WDResponse
Enumerator
WD_TOKEN_RESP3 | Watcdog RESP3 which should be sent during the close window
WD_TOKEN_RESP2 | Watcdog RESP2 which should be sent during the open window
WD_TOKEN_RESP1 | Watcdog RESP1 which should be sent during the open window
WD_TOKEN_RESP0 | Watcdog RESP0 which should be sent during the open window
enum TPS_DebugSeverity

Enumerations debug message severity.

Enumerator
DEBUG | The message severity level is debug
ERROR | The message severity level is error
INFO | The message is an information to the user
enum TPS_WDFaultType

Enumerations indicating the Watchdog fault type to be injected.

Enumerator
BAD_ANSWER

Inject bad watchdog answer fault

#include "sl_hal_stdtypes.h"

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source Directory Reference

  • TPS_Driver
  • source
source Directory Reference

Files

file | TPS_DebugSupport.c
file | Tps_Driver.c
Driver Level API to configure TPS device.
file | Tps_Interface.c
file | Tps_Interface.h [code]
File contains the TPS interfacing api's prototypes for
read,write and verifying SPI mapped registers.
file | Tps_priv.h [code]
private macros used by the TPS driver.


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source/Tps_Driver.c File Reference

  • TPS_Driver
  • source
Tps_Driver.c File Reference

Driver Level API to configure TPS device. More...

Detailed Description

Driver Level API to configure TPS device.

Interfacing API to directly send commands to the TPS device.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

The TPS_Driver.c file provides the driver level api's to
the TPS.These API's should help the application in
setting up proper operation mode for the TPS device.

Manoj

Revision History

Date | Author | Description
20Dec2012 | Manoj R | Initial version created
Oct2014 | Sharath | Fixed wrong data for commands SW_LOCK and SW_UNLOCK (SDOCM00113801, SDOCM00111757)
Oct2014 | Sharath | Fixed TPS_ConfigureWatchdogWindows scalar_window param check <= instead of <

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

The TPS_Interface.c file provides the interface api's to
the TPS.It provides API to set,clear and verify the
registers of the TPS device.

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version

Function Documentation

boolean TPS_ClearDeviceErrorCount ( void )

API clears the devices error count values in the TPS register SAFETY_ERR_STAT.

Description:
API clears the devices error count values in the TPS register SAFETY_ERR_STAT.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ClearDeviceErrorCount();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetDeviceErrorCount
boolean TPS_ClearErrorPinFailureStatusFlag ( void )

The API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register.

Description:
The API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ClearErrorPinFailureStatusFlag();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetErrorPinFailureStatusFlag
boolean TPS_ConfigureErrorMonitoring | ( | TPS_ErrorPinMonitoringMode | monitoring_mode,
 |  | TPS_ERRORPinPWMWidthScaler | pwm
 | ) |  |

Set Error signal monitoring mode.

Description:
Writes to the safety function control register so as to set MCU error signal monitoring mode.
Parameters
[in] monitoring_mode parameter indicating the PWM mode or error pin monitoring mode.
[in] pwm the scaler values for the register PWM_LOW and PWM_HIGH registers
which decide the pwm widths for the error monitoring. Note:when the mode is ERROR_PIN_MODE then the pwm_high width is not considered only the pwm_low width is used to set the pwm low duration.*
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ERRORPinPWMWidthScaler pwm;
pwm.u8PWM_LOW = 0U;
//PWM high is irrelavant since ERROR_PIN_MODE is being used.
TPS_ConfigureErrorMonitoring(ERROR_PIN_MODE, pwm)
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_ConfigureIgnintionPowerLatchControl ( boolean blignition_powerlatch_control )

Set ignition power latch behavior.

Description:
Enables ignition power latch in TPS device
The TPS powers the MCu even if the ignition goes low.
Parameters
[in] blignition_powerlatch_control parameter which enables or
disables ignition power latch.When enabled the device remains
powered on even if ignition goes low.
Returns
TRUE: no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureIgnintionPowerLatchControl(TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_ConfigureSafeStateTimeout ( boolean blsafe_state_timeout )

Enable or disable the safe state timeout.

Description:
Writes to the safety function control register so as safe state time out.
Parameters
[in] blsafe_state_timeout Enabled: After device error count limit has reached the TPS transitions to the Reset State
Disabled: The TPS remains locked to the safe state even after the device error count has been reached.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//disable safe state timeout
TPS_ConfigureSafeStateTimeout(FALSE)
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_SetSafeStateTimoutDuration,TPS_SetSafeStateTimoutDuration
boolean TPS_ConfigureVDD5 ( boolean blEnableVDD5 )

The API enables voltage source VDD5.

Description:
The API sets the flag VDD5_EN in the SENS_CTRL register so as to enable the VDD5 voltage source.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureVDD5(TRUE);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_ConfigureVSOUT1 ( boolean blEnableVSOUT1 )

The API enables voltage source VSOUT1.

Description:
The API sets the flag VSOUT1_ in the SENS_CTRL register so as to enable the VSOUT1 voltage source.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ConfigureVSOUT1(TRUE);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_DriverInit ( const TPS_Initilization_struct *const init_struct )

API to set up and initialize TPS driver.

Description:
The single API can be used to set up all the required parameters of the TPS statemachine
and configure all settings.
Parameters
[out] init_struct pointer to the initialization structure which which is passed by the application.
Returns
TRUE : no errors. FALSE: Errors in execution.

Example Usage:

TPS_Initilization_struct initstruct;
memcpy(&initstruct.AMUXVoltageRailLimits,
&TPS65381Q_VoltageLimits,
sizeof(TPS65381Q_VoltageLimits));
initstruct.GetTPSDiagPinSampledValue =
TPSDiagosticPinSampledData;
initstruct.blNRES_Monitoring = TRUE;
initstruct.blbist_at_startup = TRUE;
initstruct.blenable_drv_op = TRUE;
\\Error pin monitoring is disabled here,The Halcogen startup toggles the error pin,If error monitoring is
\\enabled then appropriate settings has to be made to error monitoring(PWM low width) width
\\so that the error monitoring does not reset the TPS device.
initstruct.blerror_pin_monitoring = FALSE;
initstruct.blignition_power_latch = FALSE;
initstruct.blsafe_state_timeout = TRUE;
initstruct.dev_configreg_settings.blMASK_VBAT_OV = TRUE;
initstruct.dev_configreg_settings.blMASK_VDD1_UV = TRUE;
initstruct.dev_configreg_settings.blPOST_RUN_RST = TRUE;
initstruct.dev_configreg_settings.blVDD3_5_OT = TRUE;
initstruct.dev_configreg_settings.blVDD5_OT = TRUE;
initstruct.error_pin_monitoring_mode = ERROR_PIN_MODE;
initstruct.error_pin_pwm_width.u8PWM_HIGH = 8;
\\the min error pin low dyuration in 204.8 us
initstruct.error_pin_pwm_width.u8PWM_LOW = 40;
initstruct.send_recieve_data_TPS = SendandRecieveDataTPS;
initstruct.u8pwd_threshhold_value = 5;
initstruct.u8safe_lock_threshhold = 5;
\\timeout duration in 198 ns
initstruct.u8safe_state_timeout_scaler = 4;
TPS_DriverInit(&initstruct);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TpsIf_Init
boolean TPS_ExitDiagnosticMode ( void )

Takes the necessary actions so as to exit DIAGNOSTIC mode and enter the active mode of TPS device operation.

Description:
Clears the flags related to WD_FAIL,ERROR_PIN_FAIL etc. and sets appropriate flags so as to exit
the DIAGNSOTIC state safely and enter the active state operating mode of the TPS device.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_ExitDiagnosticMode();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Active state
See also:
TPS_ConfigureSafetyCheckControl
boolean TPS_Get3_3Vor5VSupply ( TPS_VDD_3_5_SEL * voltage_selection )

gets VDD3/VDD5 selection.

Description:
The API gets the VDD3/VDD5 selection at power up.The VDD3/5 volt selection can be made using the pin SEL_VDD3/5.
Parameters
[out] voltage_selection SEL_5V if 5V is selected by using the SEL_VDD3/5 pin.
SEL_3_3V if 3.3V is selected by using the SEL_VDD3/5 pin.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_VDD_3_5_SEL voltage_selection;
TPS_Get3_3Vor5VSupply(&voltage_selection);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetCurrentTPSDeviceState ( uint8 * u8CurrentTPSDeviceState )

Get Current TPS device State.

Description:
The API provides the value indicating the current TPS device state.
Parameters
[in] u8CurrentTPSDeviceState value indicating the current TPS
state.Please refer to section 4.16.7 to get more infomration
on the values representing the different states of the TPS.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8TPSDevState;
TPS_GetCurrentTPSDeviceState(u8TPSDevState);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetDEV_STATE ( TPS_DeviceState * dev_state )

Provide information regarding TPS.

Description:
The API reads the register DEV_STATE and provides the canwu_l
and IGN deglitched pin status.
Parameters
[in] *dev_state Structure which stores the
information regarding latched can wakeup
and deglitched ignition pin.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DeviceState devstate;
TPS_GetDEV_STATE(&devstate);
Entry Mode:
TPS in Diagnostic/Active/Safe state.c
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetDeviceErrorCount ( uint8 * u8DeviceErrorCount )

API provides the device error count value in TPS.

Description:
API provides the device error count value in TPS.The device
error count increases every time when the device transits to
Safe state.
Parameters
[out] u8DeviceErrorCount Device error count
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint8 u8DevErrCount;
TPS_GetDeviceErrorCount(&u8DevErrCount);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_ClearDeviceErrorCount
boolean TPS_GetDeviceInformation ( TPS_DeviceInformation * device_information )

The API provides TPS device information.

Description:
The API provides TPS device information such as major version,minor version and device ID.
Parameters
[out] device_information Structure containing the device information such as device ID and major,minor version.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DeviceInformation devinfo;
TPS_GetDeviceInformation(&devinfo);
Entry Mode:
TPS in Diagnostic/Active/Safe
Exit Mode:
TPS in Diagnostic/Active/Safe
boolean TPS_GetENDRVErrorStatus ( boolean * blENDRVError )

The API provides Enable drive error status.

Description:
The API provide enable drive error status.The enable drive
error gets set when there is mismatch between EN_DRV output and EN_DRV
feedback.
Parameters
[in] *blENDRVError if TRUE the ENDRV_ERR is set.ENDRV_ERR get set
is mismatch between the EN_DRV output and EN_DRV feedback is
detected.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blEndrvErrstatus;
TPS_GetENDRVErrorStatus(&blEndrvErrstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetErrorPinFailureStatusFlag ( boolean * blFailureStatus )

The API provides failure status information of the error pin of MCU.

Description:
The API provides failure status information of the error pin.
Parameters
[in] *blFailureStatus if TRUE the error pin failure has occurred
if False no error pin failure
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

boolean blfailstatus;
TPS_GetErrorPinFailureStatusFlag(&blfailstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_ClearErrorPinFailureStatusFlag
boolean TPS_GetJnTempandCurrentLimitStatus ( TPS_JnTempCurrentLimitStatus * JnTempCurrentLtMonitoring )

Provide status of junction temperature monitoring and current limit status.

Description:
The API gets the registers SAFETY_STAT_1 and k
updates the vmon status structure with the relevant information
The API can be used to know the voltage monitoring status
of the TPS device.
Parameters
[in] *JnTempCurrentLtMonitoring Structure which stores the
information regarding the\ junction
Temperature monitoring and current
limit status.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_JnTempCurrentLimitStatus jntempcurrentmonitoringstatus;
TPS_GetJnTempandCurrentLimitStatus(&jntempcurrentmonitoringstatus);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetSPIErrorStatus ( TPS_SPIErrorType * spi_error_status )

Provide device the error status of the previous SPI transmission.

Description:
The API reads the register SAFETY_STAT_4 and provides the SPI
error status information.
Parameters
[in] *spi_error_status Structure which stores the
information regarding the spi error status.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SPIErrorType spierr;
TPS_GetSPIErrorStatus(&spierr);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GetTPSDeviceConfiguration ( TPS_DevCfg_reg_settings * config_register_settings )

Provide device confiuration(setting made in the DEV_CFG1 and DEV_CFG2 register)

Description:
The API gets the registers DEV_CFG1 and DEV_CFG2 and updates
device_configuation structure with the relevant information
The API can be used to know the current TPS device configuration.
Parameters
[in] *device_configuation Structure which stores the
information regarding the dev config
register settings of the TPS device
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_DevCfg_reg_settings tps_dev_cfg_regs;
TPS_GetTPSDeviceConfiguration(&tps_dev_cfg_regs);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
See also:
TPS_SetTPSDeviceConfigurationRegisters
boolean TPS_GetVMONStatus ( TPS_OverallVMONStatus * vmon_status )

Provide status of the Voltage monitoring by the TPS.

Description:
The API gets the registers VMON_STAT_1 and VMON_STAT_2 and
updates the vmon status structure with the relevant information
The API can be used to know the voltage monitoring status
of the TPS device.
Parameters
[in] *vmon_status Structure which stores the information regarding the
voltage monitoring status(VMON_STAT_1,VMON_STAT_2)
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_OverallVMONStatus overall_vmon_status;
TPS_GetVMONStatus(&overall_vmon_status);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_GoToSafeState ( void )

The API moves the TPS device safe state(from Active state).

Description:
The API moves the TPS device to safe state.by creating an error in the MCU. Note: The error monitoring is enabled by setting the bit NO_ERROR in safety check control to 0
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_GoToSafeState();
Entry Mode:
TPS in Active
Exit Mode:
TPS in Safe
boolean TPS_ProtectConfigurationRegisters ( TPS_HandleConfigurationRegisters state )

LOCK/UNLOCK (protect) the configuration registers for writing.

Description:
The Device configuration registers can be protected/released (for writing) by using this API.
Parameters
[in] state LOCK - Lock the device configuration registers for writing. UNLOCK - unlock device configuration registers for writing
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//LOCK the writing to TPS protected registers
TPS_ProtectConfigurationRegisters(LOCK);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_RegReadBackandCompare ( TPS_Test_Result * readback_compare )

Register read back and compare.

Description:
The API compares the init_configuration(the user configured configuration)
against the read back configuration(reads the configuration from the TPS device).
Parameters
[out] readback_compare TEST_PASS if the read back and comparison has passed.
TEST_FAIL if read back and comparison has failed
Returns
TRUE : no errors execution has succeeded. FALSE: Errors in execution

Example Usage:

TPS_Test_Result readback_compare_test;
TPS_RegReadBackandCompare(&readback_compare_test);
Entry Mode:
TPS in Diagnostic/Active/Safe state.
Exit Mode:
TPS in Diagnostic/Active/Safe state.
boolean TPS_SetMCUSoftwareDebugMode ( void )

Set TPS device configuration so to support MCU software debug.

Description:
Set TPS device configuration so to support MCU software debug.
The API sets specific flags such as DIAG EXIT MASK,NO_SAFE _TO
etc. bits so as to support MCU debug.Calling this APi corrupts
the initial settings made by the TPS_DriverInit API. So the
TPS_DriverInit has to be called so as to come back to the
init state.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetMCUSoftwareDebugMode();
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetPowerDownThreshhold ( uint8 u8threshhold_value )

Set power down threshold value.

Description:
The API is used to set the power down threshold value in the
register PWD_THR_CFG register.
Parameters
[out] u8threshhold_value Device error-count threshold to power down the device.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetPowerDownThreshhold(0x3);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetSafeLockThreshhold ( uint8 u8SafeLockThreshhold )

Set device ERROR COUNT threshold value.

Description:
The API sets the device error count threshold value.Be Safe state timeout is disabled the device remains locked in the Safe State
even after the device error count even beyond this safe lock threshold value.
Parameters
[in] u8SafeLockThreshhold Device ERROR COUNT threshold value.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetSafeLockThreshhold(0x5);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
boolean TPS_SetSafeStateTimoutDuration ( uint8 u8SafeStateTOtDuration_scaler )

Set Safe State time out duration.

Description:
Writes to the safety error configuration register so as to set safe state time out duration.Afer each error the device enters safe state from the active state
It remains in safe state until this time out duration before trasiting to the reset state.(when the device error count is lesser than the configured threshold value.
Parameters
[in] u8SafeStateTimoutDuration_scaler scaler value which decides the safe state timeout duration.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetSafeStateTimoutDuration(3);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_ConfigureSafeStateTimeout
boolean TPS_SetTPSDeviceConfigurationRegisters | ( | TPS_DeviceConfigRegisterSettings | field,
 |  | boolean | blvalue
 | ) |  |

The API helps in setting the device configuration register.

Description:
The APi when called with specific field value and proper setting of the enable_disable configures the features of TPS such as MASK_VVD3_OV,POST_RUN_RST etc.Please refer to section 4.15.3 in the TPS65381 detached.
Parameters
[in] field Feature(in the device configuration or the flag) which
has to enabled or disabled.It also indicates the field
in the configuration which has to be modified.
[in] blvalue parameter indicating whether the feature has to be
enabled or disabled
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_SetTPSDeviceConfigurationRegisters(MASK_VDD1_UV,TRUE);
Entry Mode:
TPS in Diagnostic state.
Exit Mode:
TPS in Diagnostic state.
See also:
TPS_GetTPSDeviceConfiguration
boolean TPS_TestErrorPinMonitoring ( TPS_Test_Result * ErrorPinMonitoring_Test )

The API does the selftest of the error pin monitoring.

Description:
The API does of the selftest of the error pin monitoring.Can be called only in diagnostic mode
. The API makes sure that the ERROR_PIN_FAIL flag is appropriately set when the mcu error pin is
low for more than 15us.
Parameters
[out] ErrorPinMonitoring_Test TEST_PASS if the error monitoring is successful has passed.
TEST_FAIL if error monitoring has failed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result errorpinmonitoringtest;
TPS_TestErrorPinMonitoring(&errorpinmonitoringtest);
Entry Mode:
TPS in Diagnostic
Exit Mode:
TPS in Diagnostic
See also:
TPS_ConfigureErrorMonitoring
boolean TPS_UpdateDatastringforCRCCaclcuation | ( | uint32 | u32DataforCRC[2],
 |  | uint16 | u16reg
 | ) |  |

The API updates the 64 bit data string for 8 bit crc calculation for specified register.

Description:
The API updates the 64 bit data for crc with updated contents for the specified register. It updates the necessary fields for the specified register in the 64 bit data.
Parameters
[in] | *u32DataforCRC | pointer to the 64 bit data which has to be initialized for the calculation of the 8 bit crc.
[in] | u16reg | the register for which the contents in the data string (for crc calculation) needs to be updated.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

uint32 u32dataforcrc[2] = {0U,0U};
TPS_UpdateDatastringforCRCCaclcuation(u32dataforcrc,TPS_DEV_CFG2);
Entry Mode:
TPS in Diagnostic/active state(This is used normally after
TPS_InitializeDatastringforCRCCaclcuation called once) to
a individual field of the CRC string.
Exit Mode:
TPS in Diagnostic/Active state.
See also:
API used for handling CRC protection of configuration registers and EEPROM.
#include "TPS_Driver.h"
#include "TPS_DebugSupport.h"
#include "TPS_Priv.h"
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source/Tps_Interface.h File Reference

  • TPS_Driver
  • source
Tps_Interface.h File Reference

File contains the TPS interfacing api's prototypes for
read,write and verifying SPI mapped registers. More...

Detailed Description

File contains the TPS interfacing api's prototypes for
read,write and verifying SPI mapped registers.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

todo

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version created

Function Documentation

boolean TpsIf_GetRegister | ( | const TPS_Registers | TPSReg,
 |  | uint8 * | u8value
 | ) |  |

Read Register Value.

Description:
Read the value in the specified register of the TPS device.
Parameters
[in] | TPSReg | offest of Tps register
[out] | *u8value | binary value read from the register.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SAFETY_FUNC_CFG is the TPS register
blRetVal = TpsIf_GetRegister(TPS_SAFETY_CHECK_CTRL,
&u8safety_check_ctrl);
Entry Mode:
anymode of TPS
Exit Mode:
anymode of TPS
boolean TpsIf_GetRegisterBitField | ( | const TPS_Registers | TPSReg,
 |  | const uint8 | u8bfstart,
 |  | const uint8 | u8bflength,
 |  | uint8 * | u8value
 | ) |  |

Read Register bitfield Value.

Description:
Read the value in the appropriate bitfield of specified register.
Parameters
[in] | TPSReg | offest of Tps register
[in] | u8bfstart | start of the bitfied(value ranges from 0 to 7).
[in] | u8length | length of the bitfied to be read.
[out] | *u8value | binary value of the bitfield.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SAFETY_ERR_STAT is the TPS register
blRetVal = TpsIf_GetRegisterBitField(TPS_SAFETY_ERR_STAT,
BF_ERROR_PIN_FAIL_START, BF_ERROR_PIN_FAIL_LENGTH, &u8bitavalue);
Entry Mode:
anymode of TPS
Exit Mode:
anymode of TPS
void TpsIf_Init ( send_recieve_data snd_rcv_data_api )

Initialize TPS interface.

Description:
Initialize TPS interface.Updates the global inteface function pointer which can be used to communicate to TPS device.
Parameters
[in] snd_rcv_data_api function pointer for send and receive data api(application supported)
Returns
None

Example Usage:

//SendandRecieveDataTPS is an API of type boolean SendandRecieveDataTPS(const uint16* const u16TransmitData,const uint32 u32TransmitSize,volatile uint16* u16RecieveData,uint32 *u32RecieveSize)
TpsIf_Init(send_recieve_data_TPS);
Entry Mode:
Diagnostic state of the TPS device.
Exit Mode:
Diagnostic state of the TPS device.
See also:
TPS_DriverInit
boolean TpsIf_SetRegister | ( | const TPS_Registers | TPSReg,
 |  | const uint8 | u8value
 | ) |  |

Write Register Value.

Description:
Seg value given for a TPS Register specified.
Parameters
[in] | TPSReg | offest of Tps register
[in] | u8value | binary value to write to bit.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SW_LOCK is the TPS register being set
blRetVal = TpsIf_SetRegister(TPS_SW_LOCK, (uint8)0x55U);
Entry Mode:
The TPS state can be anything depends on whether the register being set is accesible in the particular TPS mode
Exit Mode:
same as entry
boolean TpsIf_SetRegisterBitField | ( | const TPS_Registers | TPSReg,
 |  | const uint8 | u8bfstart,
 |  | const uint8 | u8bflength,
 |  | const uint8 | u8value
 | ) |  |

Set Register bitfield Value.

Description:
Set Register bitfield vaule in the specified register.
Parameters
[in] | TPSReg | offest of Tps register
[in] | u8bfstart | start of the bitfied(value ranges from 0 to 7).
[in] | u8length | length of the bitfied to be read.
[out] | *u8value | binary value of the bitfield.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SAFETY_CHECK_CTRL is the TPS register
blRetVal = ((TpsIf_SetRegisterBitField(TPS_SAFETY_CHECK_CTRL,
BF_DIAG_EXIT_START, BF_DIAG_EXIT_LENGTH, (uint8)1U)) && blRetVal);
Entry Mode:
The TPS state can be anything depends on whether the register being set is accesible in the particular TPS mode
Exit Mode:
same as entry
boolean TpsIf_SetRegisterBitFieldVerify | ( | const TPS_Registers | TPSReg,
 |  | const uint8 | u8bfstart,
 |  | const uint8 | u8bflength,
 |  | const uint8 | u8value
 | ) |  |

Set Register bitfield Value and verify.

Description:
Set value given in the secifed bitfield of the specified register.
Parameters
[in] | TPSReg | offest of Tps register
[in] | u8bfstart | start of the bitfied(value ranges from 0 to 7).
[in] | u8length | length of the bitfied to be read.
[out] | *u8value | binary value of the bitfield.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SAFETY_FUNC_CFG is the TPS register
blRetVal = TpsIf_SetRegisterBitFieldVerify(TPS_SAFETY_FUNC_CFG,
BF_NO_SAFE_TO_START, BF_NO_SAFE_TO_LENGTH, 0U);
Entry Mode:
The TPS state can be anything depends on whether the register being set is accesible in the particular TPS mode
Exit Mode:
same as entry
boolean TpsIf_SetRegisterVerify | ( | const TPS_Registers | TPSReg,
 |  | const uint8 | u8value
 | ) |  |

Write Register Value and Verify.

Description:
Set given value in the specified register and vrify by reading it back.
Parameters
[in] | TPSReg | offest of Tps register
[in] | u8value | binary value to write to bit.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

//TPS_SAFETY_CFG_CRC is the TPS register being set
TpsIf_SetRegisterVerify(TPS_SAFETY_CFG_CRC, u8safetycfgcrc);
Entry Mode:
The TPS state can be anything depends on whether the register being set is accesible in the particular TPS mode
Exit Mode:
same as entry
boolean TpsIf_SpiIFTestPwmlow ( TPS_Test_Result * selftest_result )

test PwmLow Register writes.

Description:
Write a arbitrary value to the PwmLow register, reads back to verify.
It effectively tests that the SPI interface is working fine.
Parameters
[out] *selftest_result the parameter stores the pass fail status of the test performed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result testSPIIFTest;
TpsIf_SpiIFTestPwmlow(&testSPIIFTest)
Entry Mode:
anymode of TPS
Exit Mode:
anymode of TPS
boolean TpsIf_TestCommandParityLogic ( TPS_Test_Result * selftest_result )

test command parity logic.

Description:
Send a u16Command with wrong parity.
Parameters
[out] *selftest_result the parameter stores the pass fail status of the test performed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result CommandParityTest;
TpsIf_TestCommandParityLogic(&CommandParityTest)
Entry Mode:
anymode of TPS
Exit Mode:
anymode of TPS
boolean TpsIf_TestWrongCommandLogic ( TPS_Test_Result * selftest_result )

test wrong command logic.

Description:
Send a wrong u16Command with correct parity
Parameters
[out] *selftest_result the parameter stores the pass fail status of the test performed.
Returns
TRUE : no errors FALSE: Errors in execution

Example Usage:

TPS_Test_Result testwrongcommand;
TpsIf_TestWrongCommandLogic(&testwrongcommand)
Entry Mode:
anymode of TPS
Exit Mode:
anymode of TPS
#include "TPS_Types.h"
#include "TPS_DebugSupport.h"

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source/Tps_priv.h File Reference

  • TPS_Driver
  • source
Tps_priv.h File Reference

private macros used by the TPS driver. More...

Detailed Description

private macros used by the TPS driver.

COPYRIGHT

*
*                 TEXAS INSTRUMENTS INCORPORATED PROPRIETARY INFORMATION
*
*                 Property of Texas Instruments, Unauthorized reproduction and/or distribution
*                 is strictly prohibited.  This product  is  protected  under  copyright  law
*                 and  trade  secret law as an  unpublished work.
*                 (C) Copyright Texas Instruments.  All rights reserved.
*
*

FILE DESCRIPTION

   @version    2.2.0
   @component  TPS
   @module     TPS Library
   @generator  No Configuration

The file defines private macros used within the TPS
Driver.These macros are not available to application.

Manoj

Revision History

Version | Date | Author | Change ID | Description
2.2.0 | 20Dec2012 | Manoj R | 00000000000 | Initial version created
#include "Tps_Config.h"

Go to the source code of this file.

Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- _ -

  • _TPS_AMUXSignals : Tps_Types.h
  • _TPS_BistTypes : Tps_Types.h
  • _TPS_DeviceConfigRegisterSettings : Tps_Types.h
  • _TPS_DMUXSignals : Tps_Types.h
  • _TPS_ErrorPinMonitoringMode : Tps_Types.h
  • _TPS_HandleConfigurationRegisters : Tps_Types.h
  • _TPS_Registers : Tps_Types.h
  • _TPS_SafetyBISTControlRegisterSettings : Tps_Types.h
  • _TPS_SafetyCheckControl : Tps_Types.h
  • _TPS_SPIErrorType : Tps_Types.h
  • _TPS_Test_Result : Tps_Types.h
  • _TPS_TestRunningStatus : Tps_Types.h
  • _TPS_VDD_3_5_SEL : Tps_Types.h
  • _TPS_WatchdogMode : Tps_Types.h
  • _TPS_WatchdogWindows : Tps_Types.h
  • _TPS_WDResponse : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • ABIST : Tps_Types.h
  • AMUX_MAX : Tps_Types.h
  • AMUX_MIN : Tps_Types.h
  • AUTO_BIST : Tps_Types.h
  • AVDD_UVN : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • BAD_ANSWER : Tps_Types.h
  • BG_ERR1 : Tps_Types.h
  • BG_ERR2 : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CFG_CRC : Tps_Types.h
  • CLOSE_WINDOW : Tps_Types.h
  • COMMAND_ERROR : Tps_Types.h
  • CP_DIFF3V : Tps_Types.h
  • CP_OV : Tps_Types.h
  • CP_PH1 : Tps_Types.h
  • CP_PH2 : Tps_Types.h
  • CP_UVN : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • DATA_OP_MISMATCH : Tps_Types.h
  • DEBUG : Tps_Types.h
  • DEBUG_ENABLE : Tps_Config.h
  • DFT1 : Tps_Types.h
  • DFT2 : Tps_Types.h
  • DFT3 : Tps_Types.h
  • DFT4 : Tps_Types.h
  • DIAG_EXIT : Tps_Types.h
  • DIAG_EXIT_MASK : Tps_Types.h
  • DMUX_MAX : Tps_Types.h
  • DMUX_MIN : Tps_Types.h
  • DMUX_VDD3_5_OT : Tps_Types.h
  • DMUX_VDD5_OT : Tps_Types.h
  • DRV_OUTPUT : Tps_Types.h
  • DVDD_OV : Tps_Types.h
  • DVDD_UV : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • EE_CRC_CHK : Tps_Types.h
  • ERROR : Tps_Types.h
  • ERROR_ENABLE : Tps_Config.h
  • ERROR_PIN_MODE : Tps_Types.h
  • ERROR_PIN_MONITORING : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FORMAT_ERROR : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • INFO : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- l -

  • LBIST : Tps_Types.h
  • LOCK : Tps_Types.h
  • LOCLK : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- m -

  • MAIN_BG : Tps_Types.h
  • MASK_VBAT_OV : Tps_Types.h
  • MASK_VDD1_UV : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- n -

  • NO_ERROR : Tps_Types.h
  • NRST_EXT_IN : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- o -

  • OPEN_WINDOW : Tps_Types.h
  • OVER : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • POST_RUN_RST : Tps_Types.h
  • PWM_MONITORING_MODE : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- q -

  • QANDA_MODE : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- r -

  • RD_COMMAND_NONE : Tps_priv.h
  • RD_DEV_CFG1 : Tps_priv.h
  • RD_DEV_CFG2 : Tps_priv.h
  • RD_DEV_ID : Tps_priv.h
  • RD_DEV_REV : Tps_priv.h
  • RD_DEV_STAT : Tps_priv.h
  • RD_DIAG_CFG_CTRL : Tps_priv.h
  • RD_DIAG_MUX_SEL : Tps_priv.h
  • RD_SAFETY_BIST_CTRL : Tps_priv.h
  • RD_SAFETY_CFG_CRC : Tps_priv.h
  • RD_SAFETY_CHECK_CTRL : Tps_priv.h
  • RD_SAFETY_ERR_CFG : Tps_priv.h
  • RD_SAFETY_ERR_PWM_H : Tps_priv.h
  • RD_SAFETY_ERR_PWM_L : Tps_priv.h
  • RD_SAFETY_ERR_STAT : Tps_priv.h
  • RD_SAFETY_FUNC_CFG : Tps_priv.h
  • RD_SAFETY_PWD_THR_CFG : Tps_priv.h
  • RD_SAFETY_STAT_1 : Tps_priv.h
  • RD_SAFETY_STAT_2 : Tps_priv.h
  • RD_SAFETY_STAT_3 : Tps_priv.h
  • RD_SAFETY_STAT_4 : Tps_priv.h
  • RD_SAFETY_STAT_5 : Tps_priv.h
  • RD_SENS_CTRL : Tps_priv.h
  • RD_VMON_STAT_1 : Tps_priv.h
  • RD_VMON_STAT_2 : Tps_priv.h
  • RD_WD_WIN1_CFG : Tps_priv.h
  • RD_WD_WIN2_CFG : Tps_priv.h
  • RD_WDT_STATUS : Tps_priv.h
  • RD_WDT_TOKEN_FDBCK : Tps_priv.h
  • RD_WDT_TOKEN_VALUE : Tps_priv.h
  • RD_WRONG_COMMAND : Tps_priv.h
  • RD_WRONG_PARITY : Tps_priv.h
  • RST_EXT_CLK : Tps_Types.h
  • RSV1 : Tps_Types.h
  • RSV2 : Tps_Types.h
  • RSV3 : Tps_Types.h
  • RSV4 : Tps_Types.h
  • RSV5 : Tps_Types.h
  • RUNNING : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • SDO_RDBCK : Tps_Types.h
  • SEL_3_3V : Tps_Types.h
  • SEL_5V : Tps_Types.h
  • send_recieve_data : Tps_Types.h
  • SendDebugText : Tps_Types.h
  • SPI_CLK : Tps_Types.h
  • SPI_NCS : Tps_Types.h
  • SPI_SDI : Tps_Types.h
  • SRAM_END : Tps_Config.h
  • SRAM_START : Tps_Config.h
  • SYS_CLK : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- t -

  • T_15US : Tps_Types.h
  • T_2MS : Tps_Types.h
  • T_40US : Tps_Types.h
  • T_5US : Tps_Types.h
  • TEST_FAIL : Tps_Types.h
  • TEST_PASS : Tps_Types.h
  • TPS_CalculateCRC8() : Tps_Driver.h , Tps_Driver.c
  • TPS_CheckEnabledAMUXSignalLimits() : Tps_Driver.c , Tps_Driver.h
  • TPS_ClearDeviceErrorCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_ClearErrorPinFailureStatusFlag() : Tps_Driver.c , Tps_Driver.h
  • TPS_ClearWatchdogFailureStatusFlag() : Tps_Driver.h , Tps_Driver.c
  • TPS_ConfigureBISTatStartup() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureErrorMonitoring() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureIgnintionPowerLatchControl() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureNRESMonitoring() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureSafeStateTimeout() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureSafetyCheckControl() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureVDD5() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureVSOUT1() : Tps_Driver.h , Tps_Driver.c
  • TPS_ConfigureWatchdogReset() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureWatchdogWindows() : Tps_Driver.c , Tps_Driver.h
  • TPS_DebugInit() : TPS_DebugSupport.h
  • TPS_DebugSeverity : Tps_Types.h
  • TPS_DEV_CFG1 : Tps_Types.h
  • TPS_DEV_CFG2 : Tps_Types.h
  • TPS_DEV_ID : Tps_Types.h
  • TPS_DEV_REV : Tps_Types.h
  • TPS_DEV_STAT : Tps_Types.h
  • TPS_DEVICE_ACTIVE : Tps_Types.h
  • TPS_DEVICE_DIAGNOSTIC : Tps_Types.h
  • TPS_DEVICE_RESET : Tps_Types.h
  • TPS_DEVICE_SAFE : Tps_Types.h
  • TPS_DEVICE_STANDBY : Tps_Types.h
  • TPS_DIAG_CFG_CTRL : Tps_Types.h
  • TPS_DIAG_MUX_SEL : Tps_Types.h
  • TPS_DisableMUXDiagnostic() : Tps_Driver.c , Tps_Driver.h
  • TPS_DriverInit() : Tps_Driver.c , Tps_Driver.h
  • TPS_EnableAMUXSignal() : Tps_Driver.c , Tps_Driver.h
  • TPS_EnableDMUXSignal() : Tps_Driver.c , Tps_Driver.h
  • TPS_ExitDiagnosticMode() : Tps_Driver.c , Tps_Driver.h
  • TPS_FaultInjectCRC() : Tps_Driver.c , Tps_Driver.h
  • TPS_FaultInjectWD() : Tps_Driver.h , Tps_Driver.c
  • TPS_Get3_3Vor5VSupply() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetABISTTestStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetBISTRunningStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetCRCErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetCurrentTPSDeviceState() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDEV_STATE() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDeviceErrorCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDeviceInformation() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetEECRCCheckRunningStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetENDRVErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetErrorPinFailureStatusFlag() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetJnTempandCurrentLimitStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetLBISTTestStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetNRESErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetSPIErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetTPSDeviceConfiguration() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetVMONStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogAnswerCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogErrorType() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogFailCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogFailureStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GoToSafeState() : Tps_Driver.c , Tps_Driver.h
  • TPS_InitializeDatastringforCRCCaclcuation() : Tps_Driver.c , Tps_Driver.h
  • TPS_ProtectConfigurationRegisters() : Tps_Driver.c , Tps_Driver.h
  • TPS_RegReadBackandCompare() : Tps_Driver.c , Tps_Driver.h
  • TPS_SAFETY_BIST_CTRL : Tps_Types.h
  • TPS_SAFETY_CFG_CRC : Tps_Types.h
  • TPS_SAFETY_CHECK_CTRL : Tps_Types.h
  • TPS_SAFETY_ERR_CFG : Tps_Types.h
  • TPS_SAFETY_ERR_PWM_H : Tps_Types.h
  • TPS_SAFETY_ERR_PWM_L : Tps_Types.h
  • TPS_SAFETY_ERR_STAT : Tps_Types.h
  • TPS_SAFETY_FUNC_CFG : Tps_Types.h
  • TPS_SAFETY_PWD_THR_CFG : Tps_Types.h
  • TPS_SAFETY_STAT_1 : Tps_Types.h
  • TPS_SAFETY_STAT_2 : Tps_Types.h
  • TPS_SAFETY_STAT_3 : Tps_Types.h
  • TPS_SAFETY_STAT_4 : Tps_Types.h
  • TPS_SAFETY_STAT_5 : Tps_Types.h
  • TPS_SendDebugText() : TPS_DebugSupport.h
  • TPS_SendWdgResponse() : Tps_Driver.c , Tps_Driver.h
  • TPS_SENS_CTRL : Tps_Types.h
  • TPS_SetMCUSoftwareDebugMode() : Tps_Driver.h , Tps_Driver.c
  • TPS_SetPowerDownThreshhold() : Tps_Driver.h , Tps_Driver.c
  • TPS_SetSafeLockThreshhold() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetSafeStateTimoutDuration() : Tps_Driver.h , Tps_Driver.c
  • TPS_SetTPSDeviceConfigurationRegisters() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetWatchdogMode() : Tps_Driver.h , Tps_Driver.c
  • TPS_StartBIST() : Tps_Driver.c , Tps_Driver.h
  • TPS_StartEECRCCheck() : Tps_Driver.h , Tps_Driver.c
  • TPS_SW_LOCK : Tps_Types.h
  • TPS_SW_UNLOCK : Tps_Types.h
  • TPS_TestErrorPinMonitoring() : Tps_Driver.h , Tps_Driver.c
  • TPS_UpdateActiveWDToken() : Tps_Driver.h , Tps_Driver.c
  • TPS_UpdateDatastringforCRCCaclcuation() : Tps_Driver.c , Tps_Driver.h
  • TPS_UpdateRegisterSafetyCfgCRC() : Tps_Driver.h , Tps_Driver.c
  • TPS_VMON_STAT_1 : Tps_Types.h
  • TPS_VMON_STAT_2 : Tps_Types.h
  • TPS_WatchdogInit() : Tps_Driver.c , Tps_Driver.h
  • TPS_WDFaultType : Tps_Types.h
  • TPS_WDSetTokenFDBCKValue() : Tps_Driver.c , Tps_Driver.h
  • TPS_WDSetTokenSeedValue() : Tps_Driver.h , Tps_Driver.c
  • TPS_WDT_ANSWER : Tps_Types.h
  • TPS_WDT_STATUS : Tps_Types.h
  • TPS_WDT_TOKEN_FDBCK : Tps_Types.h
  • TPS_WDT_TOKEN_VALUE : Tps_Types.h
  • TPS_WDT_WIN1_CFG : Tps_Types.h
  • TPS_WDT_WIN2_CFG : Tps_Types.h
  • TpsIf_COMMAND_t : Tps_priv.h
  • TpsIf_GetRegister() : Tps_Interface.h
  • TpsIf_GetRegisterBitField() : Tps_Interface.h
  • TpsIf_Init() : Tps_Interface.h
  • TpsIf_SetRegister() : Tps_Interface.h
  • TpsIf_SetRegisterBitField() : Tps_Interface.h
  • TpsIf_SetRegisterBitFieldVerify() : Tps_Interface.h
  • TpsIf_SetRegisterVerify() : Tps_Interface.h
  • TpsIf_SpiIFTestPwmlow() : Tps_Interface.h
  • TpsIf_TestCommandParityLogic() : Tps_Interface.h
  • TpsIf_TestWrongCommandLogic() : Tps_Interface.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • UC_ERROR_WDI : Tps_Types.h
  • UC_ERROR_WDI_RED : Tps_Types.h
  • UNLOCK : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- v -

  • VBAT : Tps_Types.h
  • VBAT_SAFING : Tps_Types.h
  • VBAT_UVN : Tps_Types.h
  • VBATP_OV : Tps_Types.h
  • VCP : Tps_Types.h
  • VCP12_NUV : Tps_Types.h
  • VCP12_OV : Tps_Types.h
  • VCP17_OV : Tps_Types.h
  • VDD1_NUV : Tps_Types.h
  • VDD1_OV : Tps_Types.h
  • VDD3_5_NUV : Tps_Types.h
  • VDD3_5_OT : Tps_Types.h
  • VDD3_5_OV : Tps_Types.h
  • VDD3_CL : Tps_Types.h
  • VDD5 : Tps_Types.h
  • VDD5_CL : Tps_Types.h
  • VDD5_NUV : Tps_Types.h
  • VDD5_OT : Tps_Types.h
  • VDD5_OV : Tps_Types.h
  • VDD6 : Tps_Types.h
  • VDD6_NUV : Tps_Types.h
  • VDD6_OV : Tps_Types.h
  • VMON_BG : Tps_Types.h
  • VMON_TRIM_ER : Tps_Types.h
  • VS_TRK_MODE : Tps_Types.h
  • VSFB1 : Tps_Types.h
  • VSOUT_ILIM : Tps_Types.h
  • VSOUT_OT : Tps_Types.h
  • VSOUT_OV : Tps_Types.h
  • VSOUT_UVN : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- w -

  • WD_TOKEN_RESP0 : Tps_Types.h
  • WD_TOKEN_RESP1 : Tps_Types.h
  • WD_TOKEN_RESP2 : Tps_Types.h
  • WD_TOKEN_RESP3 : Tps_Types.h
  • WDT_CLK : Tps_Types.h
  • WDTI_MODE : Tps_Types.h
  • WR_CAN_STBY : Tps_priv.h
  • WR_COMMAND_NONE : Tps_priv.h
  • WR_DEV_CFG1 : Tps_priv.h
  • WR_DEV_CFG2 : Tps_priv.h
  • WR_DIAG_CFG_CTRL : Tps_priv.h
  • WR_DIAG_MUX_SEL : Tps_priv.h
  • WR_SAFETY_BIST_CTRL : Tps_priv.h
  • WR_SAFETY_CFG_CRC : Tps_priv.h
  • WR_SAFETY_CHECK_CTRL : Tps_priv.h
  • WR_SAFETY_ERR_CFG : Tps_priv.h
  • WR_SAFETY_ERR_PWM_H : Tps_priv.h
  • WR_SAFETY_ERR_PWM_L : Tps_priv.h
  • WR_SAFETY_ERR_STAT : Tps_priv.h
  • WR_SAFETY_FUNC_CFG : Tps_priv.h
  • WR_SAFETY_PWD_THR_CFG : Tps_priv.h
  • WR_SENS_CTRL : Tps_priv.h
  • WR_SW_LOCK : Tps_priv.h
  • WR_SW_UNLOCK : Tps_priv.h
  • WR_WD_WIN1_CFG : Tps_priv.h
  • WR_WD_WIN2_CFG : Tps_priv.h
  • WR_WDT_ANSWER : Tps_priv.h
  • WR_WDT_TOKEN_FDBCK : Tps_priv.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • t

- t -

  • TPS_CalculateCRC8() : Tps_Driver.c , Tps_Driver.h
  • TPS_CheckEnabledAMUXSignalLimits() : Tps_Driver.h , Tps_Driver.c
  • TPS_ClearDeviceErrorCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_ClearErrorPinFailureStatusFlag() : Tps_Driver.h , Tps_Driver.c
  • TPS_ClearWatchdogFailureStatusFlag() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureBISTatStartup() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureErrorMonitoring() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureIgnintionPowerLatchControl() : Tps_Driver.h , Tps_Driver.c
  • TPS_ConfigureNRESMonitoring() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureSafeStateTimeout() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureSafetyCheckControl() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureVDD5() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureVSOUT1() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureWatchdogReset() : Tps_Driver.c , Tps_Driver.h
  • TPS_ConfigureWatchdogWindows() : Tps_Driver.c , Tps_Driver.h
  • TPS_DebugInit() : TPS_DebugSupport.h
  • TPS_DisableMUXDiagnostic() : Tps_Driver.c , Tps_Driver.h
  • TPS_DriverInit() : Tps_Driver.c , Tps_Driver.h
  • TPS_EnableAMUXSignal() : Tps_Driver.c , Tps_Driver.h
  • TPS_EnableDMUXSignal() : Tps_Driver.c , Tps_Driver.h
  • TPS_ExitDiagnosticMode() : Tps_Driver.c , Tps_Driver.h
  • TPS_FaultInjectCRC() : Tps_Driver.c , Tps_Driver.h
  • TPS_FaultInjectWD() : Tps_Driver.c , Tps_Driver.h
  • TPS_Get3_3Vor5VSupply() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetABISTTestStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetBISTRunningStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetCRCErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetCurrentTPSDeviceState() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDEV_STATE() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDeviceErrorCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetDeviceInformation() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetEECRCCheckRunningStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetENDRVErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetErrorPinFailureStatusFlag() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetJnTempandCurrentLimitStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetLBISTTestStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetNRESErrorStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetSPIErrorStatus() : Tps_Driver.h , Tps_Driver.c
  • TPS_GetTPSDeviceConfiguration() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetVMONStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogAnswerCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogErrorType() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogFailCount() : Tps_Driver.c , Tps_Driver.h
  • TPS_GetWatchdogFailureStatus() : Tps_Driver.c , Tps_Driver.h
  • TPS_GoToSafeState() : Tps_Driver.c , Tps_Driver.h
  • TPS_InitializeDatastringforCRCCaclcuation() : Tps_Driver.c , Tps_Driver.h
  • TPS_ProtectConfigurationRegisters() : Tps_Driver.c , Tps_Driver.h
  • TPS_RegReadBackandCompare() : Tps_Driver.h , Tps_Driver.c
  • TPS_SendDebugText() : TPS_DebugSupport.h
  • TPS_SendWdgResponse() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetMCUSoftwareDebugMode() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetPowerDownThreshhold() : Tps_Driver.h , Tps_Driver.c
  • TPS_SetSafeLockThreshhold() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetSafeStateTimoutDuration() : Tps_Driver.h , Tps_Driver.c
  • TPS_SetTPSDeviceConfigurationRegisters() : Tps_Driver.c , Tps_Driver.h
  • TPS_SetWatchdogMode() : Tps_Driver.c , Tps_Driver.h
  • TPS_StartBIST() : Tps_Driver.h , Tps_Driver.c
  • TPS_StartEECRCCheck() : Tps_Driver.h , Tps_Driver.c
  • TPS_TestErrorPinMonitoring() : Tps_Driver.c , Tps_Driver.h
  • TPS_UpdateActiveWDToken() : Tps_Driver.c , Tps_Driver.h
  • TPS_UpdateDatastringforCRCCaclcuation() : Tps_Driver.c , Tps_Driver.h
  • TPS_UpdateRegisterSafetyCfgCRC() : Tps_Driver.h , Tps_Driver.c
  • TPS_WatchdogInit() : Tps_Driver.c , Tps_Driver.h
  • TPS_WDSetTokenFDBCKValue() : Tps_Driver.c , Tps_Driver.h
  • TPS_WDSetTokenSeedValue() : Tps_Driver.h , Tps_Driver.c
  • TpsIf_GetRegister() : Tps_Interface.h
  • TpsIf_GetRegisterBitField() : Tps_Interface.h
  • TpsIf_Init() : Tps_Interface.h
  • TpsIf_SetRegister() : Tps_Interface.h
  • TpsIf_SetRegisterBitField() : Tps_Interface.h
  • TpsIf_SetRegisterBitFieldVerify() : Tps_Interface.h
  • TpsIf_SetRegisterVerify() : Tps_Interface.h
  • TpsIf_SpiIFTestPwmlow() : Tps_Interface.h
  • TpsIf_TestCommandParityLogic() : Tps_Interface.h
  • TpsIf_TestWrongCommandLogic() : Tps_Interface.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • send_recieve_data : Tps_Types.h
  • SendDebugText : Tps_Types.h
  • TpsIf_COMMAND_t : Tps_priv.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _TPS_AMUXSignals : Tps_Types.h
  • _TPS_BistTypes : Tps_Types.h
  • _TPS_DeviceConfigRegisterSettings : Tps_Types.h
  • _TPS_DMUXSignals : Tps_Types.h
  • _TPS_ErrorPinMonitoringMode : Tps_Types.h
  • _TPS_HandleConfigurationRegisters : Tps_Types.h
  • _TPS_Registers : Tps_Types.h
  • _TPS_SafetyBISTControlRegisterSettings : Tps_Types.h
  • _TPS_SafetyCheckControl : Tps_Types.h
  • _TPS_SPIErrorType : Tps_Types.h
  • _TPS_Test_Result : Tps_Types.h
  • _TPS_TestRunningStatus : Tps_Types.h
  • _TPS_VDD_3_5_SEL : Tps_Types.h
  • _TPS_WatchdogMode : Tps_Types.h
  • _TPS_WatchdogWindows : Tps_Types.h
  • _TPS_WDResponse : Tps_Types.h
  • TPS_DebugSeverity : Tps_Types.h
  • TPS_WDFaultType : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • ABIST : Tps_Types.h
  • AUTO_BIST : Tps_Types.h
  • AVDD_UVN : Tps_Types.h

- b -

  • BAD_ANSWER : Tps_Types.h
  • BG_ERR1 : Tps_Types.h
  • BG_ERR2 : Tps_Types.h

- c -

  • CFG_CRC : Tps_Types.h
  • CLOSE_WINDOW : Tps_Types.h
  • COMMAND_ERROR : Tps_Types.h
  • CP_DIFF3V : Tps_Types.h
  • CP_OV : Tps_Types.h
  • CP_PH1 : Tps_Types.h
  • CP_PH2 : Tps_Types.h
  • CP_UVN : Tps_Types.h

- d -

  • DATA_OP_MISMATCH : Tps_Types.h
  • DEBUG : Tps_Types.h
  • DFT1 : Tps_Types.h
  • DFT2 : Tps_Types.h
  • DFT3 : Tps_Types.h
  • DFT4 : Tps_Types.h
  • DIAG_EXIT : Tps_Types.h
  • DIAG_EXIT_MASK : Tps_Types.h
  • DMUX_VDD3_5_OT : Tps_Types.h
  • DMUX_VDD5_OT : Tps_Types.h
  • DRV_OUTPUT : Tps_Types.h
  • DVDD_OV : Tps_Types.h
  • DVDD_UV : Tps_Types.h

- e -

  • EE_CRC_CHK : Tps_Types.h
  • ERROR : Tps_Types.h
  • ERROR_PIN_MODE : Tps_Types.h
  • ERROR_PIN_MONITORING : Tps_Types.h

- f -

  • FORMAT_ERROR : Tps_Types.h

- i -

  • INFO : Tps_Types.h

- l -

  • LBIST : Tps_Types.h
  • LOCK : Tps_Types.h
  • LOCLK : Tps_Types.h

- m -

  • MAIN_BG : Tps_Types.h
  • MASK_VBAT_OV : Tps_Types.h
  • MASK_VDD1_UV : Tps_Types.h

- n -

  • NO_ERROR : Tps_Types.h
  • NRST_EXT_IN : Tps_Types.h

- o -

  • OPEN_WINDOW : Tps_Types.h
  • OVER : Tps_Types.h

- p -

  • POST_RUN_RST : Tps_Types.h
  • PWM_MONITORING_MODE : Tps_Types.h

- q -

  • QANDA_MODE : Tps_Types.h

- r -

  • RST_EXT_CLK : Tps_Types.h
  • RSV1 : Tps_Types.h
  • RSV2 : Tps_Types.h
  • RSV3 : Tps_Types.h
  • RSV4 : Tps_Types.h
  • RSV5 : Tps_Types.h
  • RUNNING : Tps_Types.h

- s -

  • SDO_RDBCK : Tps_Types.h
  • SEL_3_3V : Tps_Types.h
  • SEL_5V : Tps_Types.h
  • SPI_CLK : Tps_Types.h
  • SPI_NCS : Tps_Types.h
  • SPI_SDI : Tps_Types.h
  • SYS_CLK : Tps_Types.h

- t -

  • T_15US : Tps_Types.h
  • T_2MS : Tps_Types.h
  • T_40US : Tps_Types.h
  • T_5US : Tps_Types.h
  • TEST_FAIL : Tps_Types.h
  • TEST_PASS : Tps_Types.h
  • TPS_DEV_CFG1 : Tps_Types.h
  • TPS_DEV_CFG2 : Tps_Types.h
  • TPS_DEV_ID : Tps_Types.h
  • TPS_DEV_REV : Tps_Types.h
  • TPS_DEV_STAT : Tps_Types.h
  • TPS_DIAG_CFG_CTRL : Tps_Types.h
  • TPS_DIAG_MUX_SEL : Tps_Types.h
  • TPS_SAFETY_BIST_CTRL : Tps_Types.h
  • TPS_SAFETY_CFG_CRC : Tps_Types.h
  • TPS_SAFETY_CHECK_CTRL : Tps_Types.h
  • TPS_SAFETY_ERR_CFG : Tps_Types.h
  • TPS_SAFETY_ERR_PWM_H : Tps_Types.h
  • TPS_SAFETY_ERR_PWM_L : Tps_Types.h
  • TPS_SAFETY_ERR_STAT : Tps_Types.h
  • TPS_SAFETY_FUNC_CFG : Tps_Types.h
  • TPS_SAFETY_PWD_THR_CFG : Tps_Types.h
  • TPS_SAFETY_STAT_1 : Tps_Types.h
  • TPS_SAFETY_STAT_2 : Tps_Types.h
  • TPS_SAFETY_STAT_3 : Tps_Types.h
  • TPS_SAFETY_STAT_4 : Tps_Types.h
  • TPS_SAFETY_STAT_5 : Tps_Types.h
  • TPS_SENS_CTRL : Tps_Types.h
  • TPS_SW_LOCK : Tps_Types.h
  • TPS_SW_UNLOCK : Tps_Types.h
  • TPS_VMON_STAT_1 : Tps_Types.h
  • TPS_VMON_STAT_2 : Tps_Types.h
  • TPS_WDT_ANSWER : Tps_Types.h
  • TPS_WDT_STATUS : Tps_Types.h
  • TPS_WDT_TOKEN_FDBCK : Tps_Types.h
  • TPS_WDT_TOKEN_VALUE : Tps_Types.h
  • TPS_WDT_WIN1_CFG : Tps_Types.h
  • TPS_WDT_WIN2_CFG : Tps_Types.h

- u -

  • UC_ERROR_WDI : Tps_Types.h
  • UC_ERROR_WDI_RED : Tps_Types.h
  • UNLOCK : Tps_Types.h

- v -

  • VBAT : Tps_Types.h
  • VBAT_SAFING : Tps_Types.h
  • VBAT_UVN : Tps_Types.h
  • VBATP_OV : Tps_Types.h
  • VCP : Tps_Types.h
  • VCP12_NUV : Tps_Types.h
  • VCP12_OV : Tps_Types.h
  • VCP17_OV : Tps_Types.h
  • VDD1_NUV : Tps_Types.h
  • VDD1_OV : Tps_Types.h
  • VDD3_5_NUV : Tps_Types.h
  • VDD3_5_OT : Tps_Types.h
  • VDD3_5_OV : Tps_Types.h
  • VDD3_CL : Tps_Types.h
  • VDD5 : Tps_Types.h
  • VDD5_CL : Tps_Types.h
  • VDD5_NUV : Tps_Types.h
  • VDD5_OT : Tps_Types.h
  • VDD5_OV : Tps_Types.h
  • VDD6 : Tps_Types.h
  • VDD6_NUV : Tps_Types.h
  • VDD6_OV : Tps_Types.h
  • VMON_BG : Tps_Types.h
  • VMON_TRIM_ER : Tps_Types.h
  • VS_TRK_MODE : Tps_Types.h
  • VSFB1 : Tps_Types.h
  • VSOUT_ILIM : Tps_Types.h
  • VSOUT_OT : Tps_Types.h
  • VSOUT_OV : Tps_Types.h
  • VSOUT_UVN : Tps_Types.h

- w -

  • WD_TOKEN_RESP0 : Tps_Types.h
  • WD_TOKEN_RESP1 : Tps_Types.h
  • WD_TOKEN_RESP2 : Tps_Types.h
  • WD_TOKEN_RESP3 : Tps_Types.h
  • WDT_CLK : Tps_Types.h
  • WDTI_MODE : Tps_Types.h


TPS Driver: Globals

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • d
  • e
  • r
  • s
  • t
  • w

- a -

  • AMUX_MAX : Tps_Types.h
  • AMUX_MIN : Tps_Types.h

- d -

  • DEBUG_ENABLE : Tps_Config.h
  • DMUX_MAX : Tps_Types.h
  • DMUX_MIN : Tps_Types.h

- e -

  • ERROR_ENABLE : Tps_Config.h

- r -

  • RD_COMMAND_NONE : Tps_priv.h
  • RD_DEV_CFG1 : Tps_priv.h
  • RD_DEV_CFG2 : Tps_priv.h
  • RD_DEV_ID : Tps_priv.h
  • RD_DEV_REV : Tps_priv.h
  • RD_DEV_STAT : Tps_priv.h
  • RD_DIAG_CFG_CTRL : Tps_priv.h
  • RD_DIAG_MUX_SEL : Tps_priv.h
  • RD_SAFETY_BIST_CTRL : Tps_priv.h
  • RD_SAFETY_CFG_CRC : Tps_priv.h
  • RD_SAFETY_CHECK_CTRL : Tps_priv.h
  • RD_SAFETY_ERR_CFG : Tps_priv.h
  • RD_SAFETY_ERR_PWM_H : Tps_priv.h
  • RD_SAFETY_ERR_PWM_L : Tps_priv.h
  • RD_SAFETY_ERR_STAT : Tps_priv.h
  • RD_SAFETY_FUNC_CFG : Tps_priv.h
  • RD_SAFETY_PWD_THR_CFG : Tps_priv.h
  • RD_SAFETY_STAT_1 : Tps_priv.h
  • RD_SAFETY_STAT_2 : Tps_priv.h
  • RD_SAFETY_STAT_3 : Tps_priv.h
  • RD_SAFETY_STAT_4 : Tps_priv.h
  • RD_SAFETY_STAT_5 : Tps_priv.h
  • RD_SENS_CTRL : Tps_priv.h
  • RD_VMON_STAT_1 : Tps_priv.h
  • RD_VMON_STAT_2 : Tps_priv.h
  • RD_WD_WIN1_CFG : Tps_priv.h
  • RD_WD_WIN2_CFG : Tps_priv.h
  • RD_WDT_STATUS : Tps_priv.h
  • RD_WDT_TOKEN_FDBCK : Tps_priv.h
  • RD_WDT_TOKEN_VALUE : Tps_priv.h
  • RD_WRONG_COMMAND : Tps_priv.h
  • RD_WRONG_PARITY : Tps_priv.h

- s -

  • SRAM_END : Tps_Config.h
  • SRAM_START : Tps_Config.h

- t -

  • TPS_DEVICE_ACTIVE : Tps_Types.h
  • TPS_DEVICE_DIAGNOSTIC : Tps_Types.h
  • TPS_DEVICE_RESET : Tps_Types.h
  • TPS_DEVICE_SAFE : Tps_Types.h
  • TPS_DEVICE_STANDBY : Tps_Types.h

- w -

  • WR_CAN_STBY : Tps_priv.h
  • WR_COMMAND_NONE : Tps_priv.h
  • WR_DEV_CFG1 : Tps_priv.h
  • WR_DEV_CFG2 : Tps_priv.h
  • WR_DIAG_CFG_CTRL : Tps_priv.h
  • WR_DIAG_MUX_SEL : Tps_priv.h
  • WR_SAFETY_BIST_CTRL : Tps_priv.h
  • WR_SAFETY_CFG_CRC : Tps_priv.h
  • WR_SAFETY_CHECK_CTRL : Tps_priv.h
  • WR_SAFETY_ERR_CFG : Tps_priv.h
  • WR_SAFETY_ERR_PWM_H : Tps_priv.h
  • WR_SAFETY_ERR_PWM_L : Tps_priv.h
  • WR_SAFETY_ERR_STAT : Tps_priv.h
  • WR_SAFETY_FUNC_CFG : Tps_priv.h
  • WR_SAFETY_PWD_THR_CFG : Tps_priv.h
  • WR_SENS_CTRL : Tps_priv.h
  • WR_SW_LOCK : Tps_priv.h
  • WR_SW_UNLOCK : Tps_priv.h
  • WR_WD_WIN1_CFG : Tps_priv.h
  • WR_WD_WIN2_CFG : Tps_priv.h
  • WR_WDT_ANSWER : Tps_priv.h
  • WR_WDT_TOKEN_FDBCK : Tps_priv.h


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/TPS_DebugSupport.h Source File

  • TPS_Driver
  • include
TPS_DebugSupport.h
Go to the documentation of this file.
1
39 #ifndef __TPS_DEBUGSUPPORT__
40 #define __TPS_DEBUGSUPPORT__
41 /***************************************************************
42 * INCLUDE FILES
43 ****************************************************************/
44 #include "TPS_Types.h"
45 #include "TPS_Config.h"
46 #include <stdio.h>
47 #include <string.h>
48 /*********************************************************
49 Defines / data types / structs / unions /enums
50 **********************************************************/
51 /*********************************************************
52 Function Prototypes
53 **********************************************************/
82 void TPS_DebugInit(SendDebugText SendTPSDebugText);
113 boolean TPS_SendDebugText(TPS_DebugSeverity severity, const uint8* const u8buftext,
114 uint32 u32value);
115 #endif
116
TPS_SendDebugText
boolean TPS_SendDebugText(TPS_DebugSeverity severity, const uint8 *const u8buftext, uint32 u32value)
The API is used flag the errors/debug messages for debug purposes.
Definition: TPS_DebugSupport.c:66
TPS_DebugInit
void TPS_DebugInit(SendDebugText SendTPSDebugText)
API to initialize the debug support in the TPS driver.
Definition: TPS_DebugSupport.c:61
Tps_Config.h
This files contains the configuration items for the the TPS Driver.
TPS_DebugSeverity
TPS_DebugSeverity
Enumerations debug message severity.
Definition: Tps_Types.h:542
SendDebugText
boolean(* SendDebugText)(const uint8 *const u8textbuf, const uint32 u8textlength)
Definition for send debug text API, which is provided by the user application.
Definition: Tps_Types.h:579
Tps_Types.h
This files contains the types used by the TPS Library API's.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Config.h Source File

  • TPS_Driver
  • include
Tps_Config.h
Go to the documentation of this file.
1
40 #ifndef __TPS_CONFIG_H__
41 #define __TPS_CONFIG_H__
42
52 #define SRAM_START ((uint32)0x08000000U)
53 #define SRAM_END ((uint32)0x0803FFFFU)
62 #define DEBUG_ENABLE 1U
63 #define ERROR_ENABLE 0U
65 #endif /* __TPS_CONFIG_H__ */
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Driver.h Source File

  • TPS_Driver
  • include
Tps_Driver.h
Go to the documentation of this file.
1
42 #ifndef __TPS_DRV_H__
43 #define __TPS_DRV_H__
44 /***************************************************************
45 * INCLUDE FILES
46 ****************************************************************/
47 #include "TPS_Interface.h"
48 #include "TPS_Types.h"
49 #include "TPS_DebugSupport.h"
50 #include "reg_bitdefn_esm.h"
51 #include <string.h>
52 /*********************************************************
53 Defines / data types / structs / unions /enums
54 **********************************************************/
55
56 /*********************************************************
57 Function Prototypes
58 **********************************************************/
121 boolean TPS_DriverInit(const TPS_Initilization_struct* const init_struct);
170 boolean TPS_WatchdogInit(const TPS_WatchdoConfiguration *const watchdogconfig);
205 boolean TPS_ConfigureSafetyCheckControl(TPS_SafetyCheckControl safety_check,
206 boolean blstate);
241 boolean TPS_ConfigureSafeStateTimeout(boolean blsafe_state_timeout);
276 boolean TPS_SetSafeStateTimoutDuration(uint8 u8SafeStateTOtDuration_scaler);
314 boolean TPS_ConfigureErrorMonitoring(TPS_ErrorPinMonitoringMode monitoring_mode,
315 TPS_ERRORPinPWMWidthScaler pwm);
351 boolean TPS_SetWatchdogMode(TPS_WatchdogMode watchdogmode);
392 boolean TPS_ConfigureWatchdogWindows(TPS_WatchdogWindows watchdog_windows,
393 uint8 u8windowtime_scaler);
427 boolean TPS_ConfigureWatchdogReset(boolean blreset_enable);
461 boolean TPS_UpdateActiveWDToken(void);
501 boolean TPS_SendWdgResponse(TPS_WDResponse wd_response);
538 boolean TPS_GetWatchdogFailureStatus(boolean* blFailureStatus);
570 boolean TPS_ClearWatchdogFailureStatusFlag(void);
607 boolean TPS_GetWatchdogAnswerCount(uint8* u8AnswerCount);
641 boolean TPS_GetWatchdogErrorType(TPS_WatchdogErrorStatus *WDErrorStatus);
675 boolean TPS_GetWatchdogFailCount(uint8* u8watchdog_fail_count);
709 boolean TPS_ConfigureIgnintionPowerLatchControl(
710 boolean blignition_powerlatch_control);
745 boolean TPS_ConfigureNRESMonitoring(boolean blNRES_Monitoring);
778 boolean TPS_Get3_3Vor5VSupply(TPS_VDD_3_5_SEL *voltage_selection);
810 boolean TPS_SetSafeLockThreshhold(uint8 u8SafeLockThreshhold);
844 boolean TPS_GetCurrentTPSDeviceState(uint8* u8CurrentTPSDeviceState);
881 boolean TPS_SetTPSDeviceConfigurationRegisters(
882 TPS_DeviceConfigRegisterSettings field,
883 boolean blvalue);
918 boolean TPS_GetDeviceErrorCount(uint8* u8DeviceErrorCount);
949 boolean TPS_ClearDeviceErrorCount(void);
950
985 boolean TPS_SetMCUSoftwareDebugMode(void);
1017 boolean TPS_ExitDiagnosticMode(void);
1050 boolean TPS_ProtectConfigurationRegisters(
1051 TPS_HandleConfigurationRegisters state);
1086 boolean TPS_ConfigureBISTatStartup(boolean blbist_at_startup);
1118 boolean TPS_StartEECRCCheck(void);
1159 boolean TPS_InitializeDatastringforCRCCaclcuation(uint32 u32DataforCRC[2]);
1197 boolean TPS_UpdateDatastringforCRCCaclcuation(uint32 u32DataforCRC[2],
1198 uint16 u16reg);
1244 boolean TPS_CalculateCRC8(uint32 u32DataforCRC[2], uint8* u8crc_value);
1283 boolean TPS_GetCRCErrorStatus(TPS_CRCErrorStatus *crc_error_status);
1284
1324 boolean TPS_StartBIST(TPS_BistTypes bist);
1359 boolean TPS_GetBISTRunningStatus(TPS_BistTypes bist_type,
1360 TPS_TestRunningStatus* runningstatus);
1394 boolean TPS_GetEECRCCheckRunningStatus(TPS_TestRunningStatus * runningstatus);
1429 boolean TPS_GetABISTTestStatus(TPS_ABIST_Result* test_status);
1464 boolean TPS_GetLBISTTestStatus(TPS_Test_Result* LBIST_Test_Result);
1496 boolean TPS_SetPowerDownThreshhold(uint8 u8threshhold_value);
1531 boolean TPS_RegReadBackandCompare(TPS_Test_Result * readback_compare);
1565 boolean TPS_EnableAMUXSignal(TPS_AMUXSignals AMUXSignal);
1598 boolean TPS_DisableMUXDiagnostic(void);
1640 boolean TPS_CheckEnabledAMUXSignalLimits(TPS_Test_Result * Voltage_limit_test);
1678 boolean TPS_EnableDMUXSignal(TPS_DMUXSignals DMUXSignal);
1719 boolean TPS_FaultInjectCRC(void);
1755 boolean TPS_WDSetTokenSeedValue(uint8 u8TokenSeed);
1790 boolean TPS_WDSetTokenFDBCKValue(uint8 u8TokenFDBCK);
1824 boolean TPS_GetErrorPinFailureStatusFlag(boolean* blFailureStatus);
1855 boolean TPS_ClearErrorPinFailureStatusFlag(void);
1885 boolean TPS_ConfigureVDD5(boolean blEnableVDD5);
1915 boolean TPS_ConfigureVSOUT1(boolean blEnableVSOUT1);
1950 boolean TPS_GetVMONStatus(TPS_OverallVMONStatus * vmon_status);
1987 boolean TPS_GetJnTempandCurrentLimitStatus(TPS_JnTempCurrentLimitStatus * JnTempCurrentLtMonitoring);
2023 boolean TPS_GetTPSDeviceConfiguration(TPS_DevCfg_reg_settings * config_register_settings);
2056 boolean TPS_GetSPIErrorStatus(TPS_SPIErrorType * spi_error_status);
2090 boolean TPS_GetDEV_STATE(TPS_DeviceState * dev_state);
2130 boolean TPS_GetNRESErrorStatus(boolean* blNRESError);
2174 boolean TPS_FaultInjectWD(TPS_WDFaultType WDFault);
2210 boolean TPS_GetENDRVErrorStatus(boolean* blENDRVError);
2246 boolean TPS_UpdateRegisterSafetyCfgCRC(uint8 u8safetycfgcrc);
2283 boolean TPS_TestErrorPinMonitoring(TPS_Test_Result * ErrorPinMonitoring_Test);
2314 boolean TPS_GoToSafeState(void);
2347 boolean TPS_GetDeviceInformation(TPS_DeviceInformation * device_information);
2348 #endif
TPS_FaultInjectCRC
boolean TPS_FaultInjectCRC(void)
Inject CRC fault.
Definition: Tps_Driver.c:2064
TPS_GetTPSDeviceConfiguration
boolean TPS_GetTPSDeviceConfiguration(TPS_DevCfg_reg_settings *config_register_settings)
Provide device confiuration(setting made in the DEV_CFG1 and DEV_CFG2 register)
Definition: Tps_Driver.c:2251
TPS_GetLBISTTestStatus
boolean TPS_GetLBISTTestStatus(TPS_Test_Result *LBIST_Test_Result)
The API provides the LBIST test status.
Definition: Tps_Driver.c:1773
TPS_ABIST_Result
ABIST result information to be used with TPS_GetABISTTestStatus API.
TPS_GetNRESErrorStatus
boolean TPS_GetNRESErrorStatus(boolean *blNRESError)
The API provides failure information of NRES pin(readback state of NRES PIN).
Definition: Tps_Driver.c:2327
TPS_EnableAMUXSignal
boolean TPS_EnableAMUXSignal(TPS_AMUXSignals AMUXSignal)
Enable particular AMUX signal.
Definition: Tps_Driver.c:1906
TPS_DisableMUXDiagnostic
boolean TPS_DisableMUXDiagnostic(void)
Disable MUX diagnostics.
Definition: Tps_Driver.c:1942
TPS_GetCurrentTPSDeviceState
boolean TPS_GetCurrentTPSDeviceState(uint8 *u8CurrentTPSDeviceState)
Get Current TPS device State.
Definition: Tps_Driver.c:1007
TPS_GetDeviceErrorCount
boolean TPS_GetDeviceErrorCount(uint8 *u8DeviceErrorCount)
API provides the device error count value in TPS.
Definition: Tps_Driver.c:1147
TPS_GetJnTempandCurrentLimitStatus
boolean TPS_GetJnTempandCurrentLimitStatus(TPS_JnTempCurrentLimitStatus *JnTempCurrentLtMonitoring)
Provide status of junction temperature monitoring and current limit status.
Definition: Tps_Driver.c:2220
TPS_ConfigureWatchdogWindows
boolean TPS_ConfigureWatchdogWindows(TPS_WatchdogWindows watchdog_windows, uint8 u8windowtime_scaler)
configure watchdog windows.
Definition: Tps_Driver.c:640
TPS_GetDEV_STATE
boolean TPS_GetDEV_STATE(TPS_DeviceState *dev_state)
Provide information regarding TPS.
Definition: Tps_Driver.c:2304
TPS_DeviceInformation
The structure will contain the device information such as device revision,device id.
TPS_CheckEnabledAMUXSignalLimits
boolean TPS_CheckEnabledAMUXSignalLimits(TPS_Test_Result *Voltage_limit_test)
Check Enabled AMUX signal limits.
Definition: Tps_Driver.c:1952
TPS_SetMCUSoftwareDebugMode
boolean TPS_SetMCUSoftwareDebugMode(void)
Set TPS device configuration so to support MCU software debug.
Definition: Tps_Driver.c:1185
TPS_ConfigureIgnintionPowerLatchControl
boolean TPS_ConfigureIgnintionPowerLatchControl(boolean blignition_powerlatch_control)
Set ignition power latch behavior.
Definition: Tps_Driver.c:888
TPS_OverallVMONStatus
TPS_OverallVMONStatus structure is used api TPS_GetVMONStatus and it is used for recording the compl...
TPS_ERRORPinPWMWidthScaler
TPS_ERRORPinPWMWidthScaler structure to be used with TPS_ConfigureErrorMonitoring API...
TPS_SetWatchdogMode
boolean TPS_SetWatchdogMode(TPS_WatchdogMode watchdogmode)
Set Watchdog configuration.
Definition: Tps_Driver.c:546
TPS_Initilization_struct
TPS Initialization struct to be used with TPS_Init API.
TPS_InitializeDatastringforCRCCaclcuation
boolean TPS_InitializeDatastringforCRCCaclcuation(uint32 u32DataforCRC[2])
The API initializes the 64 bit data string for 8 bit crc calculation.
Definition: Tps_Driver.c:1377
TPS_StartEECRCCheck
boolean TPS_StartEECRCCheck(void)
The API starts EEPROM CRC check.
Definition: Tps_Driver.c:1280
TPS_SetSafeStateTimoutDuration
boolean TPS_SetSafeStateTimoutDuration(uint8 u8SafeStateTOtDuration_scaler)
Set Safe State time out duration.
Definition: Tps_Driver.c:360
TPS_GetSPIErrorStatus
boolean TPS_GetSPIErrorStatus(TPS_SPIErrorType *spi_error_status)
Provide device the error status of the previous SPI transmission.
Definition: Tps_Driver.c:2284
TPS_RegReadBackandCompare
boolean TPS_RegReadBackandCompare(TPS_Test_Result *readback_compare)
Register read back and compare.
Definition: Tps_Driver.c:1834
TPS_Get3_3Vor5VSupply
boolean TPS_Get3_3Vor5VSupply(TPS_VDD_3_5_SEL *voltage_selection)
gets VDD3/VDD5 selection.
Definition: Tps_Driver.c:959
TPS_GetVMONStatus
boolean TPS_GetVMONStatus(TPS_OverallVMONStatus *vmon_status)
Provide status of the Voltage monitoring by the TPS.
Definition: Tps_Driver.c:2156
TPS_GetBISTRunningStatus
boolean TPS_GetBISTRunningStatus(TPS_BistTypes bist_type, TPS_TestRunningStatus *runningstatus)
The API gets the built in selftest running status.
Definition: Tps_Driver.c:1660
TPS_ClearDeviceErrorCount
boolean TPS_ClearDeviceErrorCount(void)
API clears the devices error count values in the TPS register SAFETY_ERR_STAT.
Definition: Tps_Driver.c:1167
TPS_SendWdgResponse
boolean TPS_SendWdgResponse(TPS_WDResponse wd_response)
API to send watchdog response to TPS.
Definition: Tps_Driver.c:740
TPS_WatchdogInit
boolean TPS_WatchdogInit(const TPS_WatchdoConfiguration *const watchdogconfig)
API to set up and initialize TPS watchdog.
Definition: Tps_Driver.c:482
TPS_UpdateDatastringforCRCCaclcuation
boolean TPS_UpdateDatastringforCRCCaclcuation(uint32 u32DataforCRC[2], uint16 u16reg)
The API updates the 64 bit data string for 8 bit crc calculation for specified register.
Definition: Tps_Driver.c:1436
TPS_WatchdoConfiguration
TPS watchdog configuration to be used with TPS_WatcdogInit API.
TPS_DebugSupport.h
This files contains the Debug Support API prototypes.
TPS_ClearWatchdogFailureStatusFlag
boolean TPS_ClearWatchdogFailureStatusFlag(void)
The API clears the watchdog fail status bit in the register SAFETY_ERR_STAT TPS register.
Definition: Tps_Driver.c:794
TPS_ConfigureWatchdogReset
boolean TPS_ConfigureWatchdogReset(boolean blreset_enable)
enable/disable watchdog reset
Definition: Tps_Driver.c:698
TPS_ConfigureVSOUT1
boolean TPS_ConfigureVSOUT1(boolean blEnableVSOUT1)
The API enables voltage source VSOUT1.
Definition: Tps_Driver.c:2111
TPS_GetABISTTestStatus
boolean TPS_GetABISTTestStatus(TPS_ABIST_Result *test_status)
The provides the ABIST test status.
Definition: Tps_Driver.c:1708
TPS_GetErrorPinFailureStatusFlag
boolean TPS_GetErrorPinFailureStatusFlag(boolean *blFailureStatus)
The API provides failure status information of the error pin of MCU.
Definition: Tps_Driver.c:436
Tps_Interface.h
File contains the TPS interfacing api's prototypes for read,write and verifying SPI mapped registers...
TPS_WDFaultType
TPS_WDFaultType
Enumerations indicating the Watchdog fault type to be injected.
Definition: Tps_Types.h:532
TPS_ConfigureErrorMonitoring
boolean TPS_ConfigureErrorMonitoring(TPS_ErrorPinMonitoringMode monitoring_mode, TPS_ERRORPinPWMWidthScaler pwm)
Set Error signal monitoring mode.
Definition: Tps_Driver.c:385
TPS_ConfigureBISTatStartup
boolean TPS_ConfigureBISTatStartup(boolean blbist_at_startup)
The API enables and disables BIST at startup.
Definition: Tps_Driver.c:1253
TPS_ConfigureVDD5
boolean TPS_ConfigureVDD5(boolean blEnableVDD5)
The API enables voltage source VDD5.
Definition: Tps_Driver.c:2091
TPS_GetWatchdogFailCount
boolean TPS_GetWatchdogFailCount(uint8 *u8watchdog_fail_count)
The API provides watchdog failure count information.
Definition: Tps_Driver.c:882
TPS_EnableDMUXSignal
boolean TPS_EnableDMUXSignal(TPS_DMUXSignals DMUXSignal)
Enable particular DMUX signal.
Definition: Tps_Driver.c:2021
TPS_WDSetTokenFDBCKValue
boolean TPS_WDSetTokenFDBCKValue(uint8 u8TokenFDBCK)
Set Token FeedBack value for the watchdog.
Definition: Tps_Driver.c:613
TPS_WatchdogWindows
TPS watchdog open and close window configuration to be used with TPS_ConfigureWatchdogWindows API...
TPS_SetPowerDownThreshhold
boolean TPS_SetPowerDownThreshhold(uint8 u8threshhold_value)
Set power down threshold value.
Definition: Tps_Driver.c:1811
TPS_UpdateRegisterSafetyCfgCRC
boolean TPS_UpdateRegisterSafetyCfgCRC(uint8 u8safetycfgcrc)
Update SAFETY_CFG_CRC register.
Definition: Tps_Driver.c:1622
TPS_GetDeviceInformation
boolean TPS_GetDeviceInformation(TPS_DeviceInformation *device_information)
The API provides TPS device information.
Definition: Tps_Driver.c:2131
TPS_WDSetTokenSeedValue
boolean TPS_WDSetTokenSeedValue(uint8 u8TokenSeed)
Set Token Seed value for the watchdog.
Definition: Tps_Driver.c:585
TPS_StartBIST
boolean TPS_StartBIST(TPS_BistTypes bist)
The API starts the built in selftest ABIST/LBIST.
Definition: Tps_Driver.c:1627
TPS_ConfigureNRESMonitoring
boolean TPS_ConfigureNRESMonitoring(boolean blNRES_Monitoring)
Configure NRES pin Monitoring.
Definition: Tps_Driver.c:924
TPS_DevCfg_reg_settings
structure which can store the TPS device configuration register settings this structure updated with ...
TPS_TestErrorPinMonitoring
boolean TPS_TestErrorPinMonitoring(TPS_Test_Result *ErrorPinMonitoring_Test)
The API does the selftest of the error pin monitoring.
Definition: Tps_Driver.c:2397
TPS_GetWatchdogAnswerCount
boolean TPS_GetWatchdogAnswerCount(uint8 *u8AnswerCount)
The API provides watchdog answer count.
Definition: Tps_Driver.c:812
TPS_CRCErrorStatus
The structure will contain the data regarding the CRC error in config registers/EEPROM.
TPS_UpdateActiveWDToken
boolean TPS_UpdateActiveWDToken(void)
Update active Watchdog Token.
Definition: Tps_Driver.c:733
TPS_SetSafeLockThreshhold
boolean TPS_SetSafeLockThreshhold(uint8 u8SafeLockThreshhold)
Set device ERROR COUNT threshold value.
Definition: Tps_Driver.c:983
TPS_CalculateCRC8
boolean TPS_CalculateCRC8(uint32 u32DataforCRC[2], uint8 *u8crc_value)
Calculate the CRC 8 value of the Tps65381 configuration registers(stored as 64 bit data) ...
Definition: Tps_Driver.c:1532
TPS_DriverInit
boolean TPS_DriverInit(const TPS_Initilization_struct *const init_struct)
API to set up and initialize TPS driver.
Definition: Tps_Driver.c:69
TPS_GetWatchdogErrorType
boolean TPS_GetWatchdogErrorType(TPS_WatchdogErrorStatus *WDErrorStatus)
The API provides failure status information of the watchdog.
Definition: Tps_Driver.c:831
TPS_SetTPSDeviceConfigurationRegisters
boolean TPS_SetTPSDeviceConfigurationRegisters(TPS_DeviceConfigRegisterSettings field, boolean blvalue)
The API helps in setting the device configuration register.
Definition: Tps_Driver.c:1026
TPS_ClearErrorPinFailureStatusFlag
boolean TPS_ClearErrorPinFailureStatusFlag(void)
The API clears the error pin fail status bit in the register SAFETY_ERR_STAT TPS register.
Definition: Tps_Driver.c:464
TPS_ConfigureSafeStateTimeout
boolean TPS_ConfigureSafeStateTimeout(boolean blsafe_state_timeout)
Enable or disable the safe state timeout.
Definition: Tps_Driver.c:325
TPS_GoToSafeState
boolean TPS_GoToSafeState(void)
The API moves the TPS device safe state(from Active state).
Definition: Tps_Driver.c:2472
TPS_GetCRCErrorStatus
boolean TPS_GetCRCErrorStatus(TPS_CRCErrorStatus *crc_error_status)
The API is used to get the error status of Configuration register CRC calculation and EEPROM CRC calc...
Definition: Tps_Driver.c:1579
TPS_DeviceState
The structure will contain the device state information such as latched CAN wake-up and deglitched IG...
TPS_GetWatchdogFailureStatus
boolean TPS_GetWatchdogFailureStatus(boolean *blFailureStatus)
The API provides watchdog failure count information.
Definition: Tps_Driver.c:766
TPS_GetENDRVErrorStatus
boolean TPS_GetENDRVErrorStatus(boolean *blENDRVError)
The API provides Enable drive error status.
Definition: Tps_Driver.c:2354
TPS_ExitDiagnosticMode
boolean TPS_ExitDiagnosticMode(void)
Takes the necessary actions so as to exit DIAGNOSTIC mode and enter the active mode of TPS device ope...
Definition: Tps_Driver.c:1211
TPS_FaultInjectWD
boolean TPS_FaultInjectWD(TPS_WDFaultType WDFault)
Inject fault in watchdog.
Definition: Tps_Driver.c:2381
Tps_Types.h
This files contains the types used by the TPS Library API's.
TPS_ProtectConfigurationRegisters
boolean TPS_ProtectConfigurationRegisters(TPS_HandleConfigurationRegisters state)
LOCK/UNLOCK (protect) the configuration registers for writing.
Definition: Tps_Driver.c:1233
TPS_GetEECRCCheckRunningStatus
boolean TPS_GetEECRCCheckRunningStatus(TPS_TestRunningStatus *runningstatus)
The API gets the EE CRC Check running status.
Definition: Tps_Driver.c:1302
TPS_ConfigureSafetyCheckControl
boolean TPS_ConfigureSafetyCheckControl(TPS_SafetyCheckControl safety_check, boolean blstate)
sets the safety check control register flags.
Definition: Tps_Driver.c:220
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source/Tps_Interface.h Source File

  • TPS_Driver
  • source
Tps_Interface.h
Go to the documentation of this file.
1
39 #ifndef __TPS_IF_H__
40 #define __TPS_IF_H__
41 /***************************************************************
42 * INCLUDE FILES
43 ****************************************************************/
44 #include "TPS_Types.h"
45 #include "TPS_DebugSupport.h"
46 /*********************************************************
47 Defines / data types / structs / unions /enums
48 **********************************************************/
49 /*********************************************************
50 Function Prototypes
51 **********************************************************/
83 void TpsIf_Init(send_recieve_data snd_rcv_data_api);
115 boolean TpsIf_SetRegister(const TPS_Registers TPSReg, const uint8 u8value);
147 boolean TpsIf_SetRegisterVerify(const TPS_Registers TPSReg, const uint8 u8value);
183 boolean TpsIf_SetRegisterBitField(const TPS_Registers TPSReg, const uint8 u8bfstart,const uint8 u8bflength,const uint8 u8value);
219 boolean TpsIf_SetRegisterBitFieldVerify(const TPS_Registers TPSReg,
220 const uint8 u8bfstart, const uint8 u8bflength, const uint8 u8value);
254 boolean TpsIf_GetRegister(const TPS_Registers TPSReg, uint8* u8value);
290 boolean TpsIf_GetRegisterBitField(const TPS_Registers TPSReg, const uint8 u8bfstart,
291 const uint8 u8bflength, uint8* u8value);
323 boolean TpsIf_TestCommandParityLogic(TPS_Test_Result * selftest_result);
355 boolean TpsIf_TestWrongCommandLogic(TPS_Test_Result * selftest_result);
388 boolean TpsIf_SpiIFTestPwmlow(TPS_Test_Result * selftest_result);
389 #endif
TpsIf_SpiIFTestPwmlow
boolean TpsIf_SpiIFTestPwmlow(TPS_Test_Result *selftest_result)
test PwmLow Register writes.
Definition: Tps_Interface.c:483
TpsIf_SetRegisterBitField
boolean TpsIf_SetRegisterBitField(const TPS_Registers TPSReg, const uint8 u8bfstart, const uint8 u8bflength, const uint8 u8value)
Set Register bitfield Value.
Definition: Tps_Interface.c:289
send_recieve_data
boolean(* send_recieve_data)(const uint16 *const u16TransmitData, const uint32 u32TransmitSize, volatile uint16 *u16RecieveData, uint32 *u32RecieveSize)
Definition for transmit_recieve_data data API, which is provided by the user application.
Definition: Tps_Types.h:559
TpsIf_SetRegisterBitFieldVerify
boolean TpsIf_SetRegisterBitFieldVerify(const TPS_Registers TPSReg, const uint8 u8bfstart, const uint8 u8bflength, const uint8 u8value)
Set Register bitfield Value and verify.
Definition: Tps_Interface.c:319
TpsIf_GetRegisterBitField
boolean TpsIf_GetRegisterBitField(const TPS_Registers TPSReg, const uint8 u8bfstart, const uint8 u8bflength, uint8 *u8value)
Read Register bitfield Value.
Definition: Tps_Interface.c:393
TPS_DebugSupport.h
This files contains the Debug Support API prototypes.
TpsIf_SetRegister
boolean TpsIf_SetRegister(const TPS_Registers TPSReg, const uint8 u8value)
Write Register Value.
Definition: Tps_Interface.c:237
TpsIf_Init
void TpsIf_Init(send_recieve_data snd_rcv_data_api)
Initialize TPS interface.
Definition: Tps_Interface.c:232
TpsIf_GetRegister
boolean TpsIf_GetRegister(const TPS_Registers TPSReg, uint8 *u8value)
Read Register Value.
Definition: Tps_Interface.c:365
TpsIf_TestCommandParityLogic
boolean TpsIf_TestCommandParityLogic(TPS_Test_Result *selftest_result)
test command parity logic.
Definition: Tps_Interface.c:423
TpsIf_TestWrongCommandLogic
boolean TpsIf_TestWrongCommandLogic(TPS_Test_Result *selftest_result)
test wrong command logic.
Definition: Tps_Interface.c:453
TpsIf_SetRegisterVerify
boolean TpsIf_SetRegisterVerify(const TPS_Registers TPSReg, const uint8 u8value)
Write Register Value and Verify.
Definition: Tps_Interface.c:255
Tps_Types.h
This files contains the types used by the TPS Library API's.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/include/Tps_Types.h Source File

  • TPS_Driver
  • include
Tps_Types.h
Go to the documentation of this file.
1
39 #ifndef TPS_TYPES_H_
40 #define TPS_TYPES_H_
41 /***************************************************************
42 * INCLUDE FILES
43 ****************************************************************/
44 #include "sl_hal_stdtypes.h"
45 /*********************************************************
46 Defines / data types / structs / unions /enums
47 **********************************************************/
53 typedef enum _TPS_Registers
54 {
55 TPS_DEV_REV,
56 TPS_DEV_ID,
57 TPS_DEV_STAT,
58 TPS_DEV_CFG1,
59 TPS_DEV_CFG2,
60 TPS_VMON_STAT_1,
61 TPS_VMON_STAT_2,
62 TPS_SAFETY_STAT_1,
63 TPS_SAFETY_STAT_2,
64 TPS_SAFETY_STAT_3,
65 TPS_SAFETY_STAT_4,
66 TPS_SAFETY_STAT_5,
67 TPS_SAFETY_ERR_CFG,
68 TPS_SAFETY_BIST_CTRL,
69 TPS_SAFETY_CHECK_CTRL,
70 TPS_SAFETY_FUNC_CFG,
71 TPS_SAFETY_ERR_STAT,
72 TPS_SAFETY_ERR_PWM_H,
73 TPS_SAFETY_ERR_PWM_L,
74 TPS_SAFETY_PWD_THR_CFG,
75 TPS_SAFETY_CFG_CRC,
76 TPS_DIAG_CFG_CTRL,
77 TPS_DIAG_MUX_SEL,
78 TPS_WDT_TOKEN_FDBCK,
79 TPS_WDT_WIN1_CFG,
80 TPS_WDT_WIN2_CFG,
81 TPS_WDT_TOKEN_VALUE,
82 TPS_WDT_STATUS,
83 TPS_WDT_ANSWER,
84 TPS_SENS_CTRL,
85 TPS_SW_LOCK,
86 TPS_SW_UNLOCK
87 }TPS_Registers;
93 typedef enum _TPS_Test_Result {
94 TEST_FAIL = 0xABU,
95 TEST_PASS = 0xCDU
96 } TPS_Test_Result;
97
98
104 typedef enum _TPS_SafetyCheckControl {
105 CFG_CRC = 0U,
107 DRV_OUTPUT,
108 ERROR_PIN_MONITORING,
109 DIAG_EXIT_MASK,
111 DIAG_EXIT
114 } TPS_SafetyCheckControl;
115
121 typedef enum _TPS_ErrorPinMonitoringMode {
122 PWM_MONITORING_MODE = 0U,
123 ERROR_PIN_MODE
124 } TPS_ErrorPinMonitoringMode;
125
131 typedef struct _TPS_ERRORPinPWMWidthScaler{
132 uint8 u8PWM_HIGH;
133 uint8 u8PWM_LOW;
134 }TPS_ERRORPinPWMWidthScaler;
140 typedef enum _TPS_WatchdogMode {
141 WDTI_MODE = 0U,
142 QANDA_MODE
143 } TPS_WatchdogMode;
144
150 typedef enum _TPS_VDD_3_5_SEL {
151 SEL_5V = 0U,
152 SEL_3_3V
153 } TPS_VDD_3_5_SEL;
154
160 typedef enum _TPS_HandleConfigurationRegisters {
161 LOCK = 0U,
162 UNLOCK
163 } TPS_HandleConfigurationRegisters;
164
165
166
173 typedef enum _TPS_DeviceConfigRegisterSettings {
174 MASK_VDD1_UV = 0U,
175 VDD3_5_OT,
176 VDD5_OT,
177 MASK_VBAT_OV,
178 POST_RUN_RST
179 } TPS_DeviceConfigRegisterSettings;
180
187 typedef enum _TPS_SafetyBISTControlRegisterSettings {
188 EE_CRC_CHK = 0,
189 AUTO_BIST
190 } TPS_SafetyBISTControlRegisterSettings;
191
198 typedef enum _TPS_BistTypes {
199 ABIST = 0,
200 LBIST
201 } TPS_BistTypes;
202
209 typedef struct _TPS_WatchdogErrorStatus{
210 boolean blTokenError;
211 boolean blWdWrongConfig;
212 boolean blSeqError;
213 boolean blTimeOutError;
214 boolean blTokenEarlyError;
215 } TPS_WatchdogErrorStatus;
216
222 typedef enum _TPS_TestRunningStatus {
223 OVER = 0,
224 RUNNING
225 }TPS_TestRunningStatus;
231 typedef struct _TPS_ABIST_Result {
232 TPS_Test_Result ABIST_Result;
233 TPS_Test_Result UVOV_Test;
235 TPS_Test_Result LOCLK_Test;
237 }TPS_ABIST_Result;
238
244 typedef enum _TPS_AMUXSignals {
245 VDD5 = 0,
246 VDD6,
247 VCP,
248 VSFB1,
249 VBAT_SAFING,
250 VBAT,
251 MAIN_BG,
252 VMON_BG
253 } TPS_AMUXSignals;
254
260 /*SAFETYMCUSW 79 S MR:19.4 <APPROVED> "Reason - Reviewed and the value assigned is an enumeration"*/
261 #define AMUX_MIN (VDD5)
262 /*SAFETYMCUSW 79 S MR:19.4 <APPROVED> "Reason - Reviewed and the value assigned is an enumeration"*/
263 #define AMUX_MAX (VMON_BG)
273 typedef enum _TPS_DMUXSignals {
274 RSV1 = 0 ,
275 AVDD_UVN ,
276 BG_ERR1 ,
277 BG_ERR2 ,
278 VCP12_NUV ,
279 VCP12_OV ,
280 VCP17_OV ,
281 VDD6_NUV ,
282 VDD6_OV ,
283 VDD5_NUV ,
284 VDD5_OV ,
285 VDD3_5_NUV ,
286 VDD3_5_OV ,
287 VDD1_NUV ,
288 VDD1_OV ,
289 LOCLK ,
290 RSV2 ,
291 SYS_CLK ,
292 DFT1 ,
293 WDT_CLK ,
294 RST_EXT_CLK ,
295 T_5US ,
296 T_15US ,
297 T_40US ,
298 T_2MS ,
299 UC_ERROR_WDI ,
300 SPI_NCS ,
301 SPI_SDI ,
302 SPI_CLK ,
303 SDO_RDBCK ,
304 UC_ERROR_WDI_RED,
305 NRST_EXT_IN ,
306 RSV3 ,
307 DFT2 ,
308 DFT3 ,
309 CP_OV ,
310 CP_UVN ,
311 CP_PH1 ,
312 CP_PH2 ,
313 CP_DIFF3V ,
314 DFT4 ,
315 VBAT_UVN ,
316 VBATP_OV ,
317 DMUX_VDD5_OT ,
318 DMUX_VDD3_5_OT ,
319 VSOUT_OT ,
320 VDD5_CL ,
321 VDD3_CL ,
322 RSV4 ,
323 VSOUT_ILIM ,
324 VSOUT_UVN ,
325 VSOUT_OV ,
326 DVDD_UV ,
327 DVDD_OV ,
328 RSV5 ,
329 VS_TRK_MODE ,
330 VMON_TRIM_ER
331 } TPS_DMUXSignals;
332
338 /*SAFETYMCUSW 79 S MR:19.4 <APPROVED> "Reason - Reviewed and the value assigned is an enumeration"*/
339 #define DMUX_MIN (RSV1)
340 /*SAFETYMCUSW 79 S MR:19.4 <APPROVED> "Reason - Reviewed and the value assigned is an enumeration"*/
341 #define DMUX_MAX (VMON_TRIM_ER)
350 typedef struct _TPS_VoltageRailLimits
351 {
352 uint16 u16voltage_min;
353 uint16 u16voltage_max;
354 } TPS_VoltageRailLimits;
355
363 typedef struct _TPS_AllVoltageRailLimits
364 {
365 TPS_VoltageRailLimits VDD5_Limits;
366 TPS_VoltageRailLimits VDD6_Limits;
367 TPS_VoltageRailLimits VCP_Limits;
368 TPS_VoltageRailLimits VSFB1_Limits;
369 TPS_VoltageRailLimits VBAT_SAFING_Limits;
370 TPS_VoltageRailLimits VBAT_Limits;
371 TPS_VoltageRailLimits MAIN_BG_Limits;
372 TPS_VoltageRailLimits VMON_BG_Limits;
373 }TPS_AllVoltageRailLimits;
374
380 typedef struct _TPS_VMONStatus
381 {
382 boolean blOverVoltage;
383 boolean blUnderVoltage;
384 }TPS_VMONStatus;
385
392 typedef struct _TPS_OverallVMONStatus
393 {
394 TPS_VMONStatus vbatp;
395 TPS_VMONStatus vcp12;
396 TPS_VMONStatus vdd6;
397 TPS_VMONStatus vdd5;
398 TPS_VMONStatus vdd3_5;
399 TPS_VMONStatus vdd1;
400 TPS_VMONStatus vsout1;
401 boolean blbandgap2_err;
402 boolean blbandgap1_err;
403 boolean blvcp17_ov;
404 boolean blavdd_vmon_err;
405 boolean blVMON_TrimError;
406 }TPS_OverallVMONStatus;
407
414 typedef struct _TPS_JnTempCurrentLimitStatus
415 {
416 boolean blvdd5_ilim;
417 boolean blvdd3_5_ilim;
418 boolean blvsout1_ilim;
419 boolean blvsout1_ot;
420 boolean blvdd5_ot;
421 boolean blvdd3_5_ot;
422 } TPS_JnTempCurrentLimitStatus;
423
424
431 typedef struct _TPS_DevCfg_reg_settings {
432 boolean blMASK_VDD1_UV;
433 boolean blVDD3_5_OT;
434 boolean blVDD5_OT;
435 boolean blMASK_VBAT_OV;
436 boolean blPOST_RUN_RST;
437 }TPS_DevCfg_reg_settings;
438
445 typedef struct _TPS_Config
446 {
447 uint8 u8safety_func_cfg;
448 uint8 u8safety_err_cfg;
449 uint8 u8safety_pwd_thr;
450 uint8 u8dev_cfg1;
451 uint8 u8dev_cfg2;
452 uint8 u8wdt_token_fbck;
453 uint8 u8wdt_win1_cfg;
454 uint8 u8wdt_win2_cfg;
455 uint8 u8safety_err_pwm_l;
456 uint8 u8safety_err_pwm_h;
457 }TPS_Config;
458
464 typedef enum _TPS_WatchdogWindows {
465 OPEN_WINDOW,
466 CLOSE_WINDOW
467 }TPS_WatchdogWindows;
468
474 typedef struct _TPS_CRCErrorStatus {
475 boolean blCfgCRCError;
476 boolean blEECRCError;
477 }TPS_CRCErrorStatus;
478
484 typedef struct _TPS_DeviceInformation {
485 uint8 u8dev_minor_version;
486 uint8 u8dev_major_version;
487 uint8 u8dev_id;
488 }TPS_DeviceInformation;
489
495 typedef struct _TPS_DeviceState {
496 boolean blLatchedCanWakeUP;
497 boolean blDeglitchedIGNPin;
498 }TPS_DeviceState;
499
505 typedef enum _TPS_WDResponse
506 {
507 WD_TOKEN_RESP3 = 0,
508 WD_TOKEN_RESP2,
509 WD_TOKEN_RESP1,
510 WD_TOKEN_RESP0
511 } TPS_WDResponse;
512
519 typedef enum _TPS_SPIErrorType
520 {
521 NO_ERROR = 0,
522 COMMAND_ERROR,
523 FORMAT_ERROR,
524 DATA_OP_MISMATCH
525 } TPS_SPIErrorType;
526
532 typedef enum
533 {
534 BAD_ANSWER
535 } TPS_WDFaultType;
536
542 typedef enum
543 {
544 DEBUG = 0,
545 ERROR,
546 INFO
547 } TPS_DebugSeverity;
548
558 /*SAFETYMCUSW 298 S <APPROVED> "Not a MISRA-C:2004 violation"*/
559 typedef boolean (* send_recieve_data) (const uint16 * const u16TransmitData,const uint32 u32TransmitSize,volatile uint16* u16RecieveData,uint32 * u32RecieveSize);
568 /*SAFETYMCUSW 298 S <APPROVED> "Not a MISRA-C:2004 violation"*/
569 typedef boolean (*GetTPSDiagosticPinSampledData) (uint16* u16Data);
578 /*SAFETYMCUSW 298 S <APPROVED> "Not a MISRA-C:2004 violation"*/
579 typedef boolean (* SendDebugText) (const uint8 * const u8textbuf,const uint32 u8textlength);
580
588 #define TPS_DEVICE_STANDBY ((uint8)0x0U)
589 #define TPS_DEVICE_RESET ((uint8)0x3U)
590 #define TPS_DEVICE_DIAGNOSTIC ((uint8)0x7U)
591 #define TPS_DEVICE_ACTIVE ((uint8)0x5U)
592 #define TPS_DEVICE_SAFE ((uint8)0x4U)
600 typedef struct _TPS_WatchdoConfiguration
601 {
602 TPS_WatchdogMode watchdog_mode;
603 boolean blwatchdog_reset;
604 uint8 u8TokenSeed;
605 uint8 u8TokenFDBK;
606 uint8 u8open_windowtime_scaler;
608 uint8 u8close_windowtime_scaler;
610 }TPS_WatchdoConfiguration;
611
617 typedef struct _TPS_Initilization_struct {
618 send_recieve_data send_recieve_data_TPS;
619 GetTPSDiagosticPinSampledData GetTPSDiagPinSampledValue;
621 boolean blbist_at_startup;
622 boolean blenable_drv_op;
623 boolean blerror_pin_monitoring;
624 boolean blignition_power_latch;
625 boolean blNRES_Monitoring;
626 boolean blsafe_state_timeout;
627 uint8 u8safe_lock_threshhold;
628 uint8 u8pwd_threshhold_value;
629 uint8 u8safe_state_timeout_scaler;
632 TPS_ErrorPinMonitoringMode error_pin_monitoring_mode;
633 TPS_ERRORPinPWMWidthScaler error_pin_pwm_width;
637 TPS_DevCfg_reg_settings dev_configreg_settings;
639 TPS_AllVoltageRailLimits AMUXVoltageRailLimits;
641 }TPS_Initilization_struct;
642
643 #endif /* TPS_TYPES_H_ */
UNLOCK
Definition: Tps_Types.h:162
WD_TOKEN_RESP1
Definition: Tps_Types.h:509
VCP12_NUV
Definition: Tps_Types.h:278
ERROR_PIN_MODE
Definition: Tps_Types.h:123
_TPS_WatchdogWindows
_TPS_WatchdogWindows
Definition: Tps_Types.h:464
TPS_SAFETY_STAT_4
Definition: Tps_Types.h:65
ABIST
Definition: Tps_Types.h:199
QANDA_MODE
Definition: Tps_Types.h:142
VSOUT_UVN
Definition: Tps_Types.h:324
INFO
Definition: Tps_Types.h:546
SYS_CLK
Definition: Tps_Types.h:291
TPS_ABIST_Result
ABIST result information to be used with TPS_GetABISTTestStatus API.
DIAG_EXIT
Definition: Tps_Types.h:111
BG_ERR1
Definition: Tps_Types.h:276
TPS_SAFETY_STAT_5
Definition: Tps_Types.h:66
VSOUT_ILIM
Definition: Tps_Types.h:323
DEBUG
Definition: Tps_Types.h:544
_TPS_DeviceConfigRegisterSettings
_TPS_DeviceConfigRegisterSettings
Definition: Tps_Types.h:173
VSFB1
Definition: Tps_Types.h:248
ERROR_PIN_MONITORING
Definition: Tps_Types.h:108
CFG_CRC
Definition: Tps_Types.h:105
TEST_PASS
Definition: Tps_Types.h:95
RST_EXT_CLK
Definition: Tps_Types.h:294
_TPS_Registers
_TPS_Registers
Definition: Tps_Types.h:53
BG_ERR2
Definition: Tps_Types.h:277
POST_RUN_RST
Definition: Tps_Types.h:178
SPI_SDI
Definition: Tps_Types.h:301
TPS_VoltageRailLimits
TPS_VoltageRailLimits structure is used to represent the maximum,minmum and typical voltage value fo...
LOCK
Definition: Tps_Types.h:161
VDD1_OV
Definition: Tps_Types.h:288
MASK_VBAT_OV
Definition: Tps_Types.h:177
TPS_SAFETY_PWD_THR_CFG
Definition: Tps_Types.h:74
TPS_DeviceInformation
The structure will contain the device information such as device revision,device id.
TPS_SAFETY_CFG_CRC
Definition: Tps_Types.h:75
TPS_SENS_CTRL
Definition: Tps_Types.h:84
TPS_SAFETY_CHECK_CTRL
Definition: Tps_Types.h:69
VDD6_OV
Definition: Tps_Types.h:282
RSV5
Definition: Tps_Types.h:328
TPS_SAFETY_ERR_PWM_H
Definition: Tps_Types.h:72
TPS_OverallVMONStatus
TPS_OverallVMONStatus structure is used api TPS_GetVMONStatus and it is used for recording the compl...
TPS_ERRORPinPWMWidthScaler
TPS_ERRORPinPWMWidthScaler structure to be used with TPS_ConfigureErrorMonitoring API...
_TPS_SafetyBISTControlRegisterSettings
_TPS_SafetyBISTControlRegisterSettings
Definition: Tps_Types.h:187
NO_ERROR
Definition: Tps_Types.h:521
WD_TOKEN_RESP2
Definition: Tps_Types.h:508
TPS_SAFETY_FUNC_CFG
Definition: Tps_Types.h:70
OVER
Definition: Tps_Types.h:223
send_recieve_data
boolean(* send_recieve_data)(const uint16 *const u16TransmitData, const uint32 u32TransmitSize, volatile uint16 *u16RecieveData, uint32 *u32RecieveSize)
Definition for transmit_recieve_data data API, which is provided by the user application.
Definition: Tps_Types.h:559
TPS_VMON_STAT_1
Definition: Tps_Types.h:60
TPS_Initilization_struct
TPS Initialization struct to be used with TPS_Init API.
AUTO_BIST
Definition: Tps_Types.h:189
ERROR
Definition: Tps_Types.h:545
TPS_DEV_CFG1
Definition: Tps_Types.h:58
LOCLK
Definition: Tps_Types.h:289
_TPS_SafetyCheckControl
_TPS_SafetyCheckControl
Definition: Tps_Types.h:104
_TPS_VDD_3_5_SEL
_TPS_VDD_3_5_SEL
Definition: Tps_Types.h:150
VCP12_OV
Definition: Tps_Types.h:279
TPS_DIAG_CFG_CTRL
Definition: Tps_Types.h:76
TPS_WDT_STATUS
Definition: Tps_Types.h:82
TPS_VMON_STAT_2
Definition: Tps_Types.h:61
CP_UVN
Definition: Tps_Types.h:310
VDD5_OV
Definition: Tps_Types.h:284
CP_OV
Definition: Tps_Types.h:309
VDD6_NUV
Definition: Tps_Types.h:281
SEL_3_3V
Definition: Tps_Types.h:152
_TPS_AMUXSignals
_TPS_AMUXSignals
Definition: Tps_Types.h:244
DMUX_VDD5_OT
Definition: Tps_Types.h:317
TPS_DEV_ID
Definition: Tps_Types.h:56
VBAT_SAFING
Definition: Tps_Types.h:249
TPS_SW_UNLOCK
Definition: Tps_Types.h:86
VBATP_OV
Definition: Tps_Types.h:316
_TPS_ErrorPinMonitoringMode
_TPS_ErrorPinMonitoringMode
Definition: Tps_Types.h:121
DVDD_UV
Definition: Tps_Types.h:326
DFT1
Definition: Tps_Types.h:292
TPS_WatchdoConfiguration
TPS watchdog configuration to be used with TPS_WatcdogInit API.
T_15US
Definition: Tps_Types.h:296
SPI_NCS
Definition: Tps_Types.h:300
SEL_5V
Definition: Tps_Types.h:151
DIAG_EXIT_MASK
Definition: Tps_Types.h:109
SPI_CLK
Definition: Tps_Types.h:302
_TPS_SPIErrorType
_TPS_SPIErrorType
Definition: Tps_Types.h:519
VS_TRK_MODE
Definition: Tps_Types.h:329
TPS_SAFETY_STAT_2
Definition: Tps_Types.h:63
WDTI_MODE
Definition: Tps_Types.h:141
RSV2
Definition: Tps_Types.h:290
VCP
Definition: Tps_Types.h:247
TEST_FAIL
Definition: Tps_Types.h:94
TPS_DEV_CFG2
Definition: Tps_Types.h:59
COMMAND_ERROR
Definition: Tps_Types.h:522
DFT4
Definition: Tps_Types.h:314
VBAT_UVN
Definition: Tps_Types.h:315
VDD5
Definition: Tps_Types.h:245
VSOUT_OT
Definition: Tps_Types.h:319
PWM_MONITORING_MODE
Definition: Tps_Types.h:122
UC_ERROR_WDI
Definition: Tps_Types.h:299
SDO_RDBCK
Definition: Tps_Types.h:303
VDD5_CL
Definition: Tps_Types.h:320
TPS_WDT_TOKEN_FDBCK
Definition: Tps_Types.h:78
_TPS_BistTypes
_TPS_BistTypes
Definition: Tps_Types.h:198
VMON_BG
Definition: Tps_Types.h:252
TPS_DebugSeverity
TPS_DebugSeverity
Enumerations debug message severity.
Definition: Tps_Types.h:542
TPS_WDT_ANSWER
Definition: Tps_Types.h:83
RSV3
Definition: Tps_Types.h:306
TPS_WDFaultType
TPS_WDFaultType
Enumerations indicating the Watchdog fault type to be injected.
Definition: Tps_Types.h:532
TPS_SAFETY_ERR_PWM_L
Definition: Tps_Types.h:73
_TPS_HandleConfigurationRegisters
_TPS_HandleConfigurationRegisters
Definition: Tps_Types.h:160
_TPS_Test_Result
_TPS_Test_Result
Definition: Tps_Types.h:93
RSV4
Definition: Tps_Types.h:322
FORMAT_ERROR
Definition: Tps_Types.h:523
EE_CRC_CHK
Definition: Tps_Types.h:188
TPS_SAFETY_ERR_CFG
Definition: Tps_Types.h:67
CP_PH1
Definition: Tps_Types.h:311
VDD3_5_NUV
Definition: Tps_Types.h:285
MAIN_BG
Definition: Tps_Types.h:251
SendDebugText
boolean(* SendDebugText)(const uint8 *const u8textbuf, const uint32 u8textlength)
Definition for send debug text API, which is provided by the user application.
Definition: Tps_Types.h:579
AVDD_UVN
Definition: Tps_Types.h:275
CP_DIFF3V
Definition: Tps_Types.h:313
WD_TOKEN_RESP3
Definition: Tps_Types.h:507
TPS_WatchdogWindows
TPS watchdog open and close window configuration to be used with TPS_ConfigureWatchdogWindows API...
TPS_DIAG_MUX_SEL
Definition: Tps_Types.h:77
TPS_DEV_REV
Definition: Tps_Types.h:55
T_2MS
Definition: Tps_Types.h:298
TPS_WDT_TOKEN_VALUE
Definition: Tps_Types.h:81
TPS_SAFETY_STAT_1
Definition: Tps_Types.h:62
VDD3_CL
Definition: Tps_Types.h:321
VDD1_NUV
Definition: Tps_Types.h:287
TPS_SAFETY_ERR_STAT
Definition: Tps_Types.h:71
NRST_EXT_IN
Definition: Tps_Types.h:305
RUNNING
Definition: Tps_Types.h:224
T_5US
Definition: Tps_Types.h:295
MASK_VDD1_UV
Definition: Tps_Types.h:174
VCP17_OV
Definition: Tps_Types.h:280
WDT_CLK
Definition: Tps_Types.h:293
_TPS_TestRunningStatus
_TPS_TestRunningStatus
Definition: Tps_Types.h:222
TPS_DevCfg_reg_settings
structure which can store the TPS device configuration register settings this structure updated with ...
VDD3_5_OV
Definition: Tps_Types.h:286
DMUX_VDD3_5_OT
Definition: Tps_Types.h:318
DFT2
Definition: Tps_Types.h:307
RSV1
Definition: Tps_Types.h:274
UC_ERROR_WDI_RED
Definition: Tps_Types.h:304
TPS_SW_LOCK
Definition: Tps_Types.h:85
LBIST
Definition: Tps_Types.h:200
_TPS_WDResponse
_TPS_WDResponse
Definition: Tps_Types.h:505
TPS_CRCErrorStatus
The structure will contain the data regarding the CRC error in config registers/EEPROM.
CLOSE_WINDOW
Definition: Tps_Types.h:466
TPS_SAFETY_BIST_CTRL
Definition: Tps_Types.h:68
TPS_SAFETY_STAT_3
Definition: Tps_Types.h:64
TPS_VMONStatus
TPS_VMONStatus structure is used for recording the Over voltage and under voltage state of the of vo...
DATA_OP_MISMATCH
Definition: Tps_Types.h:524
WD_TOKEN_RESP0
Definition: Tps_Types.h:510
CP_PH2
Definition: Tps_Types.h:312
TPS_WDT_WIN1_CFG
Definition: Tps_Types.h:79
TPS_WDT_WIN2_CFG
Definition: Tps_Types.h:80
TPS_DEV_STAT
Definition: Tps_Types.h:57
VDD5_NUV
Definition: Tps_Types.h:283
VDD3_5_OT
Definition: Tps_Types.h:175
_TPS_WatchdogMode
_TPS_WatchdogMode
Definition: Tps_Types.h:140
T_40US
Definition: Tps_Types.h:297
DRV_OUTPUT
Definition: Tps_Types.h:107
TPS_DeviceState
The structure will contain the device state information such as latched CAN wake-up and deglitched IG...
DVDD_OV
Definition: Tps_Types.h:327
VMON_TRIM_ER
Definition: Tps_Types.h:330
BAD_ANSWER
Definition: Tps_Types.h:534
VDD5_OT
Definition: Tps_Types.h:176
VDD6
Definition: Tps_Types.h:246
DFT3
Definition: Tps_Types.h:308
OPEN_WINDOW
Definition: Tps_Types.h:465
VSOUT_OV
Definition: Tps_Types.h:325
TPS_AllVoltageRailLimits
TPS_AllVoltageRailLimits structure is updated on TPS_Init and the structure is used for storing the ...
VBAT
Definition: Tps_Types.h:250
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: D:/MCU_SafeTI_Lib/safety-mcu-safetylibrary-new/TPS_Driver/source/Tps_priv.h Source File

  • TPS_Driver
  • source
Tps_priv.h
Go to the documentation of this file.
1
39 #ifndef TPS_PRIV_H_
40 #define TPS_PRIV_H_
41
42 /***************************************************************
43 * INCLUDE FILES
44 ****************************************************************/
45 #include "Tps_Config.h"
46 /*********************************************************
47 Defines / data types / structs / unions /enums
48 **********************************************************/
49 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
50 #define BIT(n) ((1u <<(n)))
51
52 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
53 #define BITU8(n) ((uint8)(((uint8)1u) <<(n)))
54
55 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
56 #define BITU32(n) ((uint32)((((uint32)1u) <<(n))))
57
58 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
59 #define BIT_GET(y,n) (((y)>>(n)) & 0x1u)
60
61 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
62 #define BIT_SET(y, mask) ((y) |= (mask))
63
64 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
65 #define BIT_CLEAR(y, mask) ((y) &= ~(mask))
66
67 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
68 #define BIT_FLIP(y, mask) ((y) ^= (mask))
69
70
71 /* Create a bitmask of length \a len.*/
72 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
73 #define BIT_MASK(len) (BIT(len)-1u)
74
75 /* Create a bitmask of length \a len.*/
76 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
77 #define BITU8_MASK(len) ((uint8)((BITU8(len))-((uint8)1u)))
78
79
80 /* Create a bitmask of length \a len.*/
81 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
82 #define BITU32_MASK(len) ((uint32)(BITU32(len)-((uint32)1u)))
83
84 /* Create a bitfield mask of length \a starting at bit \a start.*/
85 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
86 #define BF_MASK(start, len) (BIT_MASK(len)<<(start))
87
88 /* Create a bitfield mask of length \a starting at bit \a start.*/
89 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
90 #define BFU8_MASK(start, len) ((uint8)(BITU8_MASK(len)<<(start)))
91
92 /* Create a bitfield mask of length \a starting at bit \a start.*/
93 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
94 #define BFU32_MASK(start, len) ((uint32)(BITU32_MASK(len)<<(start)))
95
96 /* Prepare a bitmask for insertion or combining.*/
97 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
98 #define BF_PREP(x, start, len) (((x)&BIT_MASK(len)) << (start))
99
100 /* Prepare a bitmask for insertion or combining.*/
101 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
102 #define BFU8_PREP(x, start, len) ((uint8)((uint8)((x)&BITU8_MASK(len)) << (start)))
103
104
105 /* Prepare a bitmask for insertion or combining.*/
106 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
107 #define BFU32_PREP(x, start, len) ((uint32)((uint32)((x)&BITU32_MASK(len)) << (start)))
108
109 /* Extract a bitfield of length \a len starting at bit \a start from \a y.
110 * y is the register
111 * start is the starting bit of the field
112 * len is the length of the field*/
113 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
114 #define BF_GET(y, start, len) (((((y)>>(start))) & BIT_MASK(len)))
115
116 /* Extract a bitfield of length \a len starting at bit \a start from \a y.
117 * y is the register
118 * start is the starting bit of the field
119 * len is the length of the field*/
120 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
121 #define BFU8_GET(y, start, len) ((uint8)((((uint8)((y)>>(start))) & BITU8_MASK(len))))
122
123 /* Extract a bitfield of length \a len starting at bit \a start from \a y.
124 * y is the register
125 * start is the starting bit of the field
126 * len is the length of the field*/
127 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
128 #define BFU32_GET(y, start, len) ((uint32)((((uint32)((y)>>(start))) & BIT_MASK(len))))
129
130 /*Insert a new bitfield value \a x into \a y.
131 * y is the register
132 * x is the value of the field
133 * start is the starting bit of the field
134 * len is the length of the field*/
135 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
136 #define BF_SET(y, x, start, len) \
137 ( (y) = (uint8)(((y) & (uint8)(~(BF_MASK((start),(len))))) | (uint8)BF_PREP((x),(start),(len))))
138
139 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
140 #define BFU8_SET(y, x, start, len) \
141 ( (y) = (uint8)(((y) & ((uint8)(((uint8)~(BFU8_MASK((start),(len))))))) | ((uint8)BFU8_PREP((x),(start),(len)))))
142
143 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
144 #define BFU32_SET(y, x, start, len) \
145 ( (y) = (uint32)(((y) & ((uint32)(((uint32)~(BFU32_MASK((start),(len))))))) | ((uint32)BFU32_PREP((x),(start),(len)))))
146
147 /* change the order of the bytes so that it is easy to calculate the CRC, 0xABCDEFGH ->0xGHEFDCBA*/
148 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
149 #define CHANGE_BYTE_ORDER(x) ((((x) & 0xFFU) << 24U) + (((x) & 0xFF00U) << 8U)\
150 + (((x) & 0xFF0000U) >> 8U)+ (((x) >> 24U) & 0xFFU))
151
152
153 /*Bit fields CRC High byte*/
154 #define BF_DST_SAFETY_FUNC_CFG_START ((uint8)25U)
155 #define BF_SRC_SAFETY_FUNC_CFG_START ((uint8)0U)
156 #define BF_SAFETY_FUNC_CFG_LENGTH ((uint8)7u)
157
158 #define BF_DST_DEV_REV_START ((uint8)17U)
159 #define BF_SRC_DEV_REV_START ((uint8)0U)
160 #define BF_DEV_REV_LENGTH ((uint8)8u)
161
162 #define BF_DST_SAFETY_PWD_THR_CFG_START ((uint8)13U)
163 #define BF_SRC_SAFETY_PWD_THR_CFG_START ((uint8)0U)
164 #define BF_SAFETY_PWD_THR_CFG_LENGTH ((uint8)4u)
165
166 #define BF_DST_SAFETY_ERR_CFG_START ((uint8)5U)
167 #define BF_SRC_SAFETY_ERR_CFG_START ((uint8)0U)
168 #define BF_SAFETY_ERR_CFG_LENGTH ((uint8)8u)
169
170 #define BF_DST_EDT_TOK_FBACK_7_3_START ((uint8)0U)
171 #define BF_SRC_EDT_TOK_FBACK_7_3_START ((uint8)3U)
172 #define BF_EDT_TOKEN_FDBACK_7_3_LENGTH ((uint8)5u)
173 /*Bit fields CRC low byte*/
174 #define BF_DST_EDT_TOK_FBACK_2_0_START ((uint8)29U)
175 #define BF_SRC_EDT_TOK_FBACK_2_0_START ((uint8)0U)
176 #define BF_EDT_TOKEN_FDBACK_2_0_LENGTH ((uint8)3u)
177
178 #define BF_DST_WDT_WIN2_CFG_START ((uint8)24U)
179 #define BF_SRC_WDT_WIN2_CFG_START ((uint8)0U)
180 #define BF_WDT_WIN2_CFG_LENGTH ((uint8)5u)
181
182 #define BF_DST_WDT_WIN1_CFG_START ((uint8)17U)
183 #define BF_SRC_WDT_WIN1_CFG_START ((uint8)0U)
184 #define BF_WDT_WIN1_CFG_LENGTH ((uint8)7u)
185
186 #define BF_DST_SAFETY_ERR_PWM_L_START ((uint8)9U)
187 #define BF_SRC_SAFETY_ERR_PWM_L_START ((uint8)0U)
188 #define BF_SAFETY_ERR_PWM_L_LENGTH ((uint8)8u)
189
190 #define BF_DST_DEV_CFG2_START ((uint8)1U)
191 #define BF_SRC_DEV_CFG2_START ((uint8)0U)
192 #define BF_DEV_CFG2_LENGTH ((uint8)8U)
193
194 #define BF_DST_DEV_CFG1_START ((uint8)0u)
195 #define BF_SRC_DEV_CFG1_START ((uint8)6u)
196 #define BF_DEV_CFG1_LENGTH ((uint8)1u)
197
198 /*Bit field safety check control register*/
199 #define BF_CFG_CRC_ENABLE_START ((uint8)7U)
200 #define BF_CFG_CRC_ENABLE_LENGTH ((uint8)1U)
201
202 #define BF_ENABLE_DRV_START ((uint8)5U)
203 #define BF_ENABLE_DRV_LENGTH ((uint8)1U)
204
205 #define BF_NO_ERROR_START ((uint8)2U)
206 #define BF_NO_ERROR_LENGTH ((uint8)1U)
207
208 #define BF_DIAG_EXIT_MASK_START ((uint8)1U)
209 #define BF_DIAG_EXIT_MASK_LENGTH ((uint8)1U)
210
211 #define BF_DIAG_EXIT_START ((uint8)0U)
212 #define BF_DIAG_EXIT_LENGTH ((uint8)1U)
213
214
215 /*Bit field safety function config register*/
216 #define BF_NO_SAFE_TO_START ((uint8)7U)
217 #define BF_NO_SAFE_TO_LENGTH ((uint8)1U)
218
219 #define BF_ERROR_CFG_START ((uint8)6U)
220 #define BF_ERROR_CFG_LENGTH ((uint8)1U)
221
222 #define BF_WD_CFG_START ((uint8)5U)
223 #define BF_WD_CFG_LENGTH ((uint8)1U)
224
225 #define BF_WD_RST_EN_START ((uint8)3U)
226 #define BF_WD_RST_EN_LENGTH ((uint8)1U)
227
228 #define BF_IGN_PWRL_START ((uint8)4U)
229 #define BF_IGN_PWRL_LENGTH ((uint8)1U)
230
231 #define BF_DIS_NRES_MON_START ((uint8)2U)
232 #define BF_DIS_NRES_MON_LENGTH ((uint8)1U)
233
234 #define BF_VDD_3_5_SEL_START ((uint8)0U)
235 #define BF_VDD_3_5_SEL_LENGTH ((uint8)1U)
236
237
238 /*Bit field SAFETY_ERR_CFG register*/
239 #define BF_SAFE_TO_START ((uint8)5U)
240 #define BF_SAFE_TO_LENGTH ((uint8)3U)
241
242 #define BF_SAFE_LOCK_THR_START ((uint8)1U)
243 #define BF_SAFE_LOCK_THR_LENGTH ((uint8)4U)
244
245 /*Bit field DEV_CFG1 register*/
246 #define BF_nMASK_VDD1_UV_OV_START ((uint8)6U)
247 #define BF_nMASK_VDD1_UV_OV_LENGTH ((uint8)1U)
248
249
250 /*Bit field DEV_CFG2 register*/
251 #define BF_EN_VDD3_5_OT_START ((uint8)7U)
252 #define BF_EN_VDD3_5_OT_LENGTH ((uint8)1U)
253
254 #define BF_EN_VDD5_OT_START ((uint8)6U)
255 #define BF_EN_VDD5_OT_LENGTH ((uint8)1U)
256
257 #define BF_MASK_VBAT_OV_START ((uint8)5U)
258 #define BF_MASK_VBAT_OV_LENGTH ((uint8)1U)
259
260 #define BF_POST_RUN_RST_START ((uint8)4U)
261 #define BF_POST_RUN_RST_LENGTH ((uint8)1U)
262
263
264 /*Bit field SAFETY_ERR_CFG register*/
265 #define BF_CFG_LOCK_START ((uint8)0U)
266 #define BF_CFG_LOCK_LENGTH ((uint8)1U)
267
268
269 /*Bit field SAFETY_ERR_STAT register*/
270 #define BF_DEV_ERR_CNT_START ((uint8)0U)
271 #define BF_DEV_ERR_CNT_LENGTH ((uint8)4U)
272
273 #define BF_WD_FAIL_START ((uint8)4U)
274 #define BF_WD_FAIL_LENGTH ((uint8)1U)
275
276 #define BF_ERROR_PIN_FAIL_START ((uint8)5U)
277 #define BF_ERROR_PIN_FAIL_LENGTH ((uint8)1U)
278
279 /*Bit field WDT_TOKEN_VALUE register*/
280 #define BF_WDT_TOKEN_VALUE_START ((uint8)0U)
281 #define BF_WDT_TOKEN_VALUE_LENGTH ((uint8)4U)
282
283
284 /*Bit field WDT_STATUS register*/
285 #define BF_WDT_ANSW_CNT_START ((uint8)6U)
286 #define BF_WDT_ANSW_CNT_LENGTH ((uint8)2U)
287
288 #define BF_WDT_TOKEN_ERR_START ((uint8)5U)
289 #define BF_WDT_TOKEN_ERR_LENGTH ((uint8)1U)
290
291 #define BF_WDT_WRONG_CFG_START ((uint8)4U)
292 #define BF_WDT_WRONG_CFG_LENGTH ((uint8)1U)
293
294 #define BF_WDT_SEQ_ERR_START ((uint8)2U)
295 #define BF_WDT_SEQ_ERR_LENGTH ((uint8)1U)
296
297 #define BF_WDT_TIME_OUT_START ((uint8)1U)
298 #define BF_WDT_TIME_OUT_LENGTH ((uint8)1U)
299
300 #define BF_WDT_TOKEN_EARLY_START ((uint8)0U)
301 #define BF_WDT_TOKEN_EARLY_LENGTH ((uint8)1U)
302
303
304 /*Bit field SAFETY_STAT_2 register*/
305 #define BF_WDT_FAIL_CNT_START ((uint8)0U)
306 #define BF_WDT_FAIL_CNT_LENGTH ((uint8)3U)
307
308 #define BF_CFG_CRC_ERR_START ((uint8)5U)
309 #define BF_CFG_CRC_ERR_LENGTH ((uint8)1U)
310
311 #define BF_EE_CRC_ERR_START ((uint8)4U)
312 #define BF_EE_CRC_ERR_LENGTH ((uint8)1U)
313
314
315 /*Bit field SAFETY_STAT_3 register*/
316 #define BF_ABIST_RUN_START ((uint8)0U)
317 #define BF_ABIST_RUN_LENGTH ((uint8)1U)
318
319 #define BF_LBIST_RUN_START ((uint8)1U)
320 #define BF_LBIST_RUN_LENGTH ((uint8)1U)
321
322 #define BF_ABIST_UV_OV_ERR_START ((uint8)2U)
323 #define BF_ABIST_UV_OV_ERR_LENGTH ((uint8)1U)
324
325 #define BF_LBIST_ERR_START ((uint8)4U)
326 #define BF_LBIST_ERR_LENGTH ((uint8)1U)
327
328 #define BF_NRES_ERR_START ((uint8)5U)
329 #define BF_NRES_ERR_LENGTH ((uint8)1U)
330
331
332 /*Bit field SAFETY_STAT_4 register*/
333 #define BF_LOCLK_START ((uint8)5U)
334 #define BF_LOCLK_LENGTH ((uint8)1U)
335
336 #define BF_SPI_ERR_START ((uint8)6U)
337 #define BF_SPI_ERR_LENGTH ((uint8)2U)
338
339 #define BF_VMON_TRIM_ERR_START ((uint8)0U)
340 #define BF_VMON_TRIM_ERR_LENGTH ((uint8)1U)
341
342 #define BF_ENDRV_ERR_START ((uint8)1U)
343 #define BF_ENDRV_ERR_LENGTH ((uint8)1U)
344
345 /*values of the bit field SPI_ERR*/
346 #define NO_ERROR 0x0u
347 #define COMMAND_ERROR 0x1u
348 #define FORMAT_ERROR 0x2u
349 #define DATA_OUTPUT_MISMATCH 0x3u
350
351
352 /*Bit field SAFETY_BIST_CTRL register*/
353 #define BF_AUTO_BIST_DIS_START ((uint8)5U)
354 #define BF_AUTO_BIST_DIS_LENGTH ((uint8)1U)
355
356 #define BF_EE_CRC_CHK_START ((uint8)4U)
357 #define BF_EE_CRC_CHK_LENGTH ((uint8)1U)
358
359 #define BF_LBIST_EN_START ((uint8)2U)
360 #define BF_LBIST_EN_LENGTH ((uint8)1U)
361
362 #define BF_ABIST_EN_START ((uint8)1U)
363 #define BF_ABIST_EN_LENGTH ((uint8)1U)
364
365
366 /*Bit field SAFETY_PWD_THR_CFG register*/
367 #define BF_PWD_THR_START ((uint8)0U)
368 #define BF_PWD_THR_LENGTH ((uint8)4U)
369
370 /*Bit field WDT_TOKEN_FDBCK register*/
371 #define BF_TOKEN_SEED_START ((uint8)0U)
372 #define BF_TOKEN_SEED_LENGTH ((uint8)4U)
373
374 #define BF_TOKEN_FDBK_START ((uint8)4U)
375 #define BF_TOKEN_FDBK_LENGTH ((uint8)4U)
376
377 /*Bit field WDT_WIN1_CFG register*/
378 #define BF_WD_OPEN_WINDOW_SCALER_START ((uint8)0U)
379 #define BF_WD_OPEN_WINDOW_SCALER_LENGTH ((uint8)7U)
380 #define BF_WD_CLOSE_WINDOW_SCALER_START ((uint8)0U)
381 #define BF_WD_CLOSE_WINDOW_SCALER_LEN ((uint8)5U)
382
383 /*Bit field DIAG_CFG_CTRL register*/
384 #define BF_MUX_EN_START ((uint8)7U)
385 #define BF_MUX_EN_LENGTH ((uint8)1U)
386
387 #define BF_SPI_SDO_START ((uint8)6U)
388 #define BF_SPI_SDO_LENGTH ((uint8)1U)
389
390 #define BF_MUX_OUT_START ((uint8)5U)
391 #define BF_MUX_OUT_LENGTH ((uint8)1U)
392
393 #define BF_INT_CON_START ((uint8)2U)
394 #define BF_INT_CON_LENGTH ((uint8)3U)
395
396 #define BF_MUX_CFG_START ((uint8)0U)
397 #define BF_MUX_CFG_LENGTH ((uint8)2U)
398
399 /*Bit field SENS_CTRL register*/
400 #define BF_VDD5_EN_START ((uint8)4U)
401 #define BF_VDD5_EN_LENGTH ((uint8)1U)
402
403 #define BF_VSOUT1_EN_START ((uint8)0U)
404 #define BF_VSOUT1_EN_LENGTH ((uint8)1U)
405
406
407 /*Bit field DEV_REV register*/
408 #define BF_MINOR_VERSION_START ((uint8)0U)
409 #define BF_MINOR_VERSION_LENGTH ((uint8)4U)
410
411 #define BF_MAJOR_VERSION_START ((uint8)4U)
412 #define BF_MAJOR_VERSION_LENGTH ((uint8)4U)
413
414 /*Bit field VMON_STAT_2 Register*/
415 #define BF_VDD6_OV_START ((uint8)7U)
416 #define BF_VDD6_OV_LENGTH ((uint8)1U)
417
418 #define BF_VDD6_UV_START ((uint8)6U)
419 #define BF_VDD6_UV_LENGTH ((uint8)1U)
420
421 #define BF_VDD5_OV_START ((uint8)5U)
422 #define BF_VDD5_OV_LENGTH ((uint8)1U)
423
424 #define BF_VDD5_UV_START ((uint8)4U)
425 #define BF_VDD5_UV_LENGTH ((uint8)1U)
426
427 #define BF_VDD3_5_OV_START ((uint8)3U)
428 #define BF_VDD3_5_OV_LENGTH ((uint8)1U)
429
430 #define BF_VDD3_5_UV_START ((uint8)2U)
431 #define BF_VDD3_5_UV_LENGTH ((uint8)1U)
432
433 #define BF_VDD1_OV_START ((uint8)1U)
434 #define BF_VDD1_OV_LENGTH ((uint8)1U)
435
436 #define BF_VDD1_UV_START ((uint8)0U)
437 #define BF_VDD1_UV_LENGTH ((uint8)1U)
438
439 /*Bit field VMON_STAT_1 Register*/
440 #define BF_VBATP_OV_START ((uint8)7U)
441 #define BF_VBATP_OV_LENGTH ((uint8)1U)
442
443 #define BF_VBATP_UV_START ((uint8)6U)
444 #define BF_VBATP_UV_LENGTH ((uint8)1U)
445
446 #define BF_VCP17_OV_START ((uint8)5U)
447 #define BF_VCP17_OV_LENGTH ((uint8)1U)
448
449 #define BF_VCP12_OV_START ((uint8)4U)
450 #define BF_VCP12_OV_LENGTH ((uint8)1U)
451
452 #define BF_VCP12_UV_START ((uint8)3U)
453 #define BF_VCP12_UV_LENGTH ((uint8)1U)
454
455 #define BF_AVDD_VMON_ERR_START ((uint8)2U)
456 #define BF_AVDD_VMON_ERR_LENGTH ((uint8)1U)
457
458 #define BF_BG2_ERR_START ((uint8)1U)
459 #define BF_BG2_ERR_LENGTH ((uint8)1U)
460
461 #define BF_BG1_ERR_START ((uint8)0U)
462 #define BF_BG1_ERR_LENGTH ((uint8)1U)
463
464
465 /*Bit field SAFETY_STAT_1 Register*/
466 #define BF_VDD5_ILIM_START ((uint8)7U)
467 #define BF_VDD5_ILIM_LENGTH ((uint8)1U)
468
469 #define BF_VDD3_5_ILIM_START ((uint8)6U)
470 #define BF_VDD3_5_ILIM_LENGTH ((uint8)1U)
471
472 #define BF_VSOUT1_UV_START ((uint8)5U)
473 #define BF_VSOUT1_UV_LENGTH ((uint8)1U)
474
475 #define BF_VSOUT1_OV_START ((uint8)4U)
476 #define BF_VSOUT1_OV_LENGTH ((uint8)1U)
477
478 #define BF_VSOUT1_ILIM_START ((uint8)3U)
479 #define BF_VSOUT1_ILIM_LENGTH ((uint8)1U)
480
481 #define BF_VSOUT1_OT_START ((uint8)2U)
482 #define BF_VSOUT1_OT_LENGTH ((uint8)1U)
483
484 #define BF_VDD5_OT_START ((uint8)1U)
485 #define BF_VDD5_OT_LENGTH ((uint8)1U)
486
487 #define BF_VDD3_5_OT_START ((uint8)0U)
488 #define BF_VDD3_5_OT_LENGTH ((uint8)1U)
489
490
491 /*Bit field DEV_STAT Register*/
492 #define BF_CANWU_L_START ((uint8)1U)
493 #define BF_CANWU_L_LENGTH ((uint8)1U)
494
495 #define BF_IGN_START ((uint8)0U)
496 #define BF_IGN_LENGTH ((uint8)1U)
497
498
499
500
501 /*values for the bit field MUX_CFG*/
502 #define MUX_OUT_CONTROLLED 0x0u
503 #define DIGITAL_MUX 0x1u
504 #define ANALOG_MUX 0x2u
505 #define DEVICE_INTERCONNECT_MODE 0x3u
506
507 /*values for the bit field INT_CON*/
508 #define NO_INTERCONNECT_TEST 0x0U
509
510 /*limits for the maximum value of some register fields of TPS*/
511 #define OPEN_WINDOW_SCALER_MAX 0x7FU
512 #define CLOSE_WINDOW_SCALER_MAX 0x1FU
513 #define PWD_THRESHHOLD_MAX 0x0FU
514 #define SAFE_STATE_TIMEOUT_MAX 0x07U
515 #define SAFE_LOCK_THRESHHOLD_MAX 0x0FU
516 #define TOKEN_SEED_MAX 0xFU
517 #define TOKEN_SEED_MIN 0x0U
518 #define TOKEN_FDBCK_MAX 0xFU
519 #define TOKEN_FDBCK_MIN 0x0U
520
521 /*Include and typedefs and enums used by TPS_Interface.c*/
527 #define RD_COMMAND_NONE ((uint16)0x0000U)
528 #define RD_WD_WIN2_CFG ((uint16)0x0500U)
529 #define RD_DEV_ID ((uint16)0x0600U)
530 #define RD_DEV_REV ((uint16)0x0C00U)
531 #define RD_DEV_STAT ((uint16)0x1100U)
532 #define RD_VMON_STAT_1 ((uint16)0x1200U)
533 #define RD_SAFETY_STAT_1 ((uint16)0x2400U)
534 #define RD_WD_WIN1_CFG ((uint16)0x2E00U)
535 #define RD_SAFETY_ERR_CFG ((uint16)0x3000U)
536 #define RD_WDT_TOKEN_VALUE ((uint16)0x3600U)
537 #define RD_SAFETY_PWD_THR_CFG ((uint16)0x3900U)
538 #define RD_SAFETY_FUNC_CFG ((uint16)0x3A00U)
539 #define RD_SAFETY_BIST_CTRL ((uint16)0x3C00U)
540 #define RD_SAFETY_CHECK_CTRL ((uint16)0x4400U)
541 #define RD_DEV_CFG2 ((uint16)0x4800U)
542 #define RD_WDT_STATUS ((uint16)0x4E00U)
543 #define RD_SENS_CTRL ((uint16)0x5600U)
544 #define RD_SAFETY_ERR_PWM_L ((uint16)0x5900U)
545 #define RD_SAFETY_CFG_CRC ((uint16)0x5A00U)
546 #define RD_WDT_TOKEN_FDBCK ((uint16)0x7800U)
547 #define RD_SAFETY_STAT_3 ((uint16)0xA300U)
548 #define RD_SAFETY_STAT_4 ((uint16)0xA500U)
549 #define RD_VMON_STAT_2 ((uint16)0xA600U)
550 #define RD_SAFETY_ERR_STAT ((uint16)0xAA00U)
551 #define RD_DIAG_MUX_SEL ((uint16)0xAC00U)
552 #define RD_DEV_CFG1 ((uint16)0xAF00U)
553 #define RD_SAFETY_STAT_5 ((uint16)0xC000U)
554 #define RD_SAFETY_STAT_2 ((uint16)0xC500U)
555 #define RD_SAFETY_ERR_PWM_H ((uint16)0xD700U)
556 #define RD_DIAG_CFG_CTRL ((uint16)0xDD00U)
557 #define RD_WRONG_PARITY ((uint16)0x0D00U)
558 #define RD_WRONG_COMMAND ((uint16)0x2C00U)
565 #define WR_COMMAND_NONE ((uint16)0x0000U)
566 #define WR_WD_WIN2_CFG ((uint16)0x0900U)
567 #define WR_SAFETY_FUNC_CFG ((uint16)0x3500U)
568 #define WR_SAFETY_CFG_CRC ((uint16)0x6300U)
569 #define WR_WDT_TOKEN_FDBCK ((uint16)0x7700U)
570 #define WR_SENS_CTRL ((uint16)0x7B00U)
571 #define WR_CAN_STBY ((uint16)0x7D00U)
572 #define WR_SAFETY_ERR_PWM_L ((uint16)0x7E00U)
573 #define WR_SAFETY_CHECK_CTRL ((uint16)0x9300U)
574 #define WR_DEV_CFG2 ((uint16)0x9500U)
575 #define WR_SAFETY_PWD_THR_CFG ((uint16)0x9900U)
576 #define WR_DIAG_MUX_SEL ((uint16)0xC900U)
577 #define WR_SAFETY_BIST_CTRL ((uint16)0x9F00U)
578 #define WR_SAFETY_ERR_STAT ((uint16)0xA900U)
579 #define WR_DEV_CFG1 ((uint16)0xB700U)
580 #define WR_SW_UNLOCK ((uint16)0xBB00U)
581 #define WR_SW_LOCK ((uint16)0xBD00U)
582 #define WR_DIAG_CFG_CTRL ((uint16)0xCC00U)
583 #define WR_SAFETY_ERR_PWM_H ((uint16)0xD800U)
584 #define WR_SAFETY_ERR_CFG ((uint16)0xDB00U)
585 #define WR_WDT_ANSWER ((uint16)0xE100U)
586 #define WR_WD_WIN1_CFG ((uint16)0xED00U)
588 #define TPSIF_STATUS_FLAG_RESPOSE_MASK 0xFF00U
589 #define TPSIF_DATA_MASK 0x00FFU
590 #define TPSIF_SPI_TRANSFER_ERRFLG_MASK 0xF7U
591 #define TPSIF_MULTIBITKEY_MASK 0xF7U
592
593 /*Bit Fields*/
594 #define BF_MULTIBITKEY_START ((uint8)0x4U)
595 #define BF_MULTIBITKEY_LENGTH ((uint8)0x4U)
596 #define MULTIBITKEY_SET ((uint8)0xaU)
597
598 /*Bit Fields*/
599
600 /*Device Status Flag Byte Response*/
601 #define BF_SPI_ERRFLAG_START ((uint8)0x0U)
602 #define BF_SPI_ERRFLAG_LENGTH ((uint8)0x3U)
603
604 /*Masks for various configuration registers the
605 * unused bits of registers have to not considered for readback etc.*/
606 #define SAFETY_FUNC_CFG_MASK 0xFCU
607 #define SAFETY_PWD_THR_CFG_MASK 0x0FU
608 #define DEV_CFG1_REG_MASK 0x40U
609 #define DEV_CFG2_REG_MASK 0xF0U
610 #define WDT_WIN1_CFG_MASK 0x7FU
611 #define WDT_WIN2_CFG_MASK 0x1FU
612
613 /*Data for SPI access TPS_SW_LOCK/TPS_SW_UNLOCK registers */
614 #define SW_LOCK_DATA ((uint8)0xAAU)
615 #define SW_UNLOCK_DATA ((uint8)0x55U)
616
622 typedef struct TpsIf_Command
623 {
624 uint16 Read;
625 uint16 Write;
626 } TpsIf_COMMAND_t;
627
628
629
630
631
632
633 /*SAFETYMCUSW 340 S MR:19.7 <APPROVED> "Reason - This is an advisory by MISRA.We accept this as a coding convention*/
634 #define CHECK_RANGE_RAM_PTR(x) ((((uint32)(x)) >= SRAM_START) && ((((uint32)(x)) <= ((SRAM_END-(uint32)sizeof((x)))))))
635
636 #endif /* TPS_PRIV_H_ */
TpsIf_Command::Write
uint16 Write
Definition: Tps_priv.h:625
TpsIf_Command::Read
uint16 Read
Definition: Tps_priv.h:624
Tps_Config.h
This files contains the configuration items for the the TPS Driver.
TpsIf_COMMAND_t
struct TpsIf_Command TpsIf_COMMAND_t
Tps Interface Instruction Type Definition.
Generated on Fri Feb 6 2015 03:20:39 for TPS Driver by doxygen 1.8.7


TPS Driver: Related Pages

Related Pages
Here is a list of all related documentation pages:
Configuration items
References
TPS65381 Driver API
Build
Generated on Fri Feb 6 2015 03:20:40 for TPS Driver by doxygen 1.8.7